Mutiple Hard Drive Question

By {^}RaY{^} ยท 7 replies
Feb 13, 2006
  1. Hey, this looks like a place with alot of smart people so hopefully someone knows what's wrong. Usally I'm pretty good with this kinda stuff but I can't figure out what happened. So I have recently added a new Western Digital 80GB hard drive to my computer. So I setup Windows XP Pro on it. Now I still have my old 40GB Maxtor in the computer as well as the slave. I just finished moving some files from the 80GB drive over to the 40GB drive as its just music and some files that I don't need right on the 80GB drive. Then I restarted the computer and noticed that the 40GB Slave isn't listed in My Computer. So I checked Device Manager and it doesn't display there either. I tried adding new hard wizard but it doesn't detect it. When I check the bios both drives are detected. Any help as to get the drive displayed back in windows? The slave drive not showing doesn't have an OS on it either, it's just storage.
  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Have you got "Go Back" or some other partition manager on your 40GB ? They can sometimes "label" the drive in a way that XP can`t read.If you don`t have them on the drive,ignore this post.
  3. {^}RaY{^}

    {^}RaY{^} TS Rookie Topic Starter

    The only things on the Drive is music files a couple of compressed zips and some photshop images right now.
  4. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    go to start/ control panel /admin tools /computer management /(highlight)down on storage devices see if it lists the drive there if you see it without a letter give it one
  5. {^}RaY{^}

    {^}RaY{^} TS Rookie Topic Starter

    Already checked that as well, It's not listed there either.
  6. Exscind

    Exscind TS Rookie Posts: 26

    The same thing happened to me. But for me, management recognized the entire drive, just not the partitions I set on that hard drive. What I end up doing was hooking the hard drive to another computer (set it as slave of course), and transferring the important files I needed to the new hard drive, then a reformat of the old hard drive. I've looked into places and tried several suggestions. Don't want to burst your bubble, but if you have a solution I'd like to know for future references :p.
  7. ru_ready

    ru_ready TS Rookie Posts: 22


    just guessing here from what you wrote... from what i read are you running 3 drives at the moment?

    "Now I still have my old 40GB Maxtor in the computer as well as the slave." + the 80?

    if your running the drives, how are your jumpers set? and the ide cablings?

    any slave drive even with an old OS on it wont boot from that OS unless its set to master, so no matter whats on the slave has no bearing to the data in that way.

    check cables, jumpers, try just two drives if you have more then 2 running, see if those slaves can be seen on there own accord.

    hope this may help, post back with prognosis or sulutions and more info
  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try reconnecting the drive

    go to bios after and force reset the udma for the drive
    could be it is just ready to fail
    if the data is not important you could try bootable utility to check the disc and reformat
    swapping out the drives can force xp to see it again
    I can swap drives all day and don't seem to get this error
    I just fix clients older gateway with write error
    used there old drive to play around with would work with usb adapter but not on the ide cable? so go figure
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...