my first computer problemss :o(

By dagma20 ยท 8 replies
Mar 28, 2004
  1. I have just built a computer with the following components :

    > P4 3.0ghz
    > 80gb HDD
    > 1024 MB RAM
    > Chieftec Dragon Full tower case (Black)
    > Sony DVD-Rom/CD-RW (combo)
    > DFI LanParty Pro
    > Radeon 9800
    > terratec phase 28 (sound card)
    > 3 1/2" FD (black)

    The problem is, is that the damn thing won't turn on. I installed and put everything together properly. Made sure i was always touching the case to be at the same polarity as the components/case. I checked with the motherboard manual to see how to put the little cables in properly (hdd ld, ATX switch, Reset switch, Power Led, speaker).

    But still no joy.

    So i thought that it may be that the MBoard had shorted out but it isn't i could check this by looking on the Mboard as it has a red light displayed if power is going through the mboard.

    Any ideas your help would be fully appreciated ty.
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Welcome to Techspot;
    when you say the machine won't turn on I take it you don't get to a bios sreen and no video at all.Are there any beep errors.
    What is the actual lay out of your ram eg.2-512Mb
    I would strip down to the bare minimum ,recheck all connections and start trouble shooting from there.
  3. dagma20

    dagma20 TS Rookie Topic Starter

    yeh sorry abouyt that, the memory is 2 x 512mb RAM, when you say strip down to minimals
    what do you mean by that?

    I solved one problem. The jumper on the HDD was on slave instead of master, lol.

    I also found out that the red led actually stands for :

    I also found out that there is another red led light and this is called the 'DIMM - Led' but this is not on :(

    I also am a bit confused about the PSU. Obviously power is going through the PSU as the light is on but there isn't any noise coming out from it, i mean the fan isn't moving round and making a noise sort of thing.

    Any ideas?
  4. MattG

    MattG TS Rookie Posts: 140

    Sounds like maybe the power supply is junked. Grab another one and test to see if that one works.
  5. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    You can also try taking the motherboard out of the case & powering it on like that. If it works then the board is shorted somehow once inside the case.
  6. Shiney

    Shiney TS Booster Posts: 160

    I suggest you try liquidlens approach, remove everything from motherboard, drives, soundcard etc. just keep graphics, memory, power lead and power on lead. Reset bios then try to start up, if succesful add 1 thing back at a time till you hit the problem. Good Luck
  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    First things first,You must find out why you have no fan in the PSU Matt is correct
    Take a deep breath and make sure you have your connections correct.( led leaders often just need to be reversed)
    If you still get no fan on the PSU try another one .
    Then try to boot to the bios setup with just the Motherboard,one peice of ram(check the manual for the correct placment of one module )and your vid crd (if there is on board vid it might be better to try without the card at first.
    If you boot to bios check settings and add one more item
    and boot again.
    Keep doing this until you have your whole machine up and running
    Let us know how far you get
  8. Masque

    Masque TechSpot Chancellor Posts: 1,058

    Seeing as how this is your first build, did you make sure and plug "both" your power plugs to the motherboard? I'm referring to both the ATX plug and the little square 12V plug which actually powers the processor itself.
  9. MattG

    MattG TS Rookie Posts: 140

    Masque - that isnt always true.

    I troubleshooted a PC that didnt have that 12v connector plugged into his K7N2 motherbaord, and it seemed to STILL work. Was the oddest thing ever, however the CPU may have been damaged too :/
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...