My IBM T42p doesn't go into standby anymore - Can anybody help?

By kryfling ยท 10 replies
Mar 16, 2006
  1. Hi!

    I have a IBM T42p and I'm very happy with it and it works fine, but a month ago it stopped going into standby mode, when I close the lid...

    I have absolutely no idea what happened. I was on a conference (didn't bring the computer) and when I came back it refused to go into standby mode... The button that you can click for standby is also not working.
    I have tried to change the settings in the power management, but the option of standby is not even there.

    Yesterday I updated the BIOS-file, but still no standby :(

    I'm not a computerwiz and I really miss this function and would like it back. I have looked at previous posts, but I couldn't find anything that matched my problem...

    I would really appreciate any suggestions (except for formatting the harddisk ;) ) to help me.

    Best regards!
  2. Qu3ntin

    Qu3ntin TS Rookie Posts: 18

    did IBM give you a CD with your laptop for driver recovery? they should have, and if so, maybe something in there will help you. other than that i dont know what to say. you can try to look in the knowledge base on Microsoft and IBM's website or simply calling IBM tech support and going through the headache of having them try and diagnose your problem
  3. kryfling

    kryfling TS Rookie Topic Starter

    Well, I got my computer from the IT people at my institute, so I don't know if any CD arrived with it... I'm currently away from the insitute, the next four weeks, so I'll try to check out the Windows homepage - I have searched the IBM homepage for hours...
    Thanks for the suggestions, though :)
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    What did you change? Use only drivers from IBM, do not install any drivers Windows Updates offer you.

    First, do you have power management stuff enabled in Control Panel? Can you make the computer go on standby using Windows? (Either from Ctrl+Alt+Del or Start menu).

    If Windows can put the machine asleep, then you are missing the IBM keyboard utility that handles all the fancy buttons.
  5. kryfling

    kryfling TS Rookie Topic Starter

    The BIOS update was from IBMs homepage, so I guess that it's OK?

    No, I can't make the computer go on standby by using the Ctrl+Alt+Del... I can see the button, but it's inactive and it can't be clicked (and belive me, I've tried :) )
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    OK. Download the power management drivers from IBM.. *cough* Lenovo I mean :p

    The Software Installer utility is really cool - it can automatically fetch the latest drivers and software for your system. I recommend getting it first and then doing all the rest through that.
  7. kryfling

    kryfling TS Rookie Topic Starter

    Tanks for the advice :)

    So now my drivers are updated - all of them :)

    But it's still not working and I really don't know what to do... :(
    Do you have any other suggestions?
  8. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    OK.. Assuming all your original stuff has the IBM/Lenovo drivers now.. Do you have any extra (ancient) hardware installed that wouldn't support power management?
  9. kryfling

    kryfling TS Rookie Topic Starter

    Hi again :)
    No, I don't have any old hardware installed... The only extra thing I have for my laptop is a mouse - but it's pretty new (I bought it after I got the computer)
    The mystery goes on...
  10. kryfling

    kryfling TS Rookie Topic Starter

    BTW... the standby worked also after I bought the mouse and installed, so that's not the problem... I think...
  11. cal_alum

    cal_alum TS Rookie

    I have this problem too!!! I'm somewhat contented knowing I'm not the only one....

    Standby worked for me for a few weeks after first getting my machine (last year), but soon stopped working. The error message I get is "The device driver "Standard 101/102 Key or Microsoft Natural Keyboard" is preventing the machine from going to standby. Please update the driver..." I've repeatedly tried Rolling back the keyboard driver, uninstalling the keyboard driver, updating BIOS, reinstalling power management, reinstalling ultranav, etc and nothing seems to make a difference.

    Recently I had to send my machine in for repairs and they had to reinstall the OS. I got my machine back and Standby worked again for about two weeks and then it relapsed into the error described above.

    I use a docking port, and I noticed that the problem started occuring again after I used the "Unlock computer" feature that appears on my Star Menu when the computer is in the docking station. I don't know if this has anything to do with it.

    I have a T43 which goes into Standby perfectly well, unfortunately it's not as powerful as my 42p.

    If anyone else has this problem, and knows how to solve it without doing a complete reinstall of the OS, PLEASE tell us!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...