1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Mysterious Problem - PSU?

By nazboy ยท 9 replies
Jan 11, 2010
  1. Howdydo my fellow techies, I have a question for you regarding a strange problem I am experiencing recently on my PC and hope you can help me to solve it, or at least confirm what I suspect it might be. I've worked in IT and built/fixed many PC's down the years hence I would like to think I understand a bit about hardware and software, however what is happening is unlike anything I've come across before.

    So to the problem, I built this current machine back in October 09 and after about one month of everything running tickadeeboo I started to experience a 'No Video Input' message upon booting up. Immediately I thought bing!... graphics card failure. So opening up the machine I had a look at the card, fans were running so obviously some power getting to it. I powered down and felt the heatsink, it was warm so seems it had been operating to some extent. I unplug everything, pop the card out, reseat it, replace all connectors and switch on... powers up as normal, Sweet! So I use the pc, runs fine for several hours then I shut it down.

    Next day I go to boot my machine... 'No Video Input'. Hmm, power down, open pc, do same procedure as last time, go to boot but this time I get same message :(

    In the past I've had strange issues with ram modules causing a similar problem so I decide to take modules out one at a time and boot... same issue. Next I tried them in all different combinations, trying each stick in each slot... same issue.

    Next I decide 'ok could be the monitor', I try a known working monitor but same issue.

    Well hey it could be the fuse in the power cable, replace it and... same message. But maybe its the flex in the cable itself, try known working cable... comes on, Woot! Use as normal for several hours, switch off.

    Next time I go to use PC 'No Video Input'... Arrrgh! *slap forehead* Running out of ideas I start thinking the worst, it could be faulty graphics card, motherboard or PSU. Clutching at straws I flick off the power switch on PSU, leave to stand for about an hour, come back and switch on... Bing! It works :)

    After that occasion, several hours of use, power down, switch off. Only leave it for about 30 mins this time and come back out of curiosity, switch on... 'No Video Input', doh!

    Switch PSU off, come back one hour later... Woohoo! :grinthumb

    And so it goes, I begin to learn the nature of the beast, switch off PSU for about one hour and come back... guaranteed to work, lovely jubbly. Anything less and... 'No Video Input'.

    The key thing I have noticed in all this to give me a clue that it may be a PSU problem is that when it works the power supply sounds audibly louder during the initial 5 seconds bootup, but when I dont leave it off for up to an hour then it starts up noticably quieter, almost like it's lacking some oomph.

    So I'm hoping maybe one of you guys/gals may have come across something similar before. I can't find anything with google. Please let me know your thoughts.
  2. Kevork

    Kevork TS Rookie Posts: 73

    Seems like a power issue. Just because a power supply is running does not mean its supplying what its suppose to supply. The one hour time limit your talking about seems like enough time for all capicators to disharge while the PSU is cooling down.

    I would suggets replacing the unit with a stronger PSU and testing it. You will be suprised how much current is drawn when you start a system, for sure its a spike but if you dont get enough then it simply will not start.
  3. nazboy

    nazboy TS Rookie Topic Starter

    Thanks for your input Kevork, funnily enough that is how I visualised what might be happening in my mind, with the capacitors requiring a full emptying before they could provide sufficient power to get everything started. It seems odd to me though because I have a highly rated 650watt supply which according to sources is easily capable enough for the spec of my machine. Im guessing either it is faulty or just not quite powerful enough. I find it strange how it runs ample once it gets going, even when im playing the latest games it never cuts out or anything.
  4. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,262

    Even with a 650watt PSU you'll most likely only have two main capacitors and two rectifier bridges. One fault in either will be enough shut the system down.
    I recently had a similar problem with a Silverstone Olympia 850- tracked the problem down to the main capacitor (Toshin Kogyo LG Series 250 w.v. 82pico farad - supposedly near the top of the line). First sign of bad news was testing the PSU for ripple-where the graph line should be relatively flat it looked like my path home from the pub on a saturday night.
    Had the graphics card originally dropping out as soon as it hit 3-D speed, when the core and Vram clocks hit their normal advertised speed.
  5. Quantex_rox

    Quantex_rox TS Rookie Posts: 123

    I think you mean 82 micro farad, pico farad would be a extremely small cap. Not to mention 82uf is unacceptably small for a input capacitor. (TK is a division of OST, are supposedly good but I think you may be making something up here., because Etasis dosen't use TK at all, usually all teapo or UCC)

    A good 650W with PPFC or No pfc should have at least 2 200v, 1200uf input capacitors. APFC would be more acceptable to have something like a single 450v, 330uf input capacitor.

    As for a bad rectifying bridge, that is highly unlikely. If it was bad, it would be either open or closed. If it was open it would just blow the fuse. If it was closed it would not power on at all and not do anything.

    This is more likely a problem of excessive ripple caused by failing secondary capacitors or not enough capacity on the schottky diodes. Sounds like he may have a cheapie 650W, which are often 250-300W with a 650W label. What brand is this power supply, nazboy?
  6. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,262

    My bad-82 micro farad it is. Finding some independent corroboration was a ***** so...As for "making something" up http://www.techaddicts.net/reviews/op850/op850.html (picture 16) thanks for the slur -unless you're assuming the review site are "making something up" too- excellent Photoshopping if it is.

    Hey, It were me. I'd probably of researched my facts before calling someone out. I might also differentiate between someone offering up an anecdote, and someone offering direct advice. But then, I'd probably wouldn't construct a post that was, for the most part, clearly over the head of someone I was trying to help either.
    But should I ever meet the electrician who tested the PSU and explained the problem, and the people who okayed the refund I'll pass along your input...or not.
    The Az at Saints game is on so I'm done, y'all stay classy.
  7. Reuben13

    Reuben13 TS Rookie

    It is obviously something you have not installed correctly?
  8. Quantex_rox

    Quantex_rox TS Rookie Posts: 123

    Look at the two main caps. They are 450V, 220uf each. Sorry if I came off a little strong there, but you were just saying some things that were not accurate. I mean, I do study SMPS's and repair them so I do know quite a bit about them as well as standard things used in all power supplies.

    I would hardly call the reviewer at techaddicts.net a electrician. Someone like the reviewer at jonnyguru (Oklahoma Wolf) is more of a electrician. Correct term would be Electronics Engineer.
  9. dividebyzero

    dividebyzero trainee n00b Posts: 4,891   +1,262

    I was referring to the electrician/Electonics Engineer who tested MY PSU- not the reviewer. The Techaddicts review was linked solely because it was the first review I found that showed the capacitor in question. The guy who tested it pointed out the problem to me and gave me the brief run-down of cause and effect. I merely provided the comment for anecdotal effect.
    Regardless of the fine print, both our posts highlighted excessive ripple as a possible/probable cause, so its either (from my viewpoint at least):
    a. Of questionable build quality/underpowered for it's intended use, or
    b. Of good quality but degraded by faulty componentry, age etc.

    Either way, as I intimated in my post, I think the poster is looking at getting a new PSU- but I'll quite happily defer to the expert in these matters.
  10. nazboy

    nazboy TS Rookie Topic Starter

    Thanks for the replies, my PSU is not a cheap one, it's a BeQuiet Dark Power Pro. As far as the technicalities of capacitors go I have no way of testing these, I'm guessing they (or something else inside) must be faulty. I think the next course of action will have to be dig out the manufacturer warranty and try to get a replacement. Have thrown the packaging away so hope it will still comply :suspiciou
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...