Need help really bad ..

By Bluerain
Sep 17, 2006
  1. Hi

    I have Raid 0 on 2 hard drives 120 gigs each (240)..I'm running XP home on a 1.2 AMD Atlon 512 mb ramwith a Via chipset.

    My drives are assigned Primary and secondary and have their own cable connected directly to the controller.

    My cd-rom and DVD player are directly connected to my motherboard on seperate cables.

    I can't boot up and can't get into safe mode. When I try safe mode it does it system check and stops on O/O which is O/O defrag program that I had installed for 2 years with no problem.I can't even get into recovery with the XP disk as it keeps freezing on this program O/O defrag.

    I remember setting up O/0 defrag to check files upon booting and it took only a few seconds to do it then it would boot.It seems now there's something wrong with O/O defrag program preventing me from booting.

    I wanted to go into safemode to removed O/O defrag but when I hit enter for safemode it does it thing and when it reaches O/O defrag program it just freezes.

    How can I get in to remove this program to see if I can continue booting?

    I have tons of shiat on these drives and cannot lose this data for anything.

    I had 2 old drives (40 gigs each) and installed windows XP on them (Raid O also)and now up and running and posting here.

    I then hooked up the 2 drives in question on each cable where the other drives are. I put the old C drive on the same cable as the the new C drive and put the old D drive on the same cable as the new D drive.

    But this is not working as the old drives don't seem to exist anywhere.When booting it only shows new drives and when I look into my computer they aren't there also.

    I was hoping I could access my data this way and then transfer all my data to a external drive when I buy one this Tuesday.

    Is there anyway to get access to this data? I don't care about raid 0 anymore as when I get my data back I'm getting rid of Raid and will keep all my data on external drives in future and just run it normally.

    Thanks for your time..

    System: Running XP Home
    AMD 1.2 266 FSB
    AMD Athlon (k7) Chipset AMD 650 With VIA 686B
    512 ram
    GTS 2 ultra DDR 64
    2 HD 120 Gigs each-RAID 0 Promise fastrack 100 controller card.
    Sony DRU510A
    Lite-on Dvd Rom
    Audigy 2
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    If OO has been working perfectly, I think you should investigate WHY this has happened before you fix it. I might make a rudimentary assumption that a hard drive in your array could be failing. You should run a manufacturer's diagnostic on your drives before you do any work (individually would be ideal) so we don't muck things up more. Check out the storage forum for a list of diagnostic utilities.

    As for OO, well, I know OO Defrag's boot time loader invokes itself during the same time drivers are loaded in XP. So this is about the time your problem occurs. OO also creates a system service. My assumption is this system service is responsible for inovoking OO's offline defrag during boot time.

    It's possible to disable system services using Windows XP's recovery console. This is a command line interface that can be accessed by booting from your XP install CD - regardless of your Windows install health. More info on how to get into the console can be found on this forum.

    Once in recovery console, you can use the command listsvc to show you a list of services that can be disabled. Then you can use the disable name_of_service command to disable that service. The service you want to disable is O&O's defrag service (oodag.exe). If you have questions about using any of these commands, typing help disable should reveal additional information.

    Once disabled, your XP should boot normally after a restart. If it doesn't, then you may need more specialized help... Maybe from OO's forums? They'll probably know about the software than (most) people do here.
  3. Bluerain

    Bluerain TS Rookie Topic Starter

    Hi Rick

    Thanks so much for taking the time to reply ...

    Yes it's O/O for sure causing the trouble. I'll give it a try as u suggest ..after all it makes sense what u say.

    I know how to get into the recovery with xp disk..I'll give it a go and report back.

    Thanks so very much : )

  4. Bluerain

    Bluerain TS Rookie Topic Starter

    Hi Rick

    Well I did everything and still not working.

    By the way it's listed as OOdefrag

    I went to disable it and it was alreay disable. Strange cause it keeps coming up on boot.

    So i enabled it and the same old thing. So I tried to disable it again to see what would happen and the same thing keeps happening.

    When it boots if I press the space bar to skip defrga files it freezes and reboots.

    If I let it defrag ( Which only takes a few seconds by the way ) it says 5 of 5 already defragged then it says Pagefile.sys missing and 0 our of 5 analized.

    I wanted to delet O/O but it won't let me.It says something about systemroot only to delete.

    Maybe if I delete it all together it will work cause that is the problem.

    How can I delete O/O defrag using recovery ?

    Thanks so much : )


    I don't need O/O defrag .
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...