Need to run JavaScript on a different port for web browser

By alcapella ยท 12 replies
Aug 29, 2010
Post New Reply
  1. I have tried this in several different browsers - Opera, Firefox, Iron, Internet Explorer - and it doesn't work in any of them.

    There is a school web site that I need to access, but at the top of each of their web pages they have the following line:

    <script language='javascript' src=''></script>

    When I try to access one of their web pages, I get a message (in Firefox) that the web page is waiting for a response from "" (local machine).

    The line looks, to me, as if the page is trying to access a javascript server on my local machine via port 1025. If I save the web page and remove the ":1025", the page will load properly and quickly, but I don't get any content from the website - it all loads in from my local machine, which isn't helpful. I do have Java installed, and it works for other web pages, but I don't know what port it is being accessed at, nor how to configure it so that it is listening on port 1025.

    Unfortunately, I can't change the way that the website is set up, so I can't remove the offending ":1025", and, if I disable javascript, it introduces a whole raft of other problems when trying to access the website. (Poor design that assumes the bells and whistles are all there, and doesn't make any allowances for them not being there...) Any suggestions as to what I can do?

    Many thanks.
  2. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    you are correct; it is accessing port 1025 on the local loopback ip address.

    a) the real Internet website can not be accessed this way and would require a PROXY
    on your local PC to make it work. Sometimes an A/V product does this; my Avast! uses for scanning Weblinks and Email.

    b) port 1025 should not be open to the Internet;
    google 'port 1025' for comments.

    you say the school has a page with something like this - - ask the Teacher or the Teacher Assistant.

    You might also ensure that you are not using a PROXY by mistake in your browser settings
    Tools->Options->Click Advanced
    Click Network Tab->Settings Button
    click No Proxy
  3. alcapella

    alcapella TS Rookie Topic Starter


    Thanks for confirming my understanding of this.

    I verified that I am not using a proxy by mistake, and I am still having my attempts to access the page hang.

    Every single web page on the school's website has this line forcing the attempted acces of javascript on port 1025, so it isn't just a couple of isolated instances... And, unfortunately, I have no way to tell the school that they should change this. I can't understand why they would have set it up like this - probably some website authoring software did this rather than an actual human - but it makes it impossible to access their site.

    Other people must be able to get this working somehow, since the school doesn't seem to be aware that there is a problem, but I don't know how to work around it at all.

    Any suggestions would be appreciated.
  4. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    anything accessing is CLIENT Side and therefore, if every page from the school
    webserver has this line then
    • the school MUST be expecting some prerequisite software to be running on the students PCs,


    • every student will have the same hangup you have

    you may know, the access is to js.cgi?pca&r=30145
    /JS.CGI is the code being access
    the parms are

    /JS.CGI would be found in the %documentroot% of the webserver and
    *.CGI is a common Unix Script type

    CGI Scripts are dynamic, not static, meaning JS.CGI would normally be a PROGRAM
    that writes to stdout. As the reference to it is within a < script ... /script > tag,
    js.cgi *must* create javascript.

    While entirely possible to make this work, it is extremely rare and I am getting very suspicious, CGI on a PC???

    You must have SOME contact point for the school; copy the <script ... > line and paste into an email with a note of your symptom. Without better information, I can only conclude that the webserver has been HACKED.
  5. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

  6. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    trying your link got this result....
  7. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    hmm; don't know what to say - - works for me

    it was a google for 'javascript port 1025' and result contained
    Re: Why is port 1025 open? -
    Listening on port 1025, NAV2002, Norton Anti-virus Agent. ... Opening a file download dialog from a JavaScript function. ...​
  8. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    I had tried it several times before...
    Now it is working for me too.
  9. alcapella

    alcapella TS Rookie Topic Starter

    Thanks for the attempted analysis of things for me. I will see if I can get in touch with someone from the school, but I'm not sure who...

    The web-site itself is at if you want to take a look at it. What I've been doing is going to the link, waiting until Firefox tells me it is waiting for, hitting the "Stop loading this page" button, and then viewing the source to try to figure out what is going on.

    The source for the page shows the standard HTML headers, with a link to what seems to be a fairly generic stylesheet, and then the offending <script> line, followed by another <script> for vertical menus from - I checked the Dynamic Drive web-site to see if the offending line was part of their source code, but it isn't.

    I don't know if this helps any in trying to figure out my problem, but...

    Many thanks.
  10. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    I accessed the link posted and the page loaded just fine (FireFox).

    The source does contain that bogus script for

    but it doesn't cause any harm that it didn't load.

    You may see the browser waiting or reporting an error, but I do not - -
    as my firewall has a rule to allow all accesses
    allow in/out tcp/udp src-ip=any
  11. alcapella

    alcapella TS Rookie Topic Starter

    I have finally managed to figure out the problem. Thanks for the help.

    I did a port scan of my system and found that LEXPPS.EXE was Listening on port 1025, and was obviously interfering with this stupid flaw in the web-page I have been trying to access.

    FYI, LEXPPS.EXE has something to do with allowing a Lexmark printer to be shared on a network. Obviously, it sets itself up on port 1025 to serve printer sharing requests. Killing the LEXPPS.EXE process allowed the web-page to load almost instantly. Since I am not sharing a Lexmark printer on any network, I went through my system and renamed all files that had LEXPPS in their names, rebooted, verified that LEXPPS.EXE is not running, and I can access the web-page with no problem now.

    It's a bit of an idiosyncratic problem - it's not likely to crop up for many people - but I thought I should share the resolution with you.

    Thanks again.
  12. jobeard

    jobeard TS Ambassador Posts: 11,166   +986

    Well done :)

    LEXPPS.EXE on 1025; the *pps.exe looks like the Linux form of print sharing, but it uses port 621.

    I found this
    It's run by default when you install the Lexmark and Dell printer drivers (as of this writing, Lexmark makes Dell printers). It insidiously sits in the background and binds to TCP port 1025 in case you'd ever want to set up print services over a windows network.​

    Spybot S&D has a section to view Startups, and removing the [x] on that process will stop it from launching in the future.
  13. jobeard

    jobeard TS Ambassador Posts: 11,166   +986


    there is a Printer HiJack technique which attacks networked printers (ie attached to the router and having an ip-address) which runs on port 9100

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...