Network keeps reconnecting

First of all, sorry for my bad english.
My pc was working perfectly for about a year now, but these days it started having problems.
In the past few weeks it started disconnecting from the internet with the message: you don't have a valid
ip configuration. (It was working on the other pc connected to the router with lan, and on the notebook connected through wifi)
A reboot of the pc/router did always solve my problem in these situations.
Yesterday, my internet connection started connecting/reconnecting, and I couldn't solve it in any way, not with
a restart, and not with that network repair tool (idk it's name, I have hungarian windows). When it stayed connected for more then 2 seconds I was even able to load google, youtube, other sites,
I tried some solutions, like disabling the energy saver settings, setting it to 10mb half duplex, etc, but nothing worked, my
internet kept connecting/reconnecting.
Today I started my pc and it works perfectly.. Any ideas on how to solve it? I have the newest lan driver.

My mobo is Asrock 960gm-vgs3 fx.
 
D

DelJo63

It appears that you manually configured the IP for at least one system.
DON'T do that - - make sure all systems use DHCP
 
G

Guest

Sadly it's using it.. I have tried about 10 "solutions" but nothing worked for me.. Any ideas?
 

reckonankit

Posts: 43   +3
Have you try to reset your network setting. Login to network admin panel and reset all IP and DHCP setting. Also try to use different cable to connect. You can try to WiFi Dongle on PC to check WiFi working or not in same PC
 
G

Guest

Yes, I tried it, I even reinstalled the windows on it, but the problem still exists. I'll try changing the cable, thanks.
 
D

DelJo63

When you see
the internet with the message: you don't have a valid ip configuration.
there's nothing wrong with the cables - - it's totally an error in the TCP configuration - - it means what it says. When you see this, get a command prompt and enter
ipconfig /all >myTCP.txt
follow with
notepad myTCP.txt
copy the content and paste it into a follow-up