1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Networking in XP - NO SHARES! :(

By Spike ยท 6 replies
Dec 8, 2004
  1. I've networked (10/100 ethernet) my XP box many times before without problems, but this ones frustrating.

    My Housemat has poor sight, so I've let her use the monitor, while I'm rigged up to use the TV. This also means that my housemate has the internet connection, even though my computer is 15 times faster than hers (mines a 2400+, my housemate a pentium 2), so it may seem strange, but hers is erving the broadband internet to mine.


    I ran through the wizard on her PC (\\OSTARA) to set up the network with the workgroup MSHOME to share the internet connection, and then ran through the wizard on mine (\\BRIGHID) to set up under the same workgroup and to take the internet connection from her computer.

    All seemed fine for a moment, as the icons in the system tray showed a connection, and the internet connection flowed freely to my machine.

    That is, until I looked at the shares...

    My computer (\\Brighid) immediately sees both itself and \\OSTARA in the "view other computers on this network" window, but cannot access anything by double clicking \\Ostara, offering the error message
    My computer also sees all it's own shares in "My Network places", but none of \\Ostara's

    When I try to view computers on the network from \\Ostara, The cursor turns into an eggtimer while it works for a minute or two, before failing to detect either itself or \\Brighid on the network, displaying the error
    \\Ostara fails to see it's own shares, or \\Brighid's in "My Network Places"

    The internet connection continues to be shared perfectly.

    Both LAN connections are running "client for microsoft networks", "file and printer sharing", "QOS packet scheduler", and "Internet Protocol (TCP/IP)".

    I can't seem to figure it out.
  2. unknownzero

    unknownzero TS Rookie

    Did you install SP2? If you do select other for the sharing and it will get rid of the confusion you have. Its because the other options only host one way. Routing the internet through a machine can be frustrating I admit, but if this problem persists, try to buy a router.

    Oh and btw disconnect or delete the other network shares.
  3. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    I don't have a problem at all with the internet connection. It's the one thing in the network that is working properly. lol :D

    seriously though, I'm not sure I quite understand your meaning.

    I am running XP Pro SP2, yes. It's a slipstreamed installation, straight off a CD. I forgot tom mention that.

    I also forgot to mention that I'm looking to get the shares working both ways, just as they always have in the past (XP SP2 included)

    The broadband is nasty old AOL, using a BT Voyager100 USB ADSL modem - previous experience of not having any problems tells me no router is needed, besides which, AOL only support one o two, and probably charge the earth for them.

    I think I may also have posted in the wrong forum :D lol
  4. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Could somebody plese move this thread to the storage and networking forum? many thanks.

    Be careful what you wish for - you might get it.. :giddy:
  5. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Cheers Mic! :)

    I've just had a thought. If I was using a straight ethernet cable, instead of a crossover, would that explain the problem I seem to be having, because to tell the truth, I just don't know what I'm using!
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    You definitely should be useing a Crossover cable.
    Also ,You need at least one user with the same name and password on each machine.
    Have you placed a Shared folder or Drive on both machines?
    Also are you useing Pro on both machines?
  7. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Problem solved, thanks to Soul on #3dspotlight. (thanks!)

    It was XP pro SP2 on both machines.

    I wasn't sure whether I was using a straight cable or a crossover, so I went out and bought a crossover cable.

    Also, \\ostara wasn't password protected. I set a password on a user account, and edited the registry to log on automatically instead of going to the welcome screen.

    Unsure about whether NetBIOS was broadcasting, I went to the advanced tab on the TCP/IP properties for the connection and set it to enabled on both machines.

    loooking up the IP of each machine with ipconfig /all, from the CMD window, I pinged each machine revealing that I had a firewall issue (I misstyped the IP in the firewall rule I had set to allow all traffic to and from each machine).

    After all this, running the network connection wizard on both machines once more resolved the problem.

    Thanks to everyone, especially Soul, for their help. :D
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...