New build not seeing SATA HD

By Fureya ยท 12 replies
Jul 27, 2005
  1. Bear with me, I don't know much about bios stuff or anything about SATA drives

    I just built a system with the following:
    AMD Athlon 64 3000+
    Asus A8V deluxe mobo
    2 gigs of Kingston DDR400
    Geforce 6600GT
    and a SATA Seagate hard drive

    It posts, no error beeps or anything, but says I don't have a hard drive.
    I get the message Bios not installed.
    I can get into the Bios and the primary IDE is not detected (obviously...its not IDE) and the secondary IDE is my DVD drive that works fine.

    I thought it wasn't seeing my hard drive but I started pushing buttons (go me!) and found some SATA RAID bios that lists my drive and its size.

    I dont know anything about SATA or RAID stuff. I know that on my motherboard there are two sata plugs and two sata raid plugs. The drive is connected in the Sata 1 normal plug...not the raid ones. (I dont know what a RAID is...)

    Any...wild guesses? I'm thinking theres some simple setting in the bios I'm not seeing but I cant seem to figure it out.
  2. Merc14

    Merc14 TS Rookie Posts: 171

    RAID = Redundant Arrays of Independent (or inexpensive) Disks. It allows you to do different things with groups of disks (google it). You need more that one disk to run in a RAID array so the function is useless to you at the moment. Regardless, you probably have RAID enabled in BIOS (by default). Consult your instruction manual for the mobo and find out where RAID is in BIOS and disable it. The SATA port will remain active and your disk should be detected.
  3. Fureya

    Fureya TS Rookie Topic Starter

    Checking for that now...thank you and I hope it works!
  4. Fureya

    Fureya TS Rookie Topic Starter

    Ok I had already seen that and switched it to IDE mode.

    What about this Promise Controller? Should it be enabled? drive shows up in the bios when I'm setting up what order to boot from...however if I try to install windows it can't find a hard drive..

    More googling led me to the SATA is newer than XP thing and Im now working on stealing my floppy from my desktop to stick in my new box to install the SATA drivers that xp wants. Yay go me =)
  5. N8theGr8

    N8theGr8 TS Rookie

    hey buddy, im in your same position (amd 3000+, A8V deluxe), and i have a SATA HDD as well. (havent quite put the computer yet though, thats another story). anyways, can you get to the windows install screen? there, you need to press F6 and install the SATA drivers via floppy. i know it's a bit of a pain, but it seems like it's the only solution. the drivers should be on the cd (you'll need a 2nd computer), and a file named "makedisk.exe" in one of the directories. sorry for the lack of detail, im just going by what ive found on other forums. run a search on google and you'll probably find what i found. good luck!
  6. Fureya

    Fureya TS Rookie Topic Starter

    Well I was SURE I had found (and solved) my problem.

    Made the disk, loaded up winXP promise whatever it was in windows setup. Then it still decides that it can't find any hard disk drives =/

    Completely clueless now. That seems to be solving everyone elses problem from what I've been reading but for some didn't do a thing =/ There were more than 1 makedisk wondering if perhaps I'm trying to use the wrong thing...
  7. Merc14

    Merc14 TS Rookie Posts: 171

    You have two differet RAID controllers, Via and Promise, on the mobo, both of which should be disabled as you are not running RAID. However I looked at your manual and it is a little complicated. You have the Promise Controller drivers on disk so disable the "On Chip SATA Boot ROM" in BIOS and then Enable the "Onboard Promise controller" and set it to IDE. Promise Controller ports are the lower two that are set next to each other, not on top of each other. Now do the F6 thing.

    BTW- Before doing anything you should flash the BIOS to the latest version just so you don't have to go back in and make all the changes again. See your manual for making a BIOS flash floppy.
  8. Fureya

    Fureya TS Rookie Topic Starter

    Ok so you're saying i need to plug the drive into one of the sata raid spots on the motherboard instead and do the other stuff as well? I will give it a try today and tell you how it goes =) Thank you =)
  9. Merc14

    Merc14 TS Rookie Posts: 171

    Personally I would use the Via chipset SATA controller. My guess is since it is run by the Va chipset itself it would be faster than the Promise controller. Here is what I would do:

    1. If needed, use the makedisk function on the mobo CD to make Via CHipset SATA drivers. Make BIOS flash disk with the latest BIOS on it while you are at it (instructions in your mobo manual).
    2. With just the video card, CPU and its HSF, and RAM installed flash the mobo to the latest BIOS.
    3. Boot to BIOS and disable the Promise controller and enable "On Chip SATA Boot ROM". Also set Boot Order to CDROM/Floppy/Hard Drive. Turn off PC.
    4. Plug your hard drive into the SATA ports that are right next to the Via Chipset. Plug your CDROM drive and floppy drive into their respective ports and start PC
    5. Your Hard Drive may be recognized in BIOS now as well as the CDROM and floppy. Insert the XP CD and put the floppy in the drive and reboot.
    6. PC should boot from the XP CD. Install and do the F6 thing when asked. You may not need to do F6 as the driver may be in the BIOS but do it if you have the driver on floppy just to make windows happy.
  10. Fureya

    Fureya TS Rookie Topic Starter


    Ok here is where I have had the SATA plug plugged appears to be next to the via chipset like you mentioned.

    I'm pretty sure that all the times I tried to load the SATA drivers and install windows...the promise controller was enabled so hopefully this will work. Only 3 hours til I can get home to try it now =)

    Thank you for your detailed help =) I have the floppy made with the drivers but I haven't yet made a BIOS flash disk. I'll do that as well.

    I guess I'll give in and buy an extra damn floppy drive while I'm at it so I can stop hotswapping it =P
  11. Merc14

    Merc14 TS Rookie Posts: 171

    Yep that is the "On Chip" VIA controller you are plugged into. You were trying to load the drivers for the Promise controller.

    If you don't want to make another driver floppy disk just disable "On Chip..." controller and enable "Promise Controller", and under that enable "IDE" and plug the drive into the other set of SATA ports that are lower on the board. Then install windows using the floppy with the promise drivers that you already have on hand.

    Like I said before, you can update the BIOS later but it is generally preferable to update BIOS before anything else.
  12. Fureya

    Fureya TS Rookie Topic Starter

    Figured that one out when I tried to install windows again...hey wait a minute...that says Promise....

    Typing this from the new system which means all is well! Thanks again so very much for your help =) Hell I learned a lot at the least!
  13. Merc14

    Merc14 TS Rookie Posts: 171

    Congrats, glad I could help and enjoy your new PC!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...