No fixed disk present message - hard drive failure?

Not open for further replies.
My computer no longer boots up to the C drive. I have a Maxtor 40 gb disk that worked until sudden death. I ran the powermax diagnostic with the following results:
Bios Extension Support failed
Partition Information Read fail
Smart Enable Function Failed
Power connection, Master/slave jumpers, and interface cable passed the powermax installation confirmation test. I ran the powermax basic quick test and then the advanced test once. Now even those two tests won't run anymore.
I tried to run fdisk/mbr, but the system cannot find the hard disk. I even tried to run Fdisk. What puzzles me is that when powermax diagnostics scanned for the drive, it found "via 596 primary master Maxtor N40P" .
The drive seemed to be working fine before I opened an attachment to an email. After the system froze I rebooted and had trouble with error messages (don't remember all of them). I tried to reinstall Windows XP but it cannot find the hard drive. I can boot to the A drive and to the CD drive. I tried to go from the A drive to the C drive, but it cannot find the C drive. I am at the end of my wits. Is this a virus problem or is the hard drive dead.
Can anybody help me solve the problem?
Is all my data lost? Oh no!!!


Posts: 5,452   +7
Attach the hard drive to the CDROM cable on the secondary controller and run the MAxtor utility again. If it still fails then most likely your hard drive is dead.


Posts: 480   +0
To add to Nodsu's excellent advice, when you do this be prepared to move/copy/burn any files you might need from that might get only one chance to do so.

patio. :cool:
  • Thread Starter Thread Starter
  • #4
disk boot failure

Thanks for responding. I did what you told me to: I connected the hard drive to the CD ROM cable. When it boots up it says "detecting primary master - none", "detecting primary slave - none", "detecting secondary master = Maxter N40P", "detecting secondary slave - none". Then it gives me the "disk boot failure" error. This means to me that the bios recognizes the hard drive that is now connected to the CD ROM, but it cannot be accessed. I tried to reboot the system to the A drive to run the powermax utility, but now it no longer goes to the A drive, which was working find before.
In the process of connecting and disconnecting the controller cables, the plug of the primary slave controller came off the wide controller band and was stuck in the hard disk drive. I finally got it out of the hard drive, but the plug is broken and no longer attached to the controller band. Then I connected the hard drive to the CD ROM and the BIOS recognized it. (this is a different controller cable, right?) Could a broken slave controller plug affect the master controller cable? This whole thing is becoming hilarious.
I am not sure anymore that it is the hard disk that is defective, although it cannot be accessed. Could it have anything to do with the controller cables?
If it is really a dead hard drive, do you think "Spinrite" would be able to recover data?
I am at the end of my wits. Any help would be greaty appreciated. I am determined to make this work.


Posts: 5,452   +7
Replace the broken cable. They cost next to nothing and yes, a bad cable can give you all sorts of hilarious issues.
Not open for further replies.