No power after USB overload

By Dodds
Feb 5, 2012
Post New Reply
  1. Hope somebody can help

    I have a six year old dell dimension 5150 which is not working.

    Yesterday I tried to plug in my sons new children's tablet thing and got an USB overload error I didn't think much about it, switched the pc off and went out.

    I then found that the computer would not switch on, no beeps, nothing on the screen, no HD activity but with the power light flashing and the internal card reader light flashing too. Then I switched the power socket off and tried again. This time there were no lights at all.

    I tried unplugging the card reader from the mboard but this made no difference.

    The mboard light is still on if this makes any difference.

    Any help would be appreciated

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try replacing the power supply first, but also look around the motherboards CPU and check for any bulging or leaking capacitors
  3. Dpatt711

    Dpatt711 TS Rookie

    Unplug the power cord from the PSU.

    Turn the PSU switch to Off

    Hold the main power button down for 30 seconds.

    Plug the cord back in

    Turn on the PSU

    Hit power button and it should work.

    If it happens when it's plugged into a USB port on the back then you might have a problem.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...