No video after installing the Asus Mobo

By blodg8 ยท 7 replies
Oct 1, 2008
  1. Hi all,

    After installing the ASUS A8N SLI Premium Mobo with 2.4 AMD Socket 939 CPU, Corsair 2x512mb Memory and the 120gb WD hard drive, & the ASUS 6600 GT video card.

    the system does not boot up with video.
    the fan and the DVD rom and the hard runs but what do i need to do to get this fix.

    What could be happening? any help will work. thanks
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  3. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  4. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Tedster please note: Your link above is already in the updated No Post Tutorial
    No need to quote it
  5. blodg8

    blodg8 TS Rookie Topic Starter

    hi guys...I tried everything and my Mobo does not recognize the keyboard, mice and no video when I boot it up....

    I know the viedoe card works because I put it in another PC and it works. the keyboard and mice also works. what is going on. I followed the tutorial and still no video for me to enter the Bios setup. wassup with that.
  6. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    If you have tried everything in the tutorial then it must be faulty hardware

    You must start replacing parts:
  7. blodg8

    blodg8 TS Rookie Topic Starter

    Hey Kimsland,

    The PSU is new. The only thing is the CPU, MOBO and Ram used but I know it works because it was an upgrade from new PC.

    I did, however, that when I first putting things together I took the battery out from another mobo and put it in this one then I switch it back. Did that do anything?? Did I clear any CMOS?

    By the way, how do i clear the Cmos.....can anyone here help me?? thanks
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Probably this is at fault, the PSU (even though new)

    You did benchtest and everything?, as per the guide?

    You did re-mount the CPU?, as per link in guide (at end)

    You did try another PSU?

    Then lastly faulty
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...