Not set up to establish a connection on port...

By brear92 ยท 7 replies
Dec 26, 2009
  1. Ok guys, here's my problem...

    I was on my pc last night, everything was running fine, i was on msn, the internet and downloading music. I then went to refresh my browser and it came up with "Internet explorer cannot display the web page". At first i thought the router had gone down, but then i noticed that i was still on msn. I decided to click on 'Diagnose connection problems' - It came up with:

    "xxx" is not set up to establish a connection on port "World Wide Web service (HTTP)" with this computer.

    At this time it was late so i decided to leave it until tomorrow, when i tried it again, internet explorer still wouldn't work,but google chrome did, even though it hadn't the night before, msn is also still working fine.

    I have googled this problem and tried the suggestions such as turning my firewall off, this did not help, any other help will be greatly appreciated.

  2. almcneil

    almcneil TS Guru Posts: 1,277

    I recently had a custome with this problem and it turned out to be the Conficker worm. Go to and try their Conficker Removal Tool.

    -- Andy
  3. brear92

    brear92 TS Rookie Topic Starter

    Ty for the fast reply Andy, i used the conficker tool but it didn't find anything =/

    Is there any significance of the fact that Windows live is working, google chrome is working, but internet explorer isn't and neither is an online game that i play.
  4. almcneil

    almcneil TS Guru Posts: 1,277

    Could be a firewall problem. Are you using one and if so, what is it? Try disabling it.

    -- Andy
  5. brear92

    brear92 TS Rookie Topic Starter

    im using komodo internet security, iv'e neve had a problem with it before, like a said, i was just surfing the net, decided to refresh the browser and it did this, i have tried disabling the firewall too, it didn't work.

  6. brear92

    brear92 TS Rookie Topic Starter

    Just to let ya know Andy, i finally found the problem, i had a conflict with a security program.

  7. harleyjohn

    harleyjohn TS Rookie

    Running Vista x64, IE8
    This same problem is all over the web and there doesn't seem to be any one certain cause. I got started on it yesterday when one particular web site started displaying it when I tried to access it. (Sudhian). After flushing dns, releasing IP address, renewing IP address, changing DNS servers, turning off Protected Mode and God knows what else, I stumbled on something that may or may not help some of you.
    I could ping the web site and got my replys, I could run tracert and it would show me the route. Everything on the TCP/IP side looked good.
    I went to the web site "sitelogr" and looked at the Domain Tools section and chose "services Status" and was greeted with this:

    HTTP IS: Offline (or blocked from outside access) @ port 80
    FTP IS: Offline (or blocked from outside access) @ port 21
    MySQL IS: Offline (or blocked from outside access) @ port 3306
    SMTP IS: Offline (or blocked from outside access) @ port 25
    POP3 IS: Offline (or blocked from outside access) @ port 110

    So one more thing to check before you pull all your hair out is the Services Status!

    Hope this helps someone.
  8. harleyjohn

    harleyjohn TS Rookie


    After two days of searching the most common cause seems to be multiple firewalls (including router firewalls)
    Some other causes were DNS related, IP address related and allegedly Norton.
    This really is common and seems to be getting more common all the time. There is a HOST of cures and if you have the time and the patience you will get it repaired.
    Good luck.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...