PC locks up when loading a data disc

By nodrog
Jan 29, 2005
  1. I have a problem with my CD writer where it will only read music CD’s, if I try to load a CD with data on it i.e. a programme file or JPEG photos it causes the PC to lock up and can only be restored by turning off the power.
    The drive activates and the light flashes, the drive speeds up, the light goes off and the mouse and keyboard are frozen, even the clock stops.
    I can eject and reinsert the CD but this has no effect.

    I had initially put this down to a fault with my CD writer but I purchased a DVD writer last month and when I installed it I was surprised to find that it has exactly the same fault as the CD writer.

    The DVD writer came with Nero and Cyberlink and it took me numerous attempts to get this loaded as it would keep locking up when loading the disc.

    I have managed to write a DVD slideshow with the new drive however if I put the disc back in the PC will lock. Again it will run music CD’s perfectly but not anything that seems to have data on it.

    I have cleaned up the PC by deleting temp files, removing unused programmes, defragmented the disc, ran scan disc, changed msconfig to reduce background programmes, ran Adaware software, and ran Registry first aid software, all of which have no difference.

    I have also deleted the CD and DVD drivers and reinstalled again with improvement.

    Interestingly if I change autostart preferences to “take no action” the PC locks when I put a music CD in as well. Also If I set photos’s to open with explorer it will open explorer and display the files but when I select a photo it starts to open photo/fax viewer then locks up.

    I am not too sure when all this started but I recall I had a problem with the CD writer when I was trying to recopy some files on to a CDRW so I do not know if this stated it !!

    So you can imaging by now I am getting a bit frustrated.

    Has anyone experienced the same problem ? or can perhaps suggest a solution.

    My PC is a HP with 1.53G AMD Athlon running XP SP1.

    The CD is connected to the secondary master IDE and the DVD to the secondary slave.

    I would welcome any advise or suggestion anyone may have to resolve this.

    Thanks in anticipation.

  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Welcome to Techspot !
    Writer's can be very frustrating ,you need patience to succeed with them.
    I would start by telling you , that you need to do some trouble shooting and then post back with the results.
    I recommend that you make the DVD drive the Master on that channel(If it is newer it might be faster,but for sure DVD 's are more sensitive )
    Then turn off Auto start in Windows.
    Turn on DMA for the drives that can use it .
    Check the Info Tool in Nero and make sure you have a green light for your system and nero ASPI drivers.
    Make sure Windows cd writing capability is disabled.
    Update the" Firmware " for both drives.
    Cleanly remove all Authoring ,packetwriting software , except Nero.
    Then download and update Nero to ver 6.6..
    Have fun and Good luck.
    Let us know how it works.
  3. nodrog

    nodrog TS Rookie Topic Starter

    Hello Liquidlen

    Thanks very much for the feedback, I have made a few changes as suggested which unfortunately have not worked however there were a few actions which I was not too sure about. Therefore it is probably best if I tell you what I have done and perhaps you can put me right if I have gone wrong.
    1. I have removed my original CD writer so I now only have the DVD writer connected to the secondary master.
    2. I tried to disable autostart via gpedit.msc but this could not be found so all I have done is to select take no action on the autoplay tab under device properties. Nero info is however indicating that autoplay is on !!
    3. The DMA if available option was already selected.
    4. On Nero info ASPI, "ASPI is not installed" was selected and highlighted in yellow, if I select Nero ASPI then I get a green light however if I exit and go back in the ASPI not installed option is reset in yellow.!!
    5. For CD windows writing capability I have unchecked the desk top CD recording box under properties/recording.
    6. I have previously downloaded the latest firmware for the DVD drive.
    7. I have removed Record now and cyberlink programmes.
    8. I am already running Nero

    I hope this all makes sense, Ilook forward to your reply.

    Thanks Nodrog
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...