PC not connecting to Internet 169 IP

By tupelohny71 ยท 34 replies
Mar 17, 2011
Post New Reply
  1. Hi, I am trying to give my old laptop to a friend. A few months ago I got a new one and had since unplugged the old one from the cable connecting it to the modem. I plugged the old one back in today to get everything cleared off for my friend and now the old pc won't connect to the modem. I can't repair the connection. The IP is 169 etc etc. It connected through this cable fine two months ago. How can I make sure it can connect so I dont give my friend a busted pc? I have tried to follow older posts similar to my problem, but I'm not to savvy when it comes to this stuff. Any help would be greatly appreciated! Thanks in advance.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Follow this instruction and post the text file. Please state your version of Windows. If you are using XP or earlier just type cmd in the search box and hit enter. A new connection has the address or similar so it probably just needs to be set up correctly. Have you changed the router since the old PC was last used or reset it?

  3. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Hi, thanks for your help. I'm operating on windows xp professional, version 202, service pack 3.

    I typed the command you gave me, but it didn't run anything for me to post back.

    I did get a new modem recently that the old computer hadn't yet been connected to.

    Thoughts on next steps?

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    just fyi and help save time (as i just noticed your post)... After running that command, look for a file in your C:\ directory named ipconfig.txt is the file mark56 would like you to post
  5. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Ahh - ok . . .it was there.

    Here is the result:

    Configuration for interface "Local Area Connection"
    DHCP enabled: Yes
    InterfaceMetric: 0
    DNS servers configured through DHCP: None
    WINS servers configured through DHCP: None
    Register with which suffix: Primary only
  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    OK, try this and that should re-establish connection to the new modem.

    Connect the cable from the Modem

    Click Start and then Run, type cmd and press Enter. At the command prompt type

    ipconfig /renew (Make sure you include the gap in the middle)

    Hit Enter. Now try the connection again.

    When your friend gets the PC to his house he will have to do the same again to connect to his modem, or go through a slightly different process if he is going to use wireless.
  7. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Another solution maybe
    Open CMD window (open as adimistrator) and enter

    netsh int ip reset

    This will reset the IP to original setting by modifying some registry keys
  8. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    OK . . .her's what we got going on now.

    Mark, tried yours and this is the response. By the way, the wireless connection is disabled right now.:

    C:\Documents and Settings\xxxxxxxxx>ipconfig /renew

    Windows IP Configuration

    An error occurred while renewing interface Local Area Connection : unable to con
    tact your DHCP server. Request has timed out.
    An error occurred while renewing interface Wireless Network Connection : The sys
    tem cannot find the file specified.

    C:\Documents and Settings\xxxxxxxxxxx>

    Pigeon, I tried yours and this is what I got:

    C:\I386>netsh int ip reset
    One or more essential parameters were not entered.
    Verify the required parameters, and reenter them.
    The syntax supplied for this command is not valid. Check help for the correct sy

    Usage: reset [name=]<string>


    Tag Value
    name - The name of a file to which to append information
    regarding what settings were reset.

    Remarks: Resets TCP/IP and related components to a clean state.


    reset resetlog.txt

  9. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Sorry, my bad!

    In CMD window, type:

    netsh int ip reset c:\resetlog.txt

    So there will be a log file created on c: restlog.txt
  10. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    OK - here is what that file said.

    Still not connecting.

    deleted SYSTEM\CurrentControlSet\Services\Netbt\Parameters\EnableLmhosts
    reset SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4C047E6C-6997-4FAF-8B56-80862D4BDE11}\AddressType
    old REG_DWORD = 1

    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4C047E6C-6997-4FAF-8B56-80862D4BDE11}\IpAutoconfigurationAddress
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4C047E6C-6997-4FAF-8B56-80862D4BDE11}\IpAutoconfigurationMask
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{4C047E6C-6997-4FAF-8B56-80862D4BDE11}\IpAutoconfigurationSeed
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{7DABA476-698C-4843-85BB-74826F0C98CF}\IpAutoconfigurationAddress
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{7DABA476-698C-4843-85BB-74826F0C98CF}\IpAutoconfigurationMask
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{7DABA476-698C-4843-85BB-74826F0C98CF}\IpAutoconfigurationSeed
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DontAddDefaultGatewayDefault
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableIcmpRedirect
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\EnableSecurityFilters
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\SearchList
    deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\UseDomainNameDevolution
    reset Linkage\UpperBind for ROOT\MS_NDISWANBH\0000. bad value was:

    reset Linkage\UpperBind for PCI\VEN_8086&DEV_1043&SUBSYS_25658086&REV_04\4&39A85202&0&20F0. bad value was:

    reset Linkage\UpperBind for PCI\VEN_14E4&DEV_165D&SUBSYS_20031028&REV_01\4&39A85202&0&28F0. bad value was:

    reset Linkage\UpperBind for ROOT\MS_NDISWANIP\0000. bad value was:

  11. greypigeon

    greypigeon TS Enthusiast Posts: 29

    Did you reboot?
    What's your IP now?
    In cmd, type ipconfig /all

    XP is not my thing anymore, maybe you can find some answers here
  12. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    I did reboot and the IP was still a 169 . . . thanks for the try though.
  13. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Open control panel, go to network connections. Right click on Local Area Connection and click properties.

    Select TCP/IP and select properties. Make sure it is set to automatically obtain IP address.

    See if that works, if not:

    Have you got encryption set on the router? if so disable it and then try again to connect. If still not connecting disable your firewall.

    If that fails then follow this so we can have a better look at what is going on.

  14. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    OK . . .so I had already made sure the IP address was set to automatically obtain. check!

    Not sure about the encryption on the router. How would I check that. The laptop is connected directly through a cable. Which works fine when I connect it to another laptop.

    Firewall already disabled.

    I'll run that command in a sec and post the results.
    Thanks again!!
  15. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Here is the text from that command:

    C:\Documents and Settings\xxxxxxxx xxxxx>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : Jessica
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom 570x Gigabit Integrated Con
    Physical Address. . . . . . . . . : 00-11-43-CC-D6-12
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :

    C:\Documents and Settings\xxxxxxx xxxxx>
  16. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your Default Gateway address is incorrect it should be 192.168.xxx.xxx. Run the ipconfig command on your other PC and you will see the difference and make a note of the Default Gateway address.

    If your router is cable only it wont have any encryption. I was thinking of a wireless router when I mentioned that.

    Go into the Device Manager, find Network Adaptors and click on the symbol next to it to show the adaptors. You should see Ethernet adaptor. Right click on it and select Properties, under the drivers tab click on uninstall and then reboot the laptop. This will reset the Ethernet adaptor to default settings and reload the drivers.

    Try to connect again.

    If it still wont connect you will have to reset the default gateway address manually. Use this guide on the problem laptop to reset the correct address so it matches the one you made a note of from your other laptop

  17. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Hi there, just to be clear. There is nothing there that says "ethernet". Do you want me to uninstall the driver for the broadcom 570x gigabit integrated controller?
  18. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

  19. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Thanks for the clarification. I did what you suggested, but it still ends up with a 169 IP and the connection has limited to no connectivity.

    Also, I can't download a new version since that computer isn't connecting to the internet.

    I do know it can connect to a wireless signal, but there are no public signals in the area to get a reliable connection.

    Other suggestions?

    Thanks again for your help!
  20. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Make sure the wireless switch is off.

    Download the new driver on another PC and transfer it on a rerecordable CD or flash drive.

    Follow my suggestion to set the Default Gateway address manually.
  21. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    There is no physical switch on the computer for the wireless network, but I disabled the connection in the network connections section.

    I tried to reset the default gateway, but it says I can't proceed without also entering an IP address and subnet mask. I am supposed to enter all the numbers from the working computer's ipconfig?
  22. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Yes, enter all the numbers.

    Did you install the new driver?
  23. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    Hi Mark, I entered all the numbers and rebooted and still no connection. I haven't been able to install the new driver, is that a major issue?
  24. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Why? what was the problem. This may fix the issue if the driver is corrupted so it is important.

    (Nice to have the thread back to normal, thanks Admin)

    Have a look in the Device Manager, right click on the Broadcom device and select properties, under the general tab check the text box says, "This device is working properly" If there is an error message post back with the details.

    If you still cannot get a connection after installing a new driver then follow this link to reset the internet settings.


    Finally from the search box type each of these commands and hit enter after each one.

    ipconfig /release
    ipconfig /renew

    Now tell me what happens.
  25. tupelohny71

    tupelohny71 TS Rookie Topic Starter

    I'm having an issue with the driver because the only option it presents is for me to install it on the good computer, which I do not want to do. This may be a simple step that I am missing, but how can I bypass dell's download manager which only wants me to install it on the connected computer?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...