PC thinks CD Drive is Floppy...

By Ziyonex ยท 9 replies
Dec 5, 2006
  1. Hi all, read and searched the forums for my problem with no success... so I am now posting.

    This is my first home-built computer. Everything is working great, except my CD Drives. I have two drives, a CD and DVD burner, both of which get power and are able to open/close, even through the computer.

    I have toyed around with the jumpers on the drives, changing the top one to master, bottom one to slave, no success. Changed both to cable select, no success. I do NOT have a floppy disk drive.

    I have tried messing around with the device manager, uninstalling the floppy drive and restarting, but still no success. I have a feeling I am not doing something right with the jumpers, or maybe not, could someone give me some insight please? Thanks a lot.

    - Andrew
  2. frankibo

    frankibo TS Rookie Posts: 67

    Try first it with one of your optical drivers. After you see it works you put the second one on slave before you plug it in. If you have one for sure that you know the jumper is correct use that one.
  3. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Thanks, never thought of that, I'll give it a try.
  4. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Didn't work, I tried hooking up the first optical drive alone, tried all jumper slots. The drive itself worked on all 3, but it wouldn't detect a CD. I was able to eject the drive by right clicking the drive in My Comp, but other than that it doesn't do anything. When that drive is installed there is a Floppy Drive icon and a Cd Drive icon in My Computer... I think it may be a problem with the drive itself... because I already installed and updated the software to go with it. Maybe this is a problem other people have experienced??

    Edit: I can also hook the other optical drive up singularly and it will work, no floppy drive detected. It's just when I hook up the other one it detects a Floppy Drive and a CD drive. Like I said before, the CD drive is only good for ejecting the disk, it doesn't detect any CD, it tells me to insert one.
  5. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Are you saying that the Drive is identified in Windows as the :A: drive..?

  6. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    How are the drives showing up in the bios? Are they even showing up in the bios. Do you have the bios set to plug and play?
  7. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Alright, now I am not really sure at all now. I singled out my other drive (which supposedly had no problems) and now IT shows to be the A drive as well! Only this drive shows disks inside of it. I really have no idea.

    So both drives, no matter how I hook them up singularly, display to be both an A drive and a D drive (my main optical drive letter). I don't understand. I have tried changing the jumpers, the different ends of the IDE cable the optical drive is connected to, everything. I tried disabling the floppy drive in the device manager while one optical drive is installed. I have even been messing with my friend's computer, looking at his setup, and I have no idea why mine isn't working. Could it be the drive itself??

    I'll keep trying... Thanks for the replys

    Both drives show up in BIOS when they are both installed. I just checked the BIOS though, and it said it detected a Floppy Disk drive. BIOS is also set to Plug and Play, yes.

    Edit: If you did not catch it earlier, I do NOT have a Floppy Drive.

    OK, well I just went into the BIOS again and figured out that my CMOS battery reset and changed the Floppy Disk drive to 'enable'... so that sorta takes care of my Floppy problem... but I am still faced with the problem of the drive not working. I no longer have an A drive, just a D and E. I've tried updating the software and messing around with the jumpers, but I am beginning to think that it is the Drive itself. It just won't read anything. BUT it does eject the CD when I right click the icon and select 'eject' in My Computer. I don't know. Any suggestions?
  8. N3051M

    N3051M TS Evangelist Posts: 2,115

    Please use the edit button next time.

    Simple question, but have you tried using a different IDE data cable?
  9. Ziyonex

    Ziyonex TS Rookie Topic Starter

    Hmm, well I did recently change my MOBO stock IDE cable to a Round Cable, but didn't really hook everything up with the stock one. I'll try it and let you know. Thanks for the reply.

    EDIT: Tried different IDE Cable with no success... does the same thing as my new round cable. I am thinking it is definitely my drive...

    Again, for you guys who don't know what's wrong, my drive won't read CD's under any jumper configuration, but will eject itself from right clicking the icon in My Computer. Maybe it could be a problem with the laser inside??? I've been workin on this problem for 2 days and I still don't know exactly what the problem is. I'm going into the BIOS again to see if I forgot anything...
  10. N3051M

    N3051M TS Evangelist Posts: 2,115

    another question.. have you tried the drives on another PC you know works properly at its proper jumper setting?

    Try a different CD (not music ones because of the usual copy protected crap they try to confuse the pc with)

    try in a minimum barebones setup, just out of a whim.. you know>cpu/mobo, power, audio/video, 1 hdd (os) 1 optic drive
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...