PIO problem with DVDRW

By Ridgers ยท 4 replies
Jan 2, 2008
  1. If anyone could give me advice on this I would be most grateful.

    I have two DVD drives on my PC (2.4 Duo Intel + Nvidia), a DVDRW which is the master & a DVDROM which is the slave. They are connected via IDE ribbon cable to the single IDE slot on the motherboard.

    However the devices are set to PIO mode in device management, thus causing my entire system to slow up when accessing a CD. To make matters worse the drives do not even recognise DVD's and treats them as CD's. I can't burn anything to DVD as my devices are in PIO, as Nero 7 smugly informs me.

    I have tried all the methods i could find on the net to reset the drives to DMA. That includes opening regedit and resetting the 'bad burn' counter, uninstalling all the dvd drivers and re-installing them. Uninstalling all the IDE channels and letting XP reinstall them. I've checked the cabling and pin heads at the back of the Drives.

    Nothing seems to work. Would buying an IDE converter and switching the drives to SATA cabling work? My harddrive is SATA and i have five spare SATA ports. If not any other ideas?

    The DVDRW is a Lite-on LH-20A1H.
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

  3. Ridgers

    Ridgers TS Rookie Topic Starter

    Umm i'm 90% certain that the drives have always been stuck in PIO (i have only had this PC for a few months) and thus is not the result of the windows 'trap' of reading a bad disc too many times.

    The article mentioned BIOS which i have not tried as i would not have a clue of what to do. One guy in the email section had to buy an additional IDE controller card, perhaps i should try that?
  4. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Uninstalling the IDE channel under IDE ATA/ATAPI controllers always worked for me but I guess not for you. You could always try backing up your data and doing a fresh reinstall of Windows. I would try that before buying a controller card.
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I would go to MB website get the latest drivers from them
    check for new firmware for the Lite-on LH-20A1H
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...