Printing from Outlook 2003

By R. Ravenclaw ยท 5 replies
Sep 25, 2007
  1. When attempting to print from Outlook 2003, I receive the following error message:

    An error has occured in the script on this page.
    Line: 639
    Char: 1
    Error: Invalid argument
    Code: 0
    URL: res://C:\WINDOWS\system32\shdoclc.dll/preview.dlg
    Do you want to continue running scripts on the page? y/n

    I search the error on google and found possible solution,
    This behavior occurs if the Ole32.dll file that is located in the %Windir%\System32 folder is not registered correctly in the registry.
    Back to the top

    To resolve this problem, register the Ole32.dll file. To do this, follow these steps: 1. Click Start, click Run, type the following command in the Open box, and then click OK:
    Regsvr32.exe %Windir%\System32\Ole32.dll
    2. In the RegSvr32 dialog box, click OK.
    but it did not solve the issue. Can anyone provide something else I may try?

    Thank you for your time!
  2. k.jacko

    k.jacko TS Rookie Posts: 493

    can you not try downloading the Ole32.dll and re-registering it again?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    This is usually a printer install error. You may have to remove the printer. Then use a registry cleaner to clean up all references to the printer install. Then after a reboot, reinstall the printer.
    You might also check the printer manufacturer's web site for new printer drivers and patches. If it is a known error, there will be a patch posted to fix it.
  4. R. Ravenclaw

    R. Ravenclaw Topic Starter

    I failed to mention that the error does not occur every time I print, just with a few contacts, but always with the same contacts.

    Sorry for my ignorance, (I'm only in the IT field for one year) but from where would I download the Ole32.dll? From the MS site?
  5. k.jacko

    k.jacko TS Rookie Posts: 493

    google is your friend. But i'd prefer to download it from an MS source myself if possible.
  6. R. Ravenclaw

    R. Ravenclaw Topic Starter

    Thank you for your suggestions. I tried it, but had no luck. I posted my problem to a MS board and the fix there worked.

    I replaced the iepeers.dll with a known good one and then in the run box typed regsvr32 iepeers.dll to register the file.

    Problem solved! I thought someone else may find the info useful.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...