1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem with USB device

By rduff · 48 replies
Apr 25, 2009
  1. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Now this is getting most interesting….

    1) Just fyi,
    For Vista, when you look at Device Manager Details tab and use that pull-down menu, you can rt click to copy/paste the values you see (not true if someone's running XP)

    2) I’m quite curious about your firmware update comment
    Tell me more about this firmware...
    • Have you had to constantly re-install the firmware since day one with Vista?
    • Did the headset ever work under Vista before you ran the firmware upgrade?
    • Part of why i'm so interested in your firmware now is because of what i found in your regsitry!
    3) What I found in your registry dump (was quite the surprise)
    On the one hand
    • Device Manager shows a Device Instance Path that clearly indicates your headset driver's registry entry is
    • And the registry subkey FriendlyName currently= Micronas USB Headset is the entry that results in the device name you’re seeing
    BUT!! On the other hand!
    I also found a different device ID entry in your registry for a device with the FriendlyName = Sennheiser USB Headset! (see below. Scroll the code box down to the end)

    Now, i previously indicated that the Device ID never changes. (And it normally never does!)
    => But in your case it would appear to have changed from: VID_1395&PID_0002&MI_00 to VID_074D&PID_3554&MI_00
    => VID stands for Vendor ID
    => VID assignments are controlled by an international organization
    => VID_1395 is assigned to Sennheiser Communications A/S
    => VID_074D is assigned to Micronas GmbH

    Normally, Device IDs don't change EXCEPT now that i learned you've been applying firmware upgrades to your headset, i see how that's possible to have changed. Which also now plays into the big picture. As a firmware upgrade is the only way i'm aware of to change a device's Device ID (as its Device ID is programmed into it via the firmware in the first place!)
        DeviceDesc    REG_SZ    @wdma_usb.inf,%usb\class_01.devicedesc%;USB Audio Device
        LocationInformation    REG_SZ    0000.001d.0007.
        Capabilities    REG_DWORD    0xa4
        HardwareID    REG_MULTI_SZ    USB\VID_1395&PID_0002&REV_0004&MI_00\0USB\VID_1395&PID_0002&MI_00
        CompatibleIDs    REG_MULTI_SZ    USB\Class_01&SubClass_01&Prot_00\0USB\Class_01&SubClass_01\0USB\Class_01
        ClassGUID    REG_SZ    {4d36e96c-e325-11ce-bfc1-08002be10318}
        Driver    REG_SZ    {4d36e96c-e325-11ce-bfc1-08002be10318}\0007
        Class    REG_SZ    MEDIA
        Mfg    REG_SZ    @wdma_usb.inf,%mfgname%;(Generic USB Audio)
        Service    REG_SZ    usbaudio
        ConfigFlags    REG_DWORD    0x0
        FriendlyName    REG_SZ    [B][I][COLOR="Red"]Sennheiser USB Headset[/COLOR][/I][/B]

    So this issue is defintely related to the firmware upgrade (because your Device ID has indeed changed!) and possibly the driver update as well. Will get back to you with more.. and aside from my 2 firmware related questions above, anything else you noticed or recalled occuring between firmware updates and your headset behavior?
  2. rduff

    rduff TS Rookie Topic Starter Posts: 31

    No you're wrong...the name change is nothing to do with the firmware upgrade as it was correctly displayed as Sennheiser USB Headset until I updated the Realtek sound card driver.

    When first purchased the headset wouldn't work at all so had to install the firmware to ensure compatibility with Vista. Now it functions perfectly except every time it's disconnected the in line volume control and mute button stop working. I've always had this problem even before updating the Realtek software.

    I'm beginning to think that the problem is a conflict between the headset and Vista...there was no 'plug and play' for me when I bought it, which is what I thought USB was all about.

    Hope that answers your queries.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hmmm… I was speculating the firmware involvement in the changes of Device ID and Device name. This is above and beyond Realtek's driver change involvement. But forgetting speculation for the moment here's the facts as i've seen them

    The Sennheiser PC35 USB headset isn’t compatible with Vista without a firmware upgrade
    Specifically from Sennheiser:
    => We know this both from the Sennheiser upgrade software itself (quoted above)
    => And the many posts from people who can’t get their PC35 to work on Vista without the upgrade
    fyi Plug and Play only works when
    required PnP pieces (like drivers, the firmware, device IDs and more) are in place and things occur in proper sequence. Generally this is what happens
    • USB device is plugged into the PC
    • PC hardware detects connection to the USB device hardware on the USB port
    • PC then “pings” the device for its Device IDs (using standard USB protocol)
    • USB device responds to PC with its Device IDs (also using standard USB protocol)
    • PC looks for a suitable driver using the Device IDs received. The driver allows the PC to go beyond using just the limited USB protocol to fully support device functionality
    • Look again at the device’s Details tab in Device Manager, you’ll see the IDs the PC received from the device: Hardware IDs and Compatible IDs. Note these IDs are independent of and no involvement to any driver at this point. Driver matching occurs in the next step
    • Details tab also shows Matching ID. This is the ID Windows actually matched for the driver it picked. For your headset my best guess is Matching ID is to one of the Compatible IDs (i.e. meaning its using a generic driver)
    • The registry is updated to reflect the USB device installed and its driver info

    The forensic evidence in your registry shows that over time its installed two USB headset devices
    The headsets have different IDs They’re both “enumerated” under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\
    VID_1395&PID_0002&MI_00 has device FriendlyName Sennheiser USB Headset
    VID_074D&PID_3554&MI_00 has device FriendlyName Micronas USB Headset​
    Your USB headset is currently sending your PC the ID VID_074D&PID_3554&MI_00
    This is what we see find from the Device Instance Path in Device Manager
    => At sometime, somehow a USB headset also sent your computer the ID VID_1395&PID_0002&MI_00 because its appearing your registry as an enumerated USB device (I can only speculate why as maybe due to firmware changes (or you ever connect a different USB headset?)

    But regardless of all the above, you can simply try the registry edit if you want. Edit FriendlyName to whatever string you want but i think may have vista permission issues. Try this
    • Shut down computer then unplug your headset
    • Restart computer (i'll say try it in SafeMode but maybe normal start mode ok too)
    • Open registry editor. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_074D&PID_3554&MI_00\
      Rt click 7&84b63cc&7&0000 and select Permissions. Check box for Full Control then OK
    • Now try to edit the FriendlyName
  4. rduff

    rduff TS Rookie Topic Starter Posts: 31

    That sounds much too simple...and yes it was since access is denied when trying to select permissions!! What do I do now?
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    So close but still no cigar! And like i said earlier, Windows (especially Vista) doesn't make nuthin easy!

    I have a couple ideas but at this point i think it best to wait till i can borrow a friend's Vista computer to test the ideas i have directly on Vista first before having you try it (Till now i been remote logging in to a Vista computer to do things which limits just exactly what types of things i can do/test/try remotely. e.g. i can't remote login when vista is in safe mode.) I only have XP computers at my own home)

    So gimme a coupla days but will get back to you..

    As an aside, i'm really puzzled then just how it might have happened that your registry contains two headset devices with different IDs for each. If not the firmware, have you ever connected a different USB headset to your computer??? just wondering. as i may not know how it happened but your registry definitely shows that's the case
  6. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Yes I used to have a Logitech headset, but as I've said before the naming problem only became evident after updating the Realtek sound card, which very helpfully couldn't be undone via system restore.

    I'll wait to hear from you.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    hmm... one quick thought (don't know why didn't occur to me before at least to try, duh)

    open device mgr, rt click your USB audio device, click button to try rollback the driver. see what happens
  8. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Can't do that as it's greyed out. What about uninstalling it instead?
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    I still need to manage time to physically (vs remotely) try stuff on a Vista machine but check this out!

    It appears that Vista, by default, at least on a coupla other Vista machines i (remotely :) ) looked at, has Device Manager setup logging enabled.

    Translation: A historical log may exist and being kept of all your device install/uninstall attempts! We might be able to see the date/time of both those two headset items in your registry as well as just when they were wrt to the Realtek driver updates

    To check:
    1) You need first stop vista from "hiding" files from you. Control Panel->Folder Options-View tab. Scroll down the check list you'll see and
    => Check the option Show hidden files and folders
    => Uncheck Hide extenstions for known file types
    => Uncheck Hide protected operating system files
    => Click OK

    Now you can use Explorer to look in C:\Windows\inf for file setupapi.dev.log (i don't care about other file setupapi.app.log)

    Open the setupapi.dev.log file, position cursor at start of file, try ctrl-f to find each of the two Device IDs in there (just to check they were both logged in there)
    look for VID_1395&PID_0002 and also VID_074D&PID_3554.

    If they're there and you'd like me to have a look in that file for any interesting evidence and further i'm guessing we'll need to upload it to a free server (techspot restricts you to 200KB per attachment and i'm gonna guess the .log is huge)

    Let me know. Either way will also let u know when i can get hold of a vista machine to try things out when physically co-located with it
  10. rduff

    rduff TS Rookie Topic Starter Posts: 31

    I've found the file you requested (although it's called setupapi.dev.log). Both Device ID's are logged but as you say it's pretty big and I have no idea what any of the information means.
    Go to www.humyo.com and log in with the user name Richard Duff and email address rduff@fastmail.fm (which you can also use to contact me directly).
    Thanks again for your help, although it seems to be a lot of hassle just to solve a minor problem...still you did say you liked a challenge!!
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Some people like spending time working on the New York Times Sunday crossword puzzle each week. This is just my version of a Sunday crossword puzzle

    Also, it's an "extra" challenge to find yet another way (and reason why) Windows does things different then what i've otherwise seen/known it to do!

    If i finally need to just give-up (and sometimes i do) will tell you... And you too if you get there before me before we figure this darn thing out! ;)

    As to your file, i can't seem to logon to that site. You mention user/email, site says it wants email/password though i tried both ways (and with / without a blank between first and last name part) yet still can't logon??? :confused:
  12. rduff

    rduff TS Rookie Topic Starter Posts: 31

  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Quick question before i look at the log file further.

    Here's a brief summary of interesting date/times (time is hh:mm, where hour is 24 hour clock time). Wondering if they "line up" / make sense / seem to coincide with events as you recall them??

    Your Vista Device Setup Log: begins on 2007/08/01 10:56
    Sennheiser USB Headset: first appears 2009/02/20 16:15
    => Maybe this was its first install?
    => Did you maybe connect it using a USB port integrated into your keyboard? maybe a Compaq keyboard??

    Micronas USB Headset first appears 2009/04/17 18:13

    Do you recall about when (and if around the dates above?) when
    => you did the Realtek update?
    => you first plugged in the headset?
    => you first ran the firmware upgrade?

    /* EDIT */
    Hmm... and i see the first Sennheiser driver update: 2009/04/14 03:18
    /* EDIT2 */
    And this 4/14 date must be the first time you upgraded the firmware i think??? as i also see (for this case) the following
    (And you musta been up late! 'cuz the time stamp on the update is 3:18AM!! ;) )
          cmd: "C:\Users\My Folders\SOFTWARE\DOWNLOADS\SENNHEISER\Sennheiser_PC25PC35_Updater_0.7.3.0_new.exe"
    /* EDIT3 */
    Guess what! Found your Realtek Update occurred at 2009/04/14 03:22
  14. rduff

    rduff TS Rookie Topic Starter Posts: 31

    I'm always up late, so 3.18am is not a surprise!!

    Regarding your queries, I bought the PC in December 07 but was using a Logitech headset so the Vista Device Setup Log must refer to that. It was replaced with the Sennheiser in August 08, but as I've already told you, wouldn't work until the firmware update was installed so in fact this dates from the same time. I can't remember exactly when the Realtek driver was updated, but April this year sounds about right. It's interesting that according to your observations the Realtek and Sennhesier update took place within 4 minutes of each other on 14th April....surely that can't be a coincidence?
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    A bit more “forensic analysis” of your data. Then something to try!

    Device ID change
    Two things are clear
    => The device name changed at some point (as you noticed yourself when you started this thread!)
    => Your headset’s Windows Device ID somehow changed as of last April as this timeline indicates (note your headset's device ID each time)
    Feb 20 16:15:21   Headset Device Install      USB\VID_1395&PID_0002
    Feb 21 20:31:10   Firmware Upgrade            USB\VID_1395&PID_0002
    Apr 14 02:43:11   Headset Device Install      USB\VID_1395&PID_0002
    Apr 14 03:18:03   Firmware Upgrade            USB\VID_1395&PID_0002
    Apr 14 03:22:26   Realtek Upgrade	
    Apr 17 18:13:12   Headset Device Install      USB\VID_074D&PID_3554
    I’m stumped to explain the timeline wrt Device ID change
    • I know the timeline seems to point to Realtek
    • But based on what all I’ve read / understand things to work, I can’t explain how Realtek could possibly change it :confused: (vs. I know how firmware can do it)
    • So that leaves me stumped wrt how the Device ID changed! So, at this point, will just accept that it (somehow) changed and give up on figuring out just how/what and why
    Realtek Upgrade
    Yes, it is interesting that it occurs within minutes after a firmware upgrade. But that also begs the question "How did the Realtek Upgrade get started in the first place?" Do you recall what you were doing/ what you did to start the upgrade?
    => Was it part of a Windows Update?
    => Or do you recall manually downloading the upgrade and invoking it??
    => Or other???​
    Sennheiser Firmware Upgrade
    just fyi.. to "close an interesting loop" that goes back to one of your early posts!
    • Look at this old press release "Micronas chip puts audio into USB headset connectors" about it's UAC355xB USB audio chip
    • I took a closer look at the Sennheiser firmware upgrade download. When you run the upgrade it creates a driver file named customer.inf. This gets installed as one of your Vista drivers.
    • Now understand that driver installation files ( .inf files) that don't come as part of Windows itself (but are OEM drivers that people install in addition to Windows' own drivers) are renamed when Windows installs them. They get filenames of the form oemnn.inf where nn are simply digits assigned to create a unique filename
    • I didn't recognize it for what it was at the time, but you actually found an instance of customer.inf AFTER it had already been installed on your machine (way back at the beginning of this thread!!)
    • Look back at post #11 at file in your attachments oem6.inf! Turns out it's a driver for the Micronas audio chip in your Sennheiser headset!
      Name		Oem6 
      Folder		inf (C:\Windows)
      ; Micronas [COLOR="Red"]UAC355x[/COLOR] Filter Driver Installation Script
      ; Copyright (c) Micronas GmbH
    • And, btw, if you look at the end of oem6.inf (aka customer.inf) you'll see the ONLY 4 Device IDs this Micronas driver defines (i.e. it'll work with) (even more reason i can't believe Realtek knows these IDs let alone can change to these IDs)
      ; **** Customer device define here ********
      USB\VID_Vend&PID_Dev1 = USB\VID_1395&PID_3554  ; old mixed
      USB\VID_Vend&PID_Dev2 = USB\VID_1395&PID_0001  ; Mono Headset
      USB\VID_Vend&PID_Dev3 = USB\VID_1395&PID_0002  ; Stereo Headset
      USB\VID_Vend&PID_Dev4 = USB\VID_074D&PID_3554  ; Micronas
    What next
    (Remember you need to set Windows folder options (per my prior post) to not hide stuff or you won't find/see all your folders and files)
    See attached .pdf file for instructions on how to search for text through C:Windows\inf and all its subfolders.
    => You can also manually look (or attach) specifically ks.inf as it contains your media descriptions/definitions
    If above fails to provide anything good, i got a registry script to try before i think we near the end of this rather interesting road (hope we get that cigar!) ​

    /* EDIT */
    One thing to add about how your device ID changed, is that is possible that FIRMWARE upgrade is the cause as i still think. And might be that the change doesn't take affect at the moment that firmware upgrade ran but rather the first time the headset was unplugged then replugged! (which would then explain the timeline
  16. rduff

    rduff TS Rookie Topic Starter Posts: 31

    OK...files uploaded as before but to another Humyo account
    Email richardduff@fastmail.fm
    Password techspot

    I think the C:Windows\inf search resulted in the same setupapi.dev.log as before. Also attached is a screen print of the search results for ks.inf, but not sure if I did what you wanted.

    You are convinced this is something to do with the firmware, whereas I believe it is related to the Realtek upgrade and the fact that one seems to corrupt the other. The firmware was installed about 6 months before the upgrade but the naming issue only became apparent afterwards. Interestingly I have tried reinstalling the original Realtek driver from my PC's system restore facility (currently v 2.21, before 1.69) yet once connected Micronas is still shown, so whatever has changed would appear to be irreversible.

    Perhaps the easiest solution is simply to buy a new headset!!
  17. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    LOL i agree wrt to getting a new headset :haha: BUT

    wrt firmware vs. Realtek Upgrade
    • You're thinking of your first firmware upgrade! Look again at the timeline. You ran a second firmware upgrade just minutes before Realtek upgrade
    • The device ID at moment / beginning of 2nd firmware upgrade is still the OLD device ID (of course) but once firmware upgrade is finished we frankly don't know if it changes after the 2nd firmware or your Realtek upgrade you started shortly after. (but, again, i can't imagine Realtek modifying any vendor's hardware device ID OTHER THEN their own Realtek hardware IDs
    • It's quite possible (even likely!) that even if ID chang was result of the 2nd firmware upgrade the actual change in the headset's device ID wouldn't take affect until the next time you had actually removed then reinserted your headset plug (vs. when the firmware upgrade s/w finishes)
    • I don't know.. but am guessing and curious... Did you download the firmware from Sennheiser again when you ran that second firmware upgrade just prior to Realtek
    • /* EDIT */ Added fact to know: Those device IDs aren't the result of corruption. The IDs your computer sees are whatever IDs have been programmed into the devices themselves! So while it's not impossible i just can't imagine Realtek applying a firmware change to your Sennheiser headset!
    Your search for Micronas text
    • Are you saying that the setupapi.dev.log file is the ONLY file match?
    • Did you following my directions in the .pdf?
    • Because that C:\Windows\inf\oem6.inf should also still exist in the directory AND we know it also contain Micronas text SO it should also have appeared if the text search if done right
    Last but certainly not least
    I think have the Vista registry edit solution! (And might be just for a minor tweak now for your USB headset name change but good to know how to circumvent Vista registry permission issues in the future!)
    1. Run regedit (I'm assuming your userid has Admin rights)
    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_074D&PID_3554&MI_0 0
    3. Rt click on the key 7&84b63cc&7&0000 and select Permissions
    4. THEN click the Advanced Button, then the Owner tab
    5. Select your userid under Change owner to: then click OK
    6. Click to highlight OWNER RIGHTS, check Full Control then OK
    7. You should finally be able to edit FriendlyName!
    You'll note i renamed my friend's Maxtor drive! (and i did it remotely btw :D)
  18. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Hi again
    Sorry for the delay in responding but I had visitors staying for the last few days and it was difficult to leave them in order to edit the registry!!
    The good news is that I was able to amend the friendly name to Sennheiser USB Headset in Device Manager. The bad news is that the change does not seem to have had any impact on the Realtek driver so when clicking on the little loudspeaker icon in the system tray, Micronas USB Headset still appears under playback devices.
    With regards to the report you would like me to run, can you please specify exactly what you want me to do as I've got a bit confused with the various requests.
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Stop. Reset. OH! :D

    All this time i've been thinking you' were referring to the name appearing in Device Manager! That's where i focused (sorry if i misunderstood).

    Tho all not lost as at least (for me) have learned the trick to Vista registry permissions and a bit more about its drivers.

    But back to the business of name change! I'm not surprised to learn that the notification icon name may stored independent of the registry entry we edited. As that section of the registry is used for Windows services/drivers (e.g. for a USB enumerated device) (vs. its iconic user interface)

    I'll take a look at Vista icon names. (tho just in case, have you rebooted?) just in case the name is copied at reboot for icons vs. we can see the name change is immediately applied in the case of Device Manager
  20. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Yes I've rebooted but to no avail, and also unplugged & reconnected the headset. The Micronas name was shown in two places....in Device Manager, which is now rectified, but also in playback devices accessed by right clicking the small loudspeaker icon in the system tray. I would think this is a function of the Realtek sound card driver rather than a Vista icon as such, and brings me back to my original view that somehow the Sennheiser firmware and updated Realtek driver are somehow incompatible.
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Looking at things as I’ve had the time…. Here’s an update

    Notification Icon Text
    >> The icons you see in lower right along your Windows task bar are called “Notification Icons
    >> I’ve found the information (and text) for the notification icons for the current logged in user are stored in
    >> But do not try to edit this key!
    Unlike the “FriendlyName”, trying to edit/change TrayNotify might result in a system crash (The TrayNotify format isn't publicly documented. And windows could change anytime they want. While we might guess its format, we could be wrong and/or it simply change which might cause registry corruption and a crash!)

    Then how change text for this case? Either
    • Programmatically. Means figuring out Vista's script/program interface which allows one to set icon "properties" including its text label
      >> might turn into to a lot (i.e. too much) work. But will explore it a bit to see
    • By reference. Whichever script/program runs normally now when you start Vista is assigning the text label “Micronas USB Headset” it is finding somewhere – if only we could find where that “somewhere” is to change it!
    For option b), here's step-by-step to look for Micronas text in the C:\Windows\inf directory

    1. Unhide Files
    Control Panel->Folder Options-View.
    >> Check Show hidden files and folders
    >> Uncheck Hide extensions for known file types
    >> Uncheck Hide protected operating file systems

    2. Validate Micronas search result when you do the search
    I think a valid search should result should include these 2 files in the result
    You can open/check the 2 files to find Micronas text to prove so (and prove you did the search correctly)

    3. How to search for Micronas in folder C:\Windows\inf

    >> Note the special “Windows” key in lower left of your keyboard
    >> Hold down Windows and ‘f’ key at the same time to get Vista search
    >> Click on Advanced search (should be in upper right)
    1. Check the box Include non-indexed, hidden, and system files
    2. Click the pull down arrow for Locations. Select Choose search locations. Then click on the arrows to expand and select Computer->C:->Windows
    3. Click on the folder named inf (you should then see the folder and its subfolders and files automatically all get checks in their check boxes!). Click OK
    4. In the search box (the rectangle in upper right) enter Micronas
    5. By default windows looks for folder names so it will say “No item matches” BUT click where it says Search in File Contents

    What are the files it then lists?
  22. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Hello again & thanks for the update. I ran the search as directed but there was only one file
    - setupapi.dev.log - which you've already seen. What do you suggest now?

    Forgot to tell you that Skype also recognises the headset as Micronas, so changing the friendly name made no difference.

  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183


    Sorry for taking such a long time to reply... (Lots of distractions here.. including just being summer! Hope you're enjoying a good summer as well - assuming you're in the same hemisphere as i am!)

    Here's a bit more info if only for the "what it's worth" department as i'll admit i'm ready to resign to defeat to this Windows mystery for your specific case.

    As for FriendlyNames
    >> FriendlyName should reflect the name that appears in DeviceManager display (Click to look back at post #42 as you can see I renamed one of the disk drives listed in Device Manager to a “Maxtor Full-of-Baloney drive!

    As for the text displayed when you hover the mouse above notification icons
    >> I believe notification icon text for all the icons are stored in
    >> But advise do NOT try changing this particular registry entry by hand
    >> An icon’s text can be changed programmatically by setting the text property of the Notify Icon (see http://msdn.microsoft.com/en-us/library/system.windows.forms.notifyicon.text.aspx)

    But i'm not going to try going any further down that path... Hope you have less grief when you buy your next Sennheiser USB headset!
  24. rduff

    rduff TS Rookie Topic Starter Posts: 31

    Thanks for the update. Sorry we haven't been able to resolve this query but it's been an interesting journey.
    All the best.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...