Probs with Windows 95

By JonB · 18 replies
Jun 20, 2005
  1. Hi all, i'm new to TechSpot!

    My prob is i'm getting the following when booting up:

    "A device file that is specified in the SYSTEM.INI file is damaged. It may be needed to run windows. You may need to run the windows setup program again. If the file is included in another software package, you may need to reinstall the software package that uses the file. C:\WINDOWS\VMM32\NTKERN.VXD Press a key to continue"

    nb Using following spec;

    CPU: pent 3. MBrd: J-MARK J-9BXAS. Mem: SDRAM 128mb PC133. HDD: 2gb Win 95. CD-ROM: CD R/DVD R. FDD: Standard.

    Help appreciated, regards Jon
  2. JonB

    JonB TS Rookie Topic Starter

    So, i've since altered my bios to boot from CD-ROM, but even though it recognises the CD-ROM drive in the BIOS it reports 'failure' when attempting to boot from CD-Rom drive (NB no known probs with the Win 95 disk).

    Then altered BIOS (Award V4.SIPG by the way) to boot from my bootable FLOPPY (A drive of course), and i get: "IDE/ATAPI CD-ROM Device driver Version 2.11 17:38:39 06/07/96 Illegal operation encountered: D:CD01 CD-ROM drive not found #0 found on 178h port device, v1W29.
    A:\>A:\MSCDEX.EXE /D:CD01 Device driver not found: 'CD01'. No valid CDROM device drivers selected

    nb contents of my bootable floppy are :bounce: ;

    (nb the setup file installs v330_11c.sys to c:\cdrom, which i thought was a universal cdrom device driver)

    but when i try at a:\ prompt to cd to d:\ or c:\ i can't do it!

    so still cant seem to even get PC to read CD-ROM with WIN95 so as to reinstall.

    Took out floppy and rebooted, but now getting: "Your multi-function device (standard dual PCI IDE Controller) has some child devices using 32-bit drivers and others using compatible mode drivers. this configuration is not supported, so your computer has been halted to avoid corruption. After you restart your computer, windows will use compatibility-mode drivers for each child device attaced to this multi-function device. if you want to use 32-bit drivers, you may be able to obtain an updated driver for the device that caused the problem by contacting your hardware manufacturer, or you can disable the device. press any key to continue".

    Ddoes this mean that my o/s installed may only have a file system of 16-bit?
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go to and get a fresh W95 or W95b bootdisk file.
    Set BIOS to boot from Floppy first.
    Then start from floppy and select 'with CD support'. See how that goes.
    Could you have flashed the wrong BIOS version?
  4. JonB

    JonB TS Rookie Topic Starter

    Thanks for your help. I did get a 'w95b' boot disk from this site the other day and have tried that too. But, i'll get the 'w95' one (ie as my win95 cd-rom is an orig with no serv packs) and try that.
    But, this blxxdy new PC i purchased last week (Packbell)..bios hasnt got FDD/FDC facility even though mBrd has controller for FDD (arrrrrhhh-so back to the internet cafe to get me floppy!). i'll post result later, ta
  5. JonB

    JonB TS Rookie Topic Starter

    Hi RealBlackStuff,

    Got a 'win95a' boot disk, didn't fire up at first but when it did, windows 95 started to load (but didn't get to see a 'with CD support' prompt) and the same error then reappeared: "a device file is specified in the SYSTEM.INI...etc etc".

    nb bios i have: 'AWARD v4.51PG {2A6LGJ1F}, 'v.BX2100/BX2000 B07 03-29-2000' appears to be correct, ie as it was running OK with windows 98 at one time.
    Any other ideas?
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You did not boot from the floppy. You may have to tell BIOS to boot from the floppy drive before the hard disk.
  7. JonB

    JonB TS Rookie Topic Starter

    thanks, silly me-forgot to unpack the boot exe. so done so now, and when booting up with this disk (which contains following files);

    diskcopy (msdos exe)
    edit (msdos exe)
    edit (help file)
    format (msdos exe)
    sys (msdos exe)

    it just takes me to a:\ prompt (ie again no option to choose 'with cd rom support')

    From A:\ i then typed format c:/s <ret> then y to proceed with format (ie may aswell clear data on disk-as i have no requirement for data on this disk).

    But, following msg appeared;
    "Checking existing disk format. Verifying 1,989.65m Invalid media or track 0 bad – disk unusable. Format terminated"
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Go back to and get a W98SE bootfloppy.
    You need to copy its oakcdrom.sys and setramd.bat files onto your W95 bootfloppy.

    Then use Notepad and create 2 files, autoexec.bat and config.sys
    Copy these onto the W95 floppy as well. They have contents:
    That should give you a bootable W95-disk with CD-support.
    Try out D: or E: or F: etc. to find out which one is your CD.
  9. JonB

    JonB TS Rookie Topic Starter

    thanks, i have done as suggested, but can i check the contents of each file (config.sys and autoexec.bat) should be exactly as you have written? well except that the first line in config.sys should be ;
    device=himem.sys /testmem:eek:ff ??????

    please confirm, as alas still not booting to a cd-rom support prompt, now getting;

    loading windows 95....then
    loads oak tech cdrom device driver ok...then
    preparing to start computer...then
    (strangely?) ..."bad command or file name
    the windows 98 startup disk could not create a temporary drive for the diagnostics tool. this maybe because the computer has less than the minimum required extended memory.
    Path not found - :\COMMAND.COM
    MSCDEX Version 2.25
    Copyright (C) Microsoft Corp. 1986-1995. All rights reserved.
    Drive D: = Driver MSCD001 unit 0

    So, at A:\ typed 'D', then 'dir', then typed 'setup'.
    Routine check then performed (scandisk).
    Welcome to windows 95 set up splash appeared
    selected continue....
    clicked on yes re usual licence agreement
    started to go through the wizard mmm? should i select c:\windows as the directory to install windows 95?

    Your further help would be v much appreciated, Jon
  10. JonB

    JonB TS Rookie Topic Starter


    i selected c:\windows as the directory to install windows 95, it completed, but when it rebooted i'm back to square 1, ie as per my first post "..device file that is specified in SYSTEM.INI file is damaged..." etc etc

    Is there any way i can check and edit the contents of this ini file to what they should be for win 95? ie from dos prompt (i'm not a dos expert by the way)?
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    When you get the A:\> prompt, you should first delete everything on the harddisk.
    Or easier, re-format it again by typing in: format c: /s /u and hit enter.
    This wipes out your harddisk.
    Then type D:\setup and hit enter. W95 will do the rest.

    Never mind the errors during bootup, you have the CD-support and you can work with that.
  12. JonB

    JonB TS Rookie Topic Starter

    :approve: I did as you said, but alas the same error message after completing set up and reboot.

    Hit any key to continue and although started to install plug and play, next errpr appeared as previously explained "..error loading explorer.exe. you must reinstall windows..." pressed OK but, "...the EXPLORER.EXE file is linked to missing export SHLWAPI,DLL:SHRegGetUSValueA." appeared again.
    (Knackered..gone to bed)

    GOOD MORNING, oh it gets worse! i decided to flash the BIOS last night..seemed to go successfully, but would not reboot!!
    So, removed CMOS Batt, 20-Pin MBrd adaptor and put CMOS Jumper onto CLEAR setting (all overnight)...Put 'em all back this morning...CMOS Batt, 20-pin adapter and CMOS Jumper in right place.
    Fired up and could i get a beep..NO Could i get a display to Monitor..NO

    Arrrr HELP have i truly fxxxed th Board or Chipset. Is there any way out now? :knock: JonB
  13. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Did you make a backup of your old BIOS before you flashed?
    You probably flashed the wrong BIOS or you interrupted the flashing. In both cases you'd need to try and do a 'blind' flashing, by booting from your floppy, that must have only the system files, flashprogram and flashfile on it.
    Write down the flash-instructions and the names of the flash-program and file on that floppy. Boot from it, and type in the instructions. Come back after 10 minutes, click whatever you need to click as per instructions, remove the floppy, and try to reboot.

    I think though that your W95 CD is knackered (or not legally obtained...)
  14. JonB

    JonB TS Rookie Topic Starter

    Yup! i did make a back up to floppy of the BIOS present on the system before flashing. But, i'm not sure it's even getting to the stage when it reads the floppy drive-i'll try though, when you say boot from a floppy i pressume you mean with usual win95 boot system files + the saved bios (original) + the flash program ???????

    nb Win95 CD may well be knackered, but its def an orig complete with original booklet and cert of authen.
  15. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Yes, that's what you need.
    Borrow someone else's W95 CD, as long as you use your key. that is perfectly legal.
    Why don't you try W98SE instead?
  16. JonB

    JonB TS Rookie Topic Starter

    naah, nothing, seems to recognise cd-rom drive, ie light on and whirrrs away, but floppy driive ...nope. looks like either my cmos chipset is fried or ???
    ie nothing at all to monitor and no 'click' from floppy.
  17. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I hope your garbage bin is big enough! Or make a donation to a museum.
    Your messing with the BIOS nicely killed the mobo. Why did you do that in the first place?
    Knowing not much (if anything) about PCs is not a reason to flash a BIOS!

    You can try hunting around for a replacement BIOS chip, but it's probably faster and cheaper to buy a new, more up-to-date motherboard.
  18. JonB

    JonB TS Rookie Topic Starter

    mmm i have been appreciative of offered help, but i'm afraid can't let you get away with that mate!
    Yeah, maybe i made a mistake (don't think so though). By the way i have flashed BIOS update before on another board and all went well.

    Per my 4th post reason i flashed BIOS was that since i bought the 2nd hand unit i noticed a sticker 'BX2000' had been placed on the board near the Board model number. I decided to investigate (especially as the BIOS screen displayed this BIOS version) which accordng to J-MARK is not listed as one of their BIOS's ie not for J9JBXAS board, but it seems a Gigabyte board!
    There's ya reason.
    And hey! Cheeky bugger! "..not knowing much about PC's.." I know a bit, not enough of course, we are all learning. Maybe you know it all eh?
    As long as i have a hole in my *** i'm still learning!
    Yeah i have taken exception to your comment, i was working in IT as an analyst/tester for a dealing system for a number of years until recently being made reedundant, so just a little bit of respect please.

    Hope we can still comm, 'cos i forgive and forget. I'm Irish too by the way. Yeah one of those born in England who considers himself Irish!
  19. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    No offence meant, but all your questions sofar show that you have little knowledge about PCs and even less knowledge about operating systems such as Windows or even DOS.

    'working in IT as an analyst/tester for a dealing system' could mean anything; if that was a mainframe, it's quite different from a PC.
    A dealing system is rather vague, is that a parts department management system for e.g. car dealers, or a yoke that can 'deal' a deck of cards? Whatever...

    Don't get me wrong, I'm not knocking you or your amount of knowledge.
    That PC sounds to me like the proverbial 'old bike on which you learn how to ride'.
    W95 is over 10 years old and supported nowhere. It won't even run anymore on today's PCs.
    If (big IF) you get it up and running again, you should abandon W95, and go for W98SE. At least lots of people are still using that and lots of help is available, also online.

    In that sense, Best of Oirish!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...