PS2 Memory Card Wont save anything and puts it into corrupt data

  1. For the last few years I have been using my Playstation 2, it has been working really well, no problems. Then about 4 months ago I dropped my memory card ( out of my hand) and all the data corrupted. Okay rip data. That's fine, I'll just buy a new memory card of amazon. The new memory card arrived and everything was fine, I could save anything I wanted to. But now I cannot. I have no clue why.
    Things I have tried to fix it
    • spraying compressed air into the hole to clean the dust out (made sure no liquid was coming out of the can first :) )
    • sprayed the console with compressed air
    • tried to put the memory card into slot
    I have no clue why it will not work, This is the memory card I bought
    https://www.amazon.co.uk/PS2-Magic-...03&sr=8-2&keywords=ps2+memory+card+magic+gate
     
  2. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 2,688   +500

    Sorry,
    "We found 0 results for "Eaxus warranty"." (per Amazon)

    I think the most you can do is to check the possibility of returning the item to Em-Store (the seller) which is located in France.

    You may wish to try another brand.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...