Question regarding kernel 'CPU panic'

By Lokalaskurar ยท 10 replies
Aug 4, 2011
Post New Reply
  1. I often use Linux on one of my laptops, more specifically BackTrack 5 ( No 'funny' business of course ;) ) - currently when I try to connect to my household WiFi network (WPA, DHCP), the Caps Lock button starts blinking, and the machine halts completely.

    When I redid this using the Live CD, I got this peculiar message:
    "Kernel exception: CPU panicked"

    (Followed by the exact same symptoms as mentioned above)

    What in Notch's holy hat does this mean?

    I am not here to solve the problem, I just want to know what a "CPU panic" really is. Feel free to speak Nerd, I'm fluent ;)

    Any ideas?
  2. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    A kernel panic is basically the end result of a fatal error that the OS cannot recover from. You can get two types:

    1. Hard panic; usually the computer locks up and/or becomes unusable. It also can cause the numlock or caps lock to blink. This is what your getting.

    2. A soft panic; Usually its less severe, and the OS doesn't lock up or become unstable/unusable.

    The following link (click me) will provide you with more information and how you can look up the issue, or at least an insight if nothing more.
  3. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Exactly what I needed! (looks at log)

    Blast it. The Wi-Fi card drivers are ******* around once again... :mad:

    It worked seamlessly when I installed the OS, but it hasn't worked properly lately. I always seem to have two invisible processes running when in airmon-ng mode (aka. 'white hat mode') - and connecting to a Wi-Fi network always trigger the same panic.

    Anyway, thanks. This has in fact increased my total Linux knowledge quota; Aieee! :)
  4. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    It will likely be an update to the wireless drivers that has caused the issue, but its possible its another update.

    Turn wireless off, and connect to the LAN. Do you have any outstanding updates?
  5. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Patient resurrected

    To be honest, I don't actually know what that means :eek:

    I'll let you know that I'm writing this from my laptop, running BackTrack (user mode) - off a Wi-Fi network connection; patient resurrected.

    I looked up the same problem, but for another wireless card (also made by Atheros).

    Turns out I needed to download "compat-wireless-" - then type (from root mode);
    tar -xf /root/compat-wireless-
    cd compat-wireless-
    make install
    make unload
    reboot now -r

    I think I more or less updated/installed the necessary drivers.
  6. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    And it now works OK?
  7. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    Blargh! :mad: -- It stopped working 5 minutes ago! :rolleyes:

    Fact is, it did so when I connected just to update this thread.

    Now I'm really curious... I have repetitively restarted and shut down/started the computer - installed GIMP, used it as a normal desktop etc. It worked just fine until now! Odd...

    The error is the same (kernel panic), although I have yet to diagnose it.
  8. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    Atheros wireless cards are known to be an issue with Linux unfortunately. I thought they were more stable now, but clearly your having issues for some reason. :(
  9. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    They're not exactly stable running under the Windows NT kernel either :haha:

    I think I'll just stick with Windows 6.1 for now :zzz:
    Hmm... could it be worth popping up a thread in the Alternate OS?
  10. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    It could, but to be honest you might be best served by going to a Linux forum, as it will have likely been seen by others.
  11. Lokalaskurar

    Lokalaskurar TS Enthusiast Topic Starter Posts: 544

    It has been some time now, but I've swapped Linux distro once again.
    I changed to ArchLinux, and I got a comprehensible error log this time.

    Turns out the Ethernet and Wi-Fi handling are done completely separate from each other, although still by the same card.

    From what I can gather at the forums; when I requested to connect to a Wi-Fi network, the Ethernet portion did not halt as expected, but kept flooding the kernel with information. Add to this the Wi-Fi portion doing the same exact thing, and you get a complete overload from the Ethernet / Wi-Fi - I/O.

    Solution: disable the Ethernet I/O.

    Wi-Fi now connects perfectly, and hard-wired Internet-access is now impossible. Oh well, problem solved.

    Re-did this in the BackTrack distro (another hard drive), same result :) => Sunshine and Bunnies

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...