R40 Display

By Extreme ยท 11 replies
Apr 11, 2006
  1. I know this isn't exactly a Laptop forum, but you all have helped me in the past so I figured I would give it a shot.
    I have an IBM R40 laptop that for some reason won't display anything. The LCD does however, come on and it does light up, but won't display anything. I have hit the FN+F7 keys to see if it had placed itself into external monitor mode and that doesn't work. It won't even display the BIOS. So if anyone has a suggestion besides get a new laptop, please help.
    I don't think this is a hardware issue because the laptop worked just fine the day before. All I did was boot it up and I hit the FN key and another key (Of which I have no Idea) by accident and the display went out.
    Thanx in advance.
  2. Peddant

    Peddant TS Rookie Posts: 1,446

  3. Extreme

    Extreme TS Rookie Topic Starter Posts: 45

    Thanx for the reply, however I know what functions the FN key has and they aren't working. The LCD is on and lit up but has no display. It is just a lit up blank screen.
  4. N3051M

    N3051M TS Evangelist Posts: 2,115

    maybe you've locked the laptop? i've seen some laptops have a padlock symbol that you can activate with the FN key but dont realy know or used it...

    pressing the FN + display keys may cylcle you through the laptop's different display modes- maybe 3 types: LCD, LCD + EXT, EXT or something.. check that your display brightness/contrast is up? worth a thought.. i'd probably give every FN key a try if your bored enough at one stage (or fustrated :p)
  5. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Not to be rude, but there must be at least one key combination you don't know, since you say you think the problem arose from hitting <fn> + <unknown key>.
    So, have you tried using <fn> with <F1>, <F2>, <F6>, <F10> or <F11>, which are reserved combinations?

    Another thing to try, unless you just want to send it in to/call Lenovo, is to try all the different key-combinations that's possible. It'll probably take a while, but will be a lot cheaper than buy a new system.
  6. Extreme

    Extreme TS Rookie Topic Starter Posts: 45

    Thanx for replies
    I have tried everything I can think of
    I have hit the FN key with every key on the keyboard and nothing seems to do it, I am sorry if I came off rude earlier
    I did not mean to
    I am just frustarted with this machine
    I wonder if flashing the BIOS will help?
    Is there a way to flash it useing CD?
    IBM support sucks.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Unless it's still under warranty, I would suggest you open the laptop and check the connector(s) between the screen and the motherboard. Perhaps they have come 'undone'.
    When you add an external monitor, does that work?
  8. Extreme

    Extreme TS Rookie Topic Starter Posts: 45

    I have been trying to find an external monitor to hook up to see if it is stuck or something. But I am currently deployed to Iraq and they are far and few between here so.
    I took it apart though and unconnected everything including the CMOS battery thinking it would reset the BIOS and everything else but it didn't. I am just going to have to look a little harder for an external monitor.
    Thankx for all the replies and as soon as I fix this thing I will let you all know.
  9. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Good luck in your hunt for the CRT, and stay safe!

    Now I understand why you just don't send it to Lenovo support...
  10. Per Hansson

    Per Hansson TS Server Guru Posts: 1,960   +218

  11. Extreme

    Extreme TS Rookie Topic Starter Posts: 45

    Well it beeps now because I removed the CMOS battery and can't see the display to reset configuration in BIOS.
    But no, it didn't beep before this started happening.
  12. Per Hansson

    Per Hansson TS Server Guru Posts: 1,960   +218

    Ahh, okay, but then it works atleast... I guess your best bet then is to find an external montior afterall, happy hunting :p
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...