Realtek ALC88x and Intel 955X = no audio!

By danc
Oct 6, 2005
  1. OK, so I've tried three 955x boards now, all using the Realtek HD audio chips, and none of them have worked. I install the drivers, reboot, nothing happens. In Device Manager, it says unknown PCI device. The three boards were the Intel 955xbk, the Asus P5WD2 Premium, and now the ABIT AW8-MAX. Yeah, I'm getting real good at installing motherboards. The Abit board is the best, by the way. But why the heck won't the sound work? Using Windows XP SP2. I thought maybe it was the ATI PCI Express card that was messing it up, so I'm now using a GeForce MX 4000 PCI card. Still didn't fix it. Other than the video card, no other cards. Audio is enabled in the BIOS. I have just regular speakers, hooking to the computer with a line out plug and a mic in plug.

    Any help would be greatly appreciated. This is just very strange. Also, I'm using two SATA devices, a hard drive and a DVD-RAM drive. The CPU is a Pentium D 830. 1g of 667 MHz Non-ECC DDR2 RAM, forget the manufacturer.
  2. fig73

    fig73 TS Rookie

    Intel Audio Studio/Realtek Drivers

    Any luck figuring it out? I have same issues with Intel D915PBL.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...