Realtek Audio - Need Vista Regedit Help with Mic Unmuting Problem

By confusedmusikid ยท 8 replies
Jan 25, 2009
  1. (Apologies if this is posted in the wrong section)

    Hi, I've been doing some research and apparently this is a common problem: there is no sound from the speakers while using the built-in microphone (or any musical device plugged into the front panel mic input jack), although it does record (audible upon playback only, not in real-time), and there is no available option to unmute the mic. In other words I want my speakers to function as monitors.

    I've found some solutions in forums like this, but none that work for my setup. I have a Toshiba Satellite A305-S6858 running Vista Home Premium x64, SP1, using Realtek HD Audio driver

    First, I've already tried all the obvious easy fixes:
    -In "Sound>Playback>Speakers Properties>Levels", there are only volume sliders for "Realtek HD Audio output" and "PC Beep", nothing else. Both set to full volume.
    -In "Sound>Recording>Microphone Properties>Levels", the "Microphone" and "Microphone Boost" sliders are set at full volume and the microphone is enabled.
    -In both the playback and recording tabs, "Show Disabled/Disconnected Devices" are both selected. Changing default recording device from "Microphone" to "Stereo Mix" had no effect, so I put it back to mic.
    -I've also looked through literally every other sound-related menu page for anything relevant, with no luck.
    -I upgraded my Realtek audio driver to the latest available, but it made no difference.

    From what I gather, the only way to fix this is by editing the registry (I've already created a backup system restore point just in case I mess something up). I believe I found my audio driver in Regedit at this path:


    I'm new here so it won't let me post a screenshot I'll have to paste the resulting list here (name first, value data on the following line):

    name: (Default)
    data: (value not set)
    03 00 00 00
    00 00 00 00
    00 00 00 00
    00 00 00 00
    00 00 00 00
    00 00 00 00
    00 00 00 00
    data: 00 00 00 00
    00 00 00 00
    00 00 14 00
    00 00 00 00
    00 08 dc ff
    00 00 14 00
    00 00 fa ff
    00 00 14 00
    00 00 00 00
    00 08 dc ff
    00 00 14 00
    00 00 fa ff

    Can anyone please tell me what I need to change? Based on suggestions that worked for other systems, I've already searched the registry for the following with no luck: "MicV," "MonR," "DisableMicFromPlayback," "DisableMicSelect," "EnablePoPBypass," "EnableInputMonitor," "EnableIntSpkrMute." Once I get 5 posts here I can paste the actual screenshot if that would be helpful.

    Sorry for the long post, just trying to be specific. Help is truly appreciated since I NEED to use my laptop for recording and performing music, and all my expensive music equipment/software is worthless if I can't hear myself while recording! Thanks!
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm. have you seen this?

    The process/steps it describes seem pretty complete
    (and note the step where you must specifically enable speakers for playback)

    If you're saying you've followed those exact steps and still doesn't work, i would guess you have a different problem.

    As understand all these control panel steps simply make the registry changes for you
  3. confusedmusikid

    confusedmusikid TS Rookie Topic Starter

    Thanks for the response, that seems to be a different problem though (getting your computer to record the stereo mix of both what the microphone is picking up as well as what your speakers are playing at that moment). My problem is that although the mic is enabled and working (I know it records because you can play back the recordings with sound), no sound plays on the speakers while you're talking into it or doing the actual recording.

    For me, the problem with those directions you linked to is in the third screenshot down. In the Microphone tab of the Realtek HD Audio Manager, I have no "Playback Level" volume slider, only "Recording Level." (I wish it was that simple!) So essentially what I'm looking for with the regedit stuff is to be able to create exactly that option, so that I have a microphone playback level control or something similar. Because right now I definitely don't have it anywhere.

    So basically, if the solution involves something in the Control Panel under "Sound" or "Realtek HD Audio Manager", believe me I've probably already tried it...thanks though
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yes, i know what your problem is. But have you been carefully reading all the online material you been finding? ;)
    So ..
    1. Even tho the article's end goal is different it appears a spot on solution for you
    2. EXCEPT if you're saying everything else is identical for Sound Control Panel but that one option

    But rather than trying to get a registry hack i'd trying to identify the different Realtek codecs when this has worked vs. not worked to know if due to a fundamental difference in the codecs or not (i.e. you'll never get yours to work)

    Similarly, why no slider for you? is it codec model dependant? or what?

    Also, there's alot involved with hacking the registry of a product. You might be able to find sections based on an alpha search but reverse engineering the proper values so you set them just right is real task, Not saying impossible task, but something only a Realtek tekkie/audiophile might have done. If that answer does exist, probably better to target your question to forums dedicated or that at least draw heavy percentages of that type person
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    ^^^^^ Yes, good idea. Start by reinstalling all your sound devices. First check Add/Remove programs and remove any Realtek entries. Then check device manager to uninstall any lingering devices***
  7. confusedmusikid

    confusedmusikid TS Rookie Topic Starter

    Yes, that's what I'm saying. I did read it carefully :), it just didn't work for me because that option isn't available in my Sound Control Panel (or anywhere else it seems). I'm not sure why exactly. I haven't been able to determine from my googling if it's a codec-specific issue. I have Realtek ALC268 codec and I've used several different driver versions (including the latest) with no results.

    Thanks for the advice, I'll try removing all sound devices, etc. & reinstalling. Let ya know how that goes...
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    And whoever wrote that last blog seemed quite friendly.

    You might send them an email with info on
    - Realtek Sound card
    - Version level of sortware, etc

    and he mihgt supply some very userfuli info.
  9. ruisatriani

    ruisatriani TS Rookie

    ConfusedmusicKid, I have EXACTLY the same problem you have. I tried the basic and obvious solutions first, with no result. Then tried changing the REGISTER values (EnableInputmonitor, etc...) but my subfolders dont match the ones with the solutions, they are exactly like yours.

    ANYWAY, i also used to plug my electric guitar to the computer normally with Windows XP or 98, and now with a new PC (TOSHIBA with VISTA Home Premium) I cant find a solution for this!

    DID YOU MANAGE TO FIND SOMETHING THAT WORKS? Would apreciate your help if you did.... THKX! ROCK ON!!!!!!!!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...