Reformatted w/ XP, now getting BSOD

By midwestjps ยท 5 replies
Dec 4, 2008
  1. Every couple of times a year when my machine starts to run slow, I will reformat my hard drive and install a fresh copy of XP. I did it the same way I always do except this time when the OS booted up for the first time after the reinstall, I was greeted with a BSOD shortly after. I opened up the dump file and it seems to be related to the atapi.sys driver.

    Here is the dump:

    BugCheck D1, {60468b18, 2, 1, f749b04b}

    Unable to load image atapi.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for atapi.sys
    *** WARNING: Unable to verify timestamp for CLASSPNP.SYS
    *** WARNING: Unable to verify timestamp for Ntfs.sys
    Probably caused by : atapi.sys ( atapi!IdeProcessCompletedRequest+51 )

    Followup: MachineOwner

    kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arg1: 60468b18, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000001, value 0 = read operation, 1 = write operation
    Arg4: f749b04b, address which referenced memory

    Debugging Details:

    WRITE_ADDRESS: 60468b18


    f749b04b 094e0c or dword ptr [esi+0Ch],ecx




    PROCESS_NAME: IKernel.exe

    LAST_CONTROL_TRANSFER: from 804dce53 to 805266db

    b9ebb57c 804dce53 0000000a 60468b18 00000002 nt!RamdiskBootDiskGuid+0xbb
    b9ebb57c f749b04b 0000000a 60468b18 00000002 nt!KiTrap01+0xd7
    b9ebb620 804eb788 894a5030 8931a860 8945b9f8 atapi!IdeProcessCompletedRequest+0x51
    b9ebb630 894a5030 8931a860 00000000 b9ebb660 nt!IoReuseIrp+0xd
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    b9ebb640 804edd52 894a5030 8931a860 00000000 0x894a5030
    b9ebb660 f749a4fc 894a5030 8931a860 00000000 nt!CcMapAndRead+0x8c
    b9ebb68c 804eca36 894a5030 0031a860 f75b010c atapi!IssueAsyncAtaPassThroughSafe+0xca
    b9ebb6d4 804eca36 894669e8 f75c468c 8931a9f8 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb720 f7667b5a 00007000 00007000 89264600 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb740 804eca36 89420b48 00000000 894ab308 CLASSPNP!SetupReadWriteTransferPacket+0x133
    b9ebb760 804eca36 89420920 89264600 8926476c nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb78c 804eca36 89487c08 89264600 894ab210 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb7ac 804eca36 894c5b30 89264600 89264600 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb7cc baf7777d b9ebba98 894c5b30 3bce4000 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebb9a4 baf7929d b9ebba98 89264600 e10df718 Ntfs!NtfsCommonWrite+0x1e2
    b9ebba84 baf7916f b9ebba98 89264600 00000001 Ntfs!NtfsCommonRead+0xc52
    b9ebbc34 804eca36 89488020 89264600 894c5a48 Ntfs!NtfsCommonRead+0x4a6
    b9ebbc6c 804f0edd 894624f0 89463809 89463860 nt!CcAcquireByteRangeForWrite+0x68d
    b9ebbc8c 804f0d82 892d2b50 89463880 89463860 nt!ExpDeleteMutant+0x10
    b9ebbcfc 804ef157 89463848 00465718 c0001194 nt!RtlFindClearBits+0x19b
    b9ebbd4c 804dcc5e 00000000 00465718 01000001 nt!MiSwapWslEntries+0x164
    b9ebbd4c 00465718 00000000 00465718 01000001 nt!KiTrap00+0x5f
    0013f178 00000000 00000000 00000000 00000000 0x465718


    f749b04b 094e0c or dword ptr [esi+0Ch],ecx


    SYMBOL_NAME: atapi!IdeProcessCompletedRequest+51

    FOLLOWUP_NAME: MachineOwner

    MODULE_NAME: atapi

    IMAGE_NAME: atapi.sys


    FAILURE_BUCKET_ID: 0xD1_atapi!IdeProcessCompletedRequest+51

    BUCKET_ID: 0xD1_atapi!IdeProcessCompletedRequest+51

    Followup: MachineOwner


    It seems that atapi.sys is the driver for the CD/DVD drive, but I have no idea why I would be getting an error. Sometimes I will get the BSOD and other times the computer will just freeze (no mouse movement or c+a+d). Not sure if the two are related, but I hope this is the case so I don't have another problem to solve after this one. Anyways, any help is appreciated!
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    seems a faulty driver for atapi.sys. I am not sure if it is different for different motherboard chips, but I hope not - I suspect your problem is how your particular motherboard drivers interact with atapi.sys, but equally, it could be a bad spot developing on your hard drive. You should also run chkdsk /r and the manufacturers test suite first for the hard drive.

    The next thing you should do is clear out your pre-fetch cache.

    People seem to find their installs for XP (or anything really) from CD or DVD start to give read problems from the media after a few uses.

    Assuming no cure at this pint, I suggest you download a new motherboard driver set (on a good PC) and install them. If that does not solve the problem, a fresh copy of the Windows version of atapi.sys could be copied over from a floppy disk or CD. You need to be able to access your Hard driver by NOT booting from Windows to do this. A bootable CD image can be easily be found on the internet.

    The version of atapi.sys you want is :
    for SP2 5.1.2600.2180 95,360 bytes 3 Aug 2004.
    for SP3 5.1.2600.5512 96,512 bytes 2 Aug 2008
    It goes in c:\windows\system32\drivers and also c:\winsows\servicepackfiles\i386

    The reason the apisys gives an error, although your CD/DVD is not being accessed, is because it is loaded into memory at boot time, ready for use.
  3. midwestjps

    midwestjps TS Rookie Topic Starter

    Thanks for the suggestion. I forgot to specify that I only have SP1 as of now, but I'm going to go ahead and try to find the atapi.sys driver for that. I tried deleting the ATAPI controller in Device Manager so that Windows could automatically find and install the hardware and driver, but the system still freezes. Regardless, I am going out to buy a new laptop today and hopefully I can get this one fixed up to sell to a friend or something. Thanks again gball!
  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    SP1 ! Oh dear, you may never get this going without a slip-streamed SP2 install....

    The point is that motherboard drivers, video drivers and similar will nowadays be expecting SP2 at minimum, so it may not be surprising that there is a conflict - unless along with SP1 you are also installing only drivers dating from the same which case, a more likely possibility is hard drive faulty, as I already suggested.

    A tip here. If you are inclined to continuously re-install Windows, a much, much better approach is to take an image of the system after installing, configuring and proving out a mimimum setup. After that, you just revert to that image evry time, knowing it has saved you a few hours already, is proven to work, and so on.
  5. midwestjps

    midwestjps TS Rookie Topic Starter

    I was kind of thinking the same thing about SP1. I guess the trick is just getting SP2 to install before the system freezes. I've noticed that the freeze will happen sooner if I open up IE for Windows Update, so this could be a problem. Is there any way that I can download a setup file of SP2 on a different computer and run it on the problem computer to upgrade? It is a good possibility that it is the hard drive though because I have always reformatted and installed with the XP SP1 CD and used the same drivers that came with my computer at that time. After that I will install any driver upgrades after going through all the Windows Updates (SP2 and other critical updates). I'm not as worried about it now though because I just got a shiny new HP laptop to ease the pain! I'm never going to get around to fixing this thing now. Do you happen to know of a place like GeekSquad or Fire Dog where they will diagnose hardware problems for free or at a low price? I'm going to have to check this out......

    Thanks again gbhall


    dont go to geek squad. first off if you have used this disk in the past and it has worked then i would take the time to try re-installing windows. if the same BSOD returns, then i would try using Autostreamer (find it via google) to slipstream sp3 into your xp disk. of course this requires a working computer with a cd-burner and a blank disk. There are guides on the autostreamer site about this process.

    if you have a bootcd with utilities on it you can boot off that just to make sure drivers properly load for all of your hardware.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...