Tech Stocking Stuffers: 18 awesome gifts under $50

Replacing invalid security ID with default security ID problem

By Willster ยท 14 replies
Oct 29, 2011
Post New Reply
  1. Hey guys. Sorry to bother you with this but I need your help.

    Today I restarted my computer and came back to it and it was running a Chkdsk scan and for about a hour it was saying ' Replacing invalid security id with default security id ' for various different files.

    Now when I log in I can't play any music files, can't copy and paste any files, can't drag any files, the computer won't connect to the internet using wifi.

    I'm using windows xp, really need your help to get this fixed, I can't see a way ATM.

  2. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

    First, document the path to the files of concern. They are likely related to
    (A) \Documents and Settings\yourlogin\my documents.

    Find what user-id exist on the system: cd \documents and settings\
    and (B) every subdirectory is an account on your system.

    Now boot into Save Mode using F8 and log into an Admin account

    Naviage to the %userprofile% for your account eg \Documents and Settings\yourlogin\
    Take ownership of My Documents using
    1. right-click on My Docs->Properties->Security
    2. click on Advanced Button near the bottom
    3. click the Permissions Tab and
      • verify your login is shown OR
      • click ADD and insert your login and click CHECK NAMES (it must return your login or you've got a typo)
    4. click EDIT and mark it for Full Control
    5. Click the OWNER tab and select the ADMIN login you started with
    6. [x] replace ownership and apply (Giving the Admin all your files)
    7. click Apply
    step (4) ensures you can still manage all content regardless of steps 5-6

    ALL the NTFS settings for this directory will be rebuilt
  3. Willster

    Willster TS Rookie Topic Starter

    Thank you for your quick reply, I went through what you suggested and the problems are still there.

    Every file on the computer is effected with the problem even if I put a USB stick or hard drive in I can't copy and paste files on there or drag files on there etc.
  4. Willster

    Willster TS Rookie Topic Starter

    Actually ignore that last post, went through the steps again and it seems to have fixed it (fingers crossed).

    Thank you very much :)
  5. Alexsoltani

    Alexsoltani TS Rookie

    OMG I am having the same problem, I am returning this laptop to my job so I had all of my personal info transferred of the hard drive and when I tried to reboot it gave me the invalidsecurityid error, and now it deleted it looks like all of the company's files that I needed to keep on there!! I have to return this laptop in working condition or forego my severance, sorry please help me!! I will paypal for help ..
  6. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

    Print the instructions above and perform each step
  7. Alexsoltani

    Alexsoltani TS Rookie

    Jobeard, thanks for your reply first off, I appreciate it. I am showing as the owner and in full control along with the admin. It is showing me as the current owner. I have now changed the owner to Admin/AlexSoltani, applied the changes, and am now rebooting.
  8. Alexsoltani

    Alexsoltani TS Rookie

    It took me back to the same spot, it looks like, I logged in but cannot access or see any of my files.
  9. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

    You should have seen that the effective permissions were applied to This Directory and all Subdirs - -
    pls reverify.
  10. Alexsoltani

    Alexsoltani TS Rookie

    Should I replace owner on subcontainers and objects?
  11. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

  12. Alexsoltani

    Alexsoltani TS Rookie

    Last question before I do that!!

    I am showing current owner as administrators (alexsoltani-pc..\adminstrators.

    Change owner to (??)
    administrators (alex soltani)
    alex soltani (alex soltani)

    which one do I select, and then I will "replace owner on subcontainers and objects)
  13. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

    First, you are reporting YOUR PROFILE directory and NOT C: or the \Windows\* - - if so then:

    Looks like alex soltani is has admin rights and that's ok, but understand that administrators means ALL admins will have access too. If your happy with that, then #2 otherwise #3
  14. Alexsoltani

    Alexsoltani TS Rookie

    Ok I made myself the owner (admin/alexsoltani) and am replacing owner on multiple files it looks like right now. Sorry for being confusing, haven't done this in years. You are a genius. I will reboot after this and see where I am at.

    And yes, the problem was I was doing it in "my documents" instead of for the root directory C:\ also. I should read directions better :)
  15. jobeard

    jobeard TS Ambassador Posts: 10,885   +903

    Grrr; it should have been MY DOCS or %userprofile%.
    While C: gives admin total control, the Windows\* should be owned by SYSTEM.

    If you get where you NEED to be - - PUNT and let the IT department fuss with it - - they should just wipe and
    reimage it anyway :grin:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...