Router working, but no internet

By GJW ยท 9 replies
Jul 16, 2009
  1. I hope this is the right place for this question - I've never used one of these forums before. But I have been scouring them for answers to my problem, to no avail so far. So here it is, with all the info I can think of:

    I'm running a PC with XP and a Netgear wireless adapter and router-modem. It is all working properly and I can connect to the internet on it.

    I'm also running an Acer Travelmate 2300 laptop with XP. This can find the router and shows an excellent connection to it either wireless or wired, but it cannot access the internet either way. Until the day before we moved to a new house it was working perfectly on our old network.

    Here is what I have tried so far following phone calls to the ISP and Netgear and lots of searching in forums:

    Trying it wireless and wired.
    Lots of turning on and off and rebooting.
    Installing Firefox and trying that instead
    scanning for viruses, trojans etc (it was up to date with Avira and Malbytes or whatever it was called)
    Turning firewall off.
    Turning virus protection off.
    Deleting Norton with the complete removal tool (this seems to have worked for lots of people writing in forums)
    Deleting Avira.
    Deleting Malware Malbytes.
    Netsh int ip reset commands
    Ipconfig release and renew commands
    Running Winsockxpfix
    checking the internet settings - it is set to obtain ip address and dns server automatically, it is not set to use a proxy server

    Let me say again that it can find the router. It can ping the router. But it cannot ping e.g.

    Here are its ipconfig results when it is running wireless:

    connection-specific dns suffix:
    ip address:
    subnet mask:
    default gateway:

    Our old network didn't require a modem since it was a college system. It used a proxy server. When I set up the laptop a few years ago I spent ages on the phone to Netgear and they got me doing lots of things to the laptop that I didn't understand and don't recall. After several hours one brilliant Netgear tech assistant got it working. I'm wondering if something might have been changed then to make it work on a college network without a modem that is causing it not to work now. But that may make no sense.

    Can anyone help with things I haven't tried yet?

    Many thanks.
  2. B00kWyrm

    B00kWyrm TechSpot Paladin Posts: 1,436   +37

    Since you have not mentioned this tool...
    If you are running xp sp3, there is a Network Diagnostic utility that is now part of Internet Explorer.
    When you start IE, it should automatically start and take you through a process of determining your connectivity issues.
    Check this MS site for more information...
    I have successfully used it to remedy network issues for myself.
  3. jobeard

    jobeard TS Ambassador Posts: 11,161   +986

    find the Lan Connection; get the properties, scroll to the bottom to TCP/IP & click properties button

    use Automatic for both IP & DNS

    on the alternative config; us Auto private ip address

    disconnect from the router, wait 30 sec, and reconnect
  4. brucethetech

    brucethetech TS Enthusiast Posts: 229

    everything posted so far is right but don't forget the obvious...that the cable going from modem to router is in the right port of the router and that the modem has been reset.
  5. GJW

    GJW TS Rookie Topic Starter

    thanks for these ideas - still not working

    I tried changing the ip and dns settings as suggested a while ago and they have remained on the suggested settings since then.

    the modem and router are all in one so no connecting cables between them - the cable works fine in the desktop - move it to the laptop and it finds the router but not the internet.

    thanks for these ideas - any more v welcome!
  6. GJW

    GJW TS Rookie Topic Starter

    Port 80 closed

    one more thing - port 80 is closed on the laptop. This was what made the isp say it is a problem with the computer not them.

    I don't know anything about ports but I wondered if this might be relevant, and what to do to open it.
  7. jobeard

    jobeard TS Ambassador Posts: 11,161   +986

    hm; from the ISP, ALL ports should appear closed!

    From your system, the browser uses port 80 to access webpages, port 110/143 to read email and port 25 to send email.

    You should first test to see if you can access the DNS to convert a url to an ip address. get a command prompt (run->cmd) and enter
    The reply should be

    To test port 80 from your end,
    Copy this
    telnet 80
    GET / HTTP/1.0
    Paste it into the cmd prompt window. if nothing happens, hit <enter> once or twice.
    you should see at the bottom of the window something link
            <!-- pbt 1248040881 -->
    Connection to host lost.
    If so, then you can access outbound port 80 (ie browser access to web pages)
  8. GJW

    GJW TS Rookie Topic Starter

    2 empty posts to boost my posting count so I can post the web addresses you've included in the commands - I need five posts
  9. GJW

    GJW TS Rookie Topic Starter

    2nd empty post to boost my posting count so I can post the web addresses you've included in the commands - I need five posts
  10. GJW

    GJW TS Rookie Topic Starter

    results of commands

    OK, now I can post with the web addresses:

    Thank you for the instruction - here are the results:

    For nslookup I got this:

    *** Can't find server name for address Non-existent domain
    *** Default servers are not available
    Server: Unknown

    Non-authoritative answer:

    To telnet I got this (I couldn't work out how to enter the seocnd line beginning GET without hitting enter after the first - if I entered the second line on its own it just told me GET is not a command):

    Connecting to not open connection to the host, on port 80: Connect failed

    Does this shed any light on it all?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...