Running Win95 in virtual machine, need video drivers..

By abazaba
Aug 15, 2010
Post New Reply
  1. Ok so I know this is totally out of left field but its driving me crazy and maybe someone can help. I found a game from waaaaay back that I wanted to play but it wasnt old enough that it was dos based so dosbox is out. Can't run it on xp\vista\7 (tried all 3). That leaves 95\98. I actually went through the trouble to make an iso for 95 so that I could run it on VMware and it actually works surprisingly well. The game even installed fine, but when I go to run it it needs to be in 256 color mode. Thats where the problem starts... My computer has an Intel 965gm express chipset with integrated graphics which is not exactly something that was around in the win95 era. I have tried both the generic vga and svga drivers built in, didn't work. Tried windows 2000 drivers, didn't work. If anyone has any ideas on how to trick it into 256 color mode please help. Thanks!
  2. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,448   +145

    Have you, by any chance, tried using 256 color mode from XP?
  3. abazaba

    abazaba TS Rookie Topic Starter

    Yeah, I tried all kinds of dumbing down and compatibility modes in all xp vista and 7, to no avail.
  4. abazaba

    abazaba TS Rookie Topic Starter

    I got it!!!!!
    After a good 12 hours of frustration I solved the problem, I'll post the solution here in case anyone else has a similar problem in the future.

    Ok, so first you need to have VMware tools installed, and then go to device manager. Contrary to logic, the place you need to install the drivers is not under display adapters, but under other devices -> pci vga adapter (or something like that). select properties, then click the drivers tab, then hit change drivers and when it asks for device type select display adapter. at this point select have disk, browse, and navigate to c:\program files\vmware\vmware tools\drivers\video and the .inf driver file will be in there. select it, let it install, restart, and boom, problem solved.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...