Sata Drives not seen and Bios will not boot

By pscott1955 ยท 4 replies
Oct 4, 2013
Post New Reply
  1. Hi, I am having a problem with my Acer x130 running Vista

    It has been working fine until recently and I experienced a system crash. The computer will power up but does not see my hard drive even though its recognised in bios. I have pulled the battery out to force a reset, I have adjusted bios, I have checked bios settings against another (Identical) machine that is working fine. I have fitted another Sata drive with XP installed. All to no avail. The system seems to boot but then will attempt to start windows before flicking through a blue screen to reset the display to show 'no signal'.

    I sometimes get a screen that asks to start repair or boot normally. neither function works and the repair function returns me to an earlier screen.

    I have checked the sata drive (vista) in another machine and can access it so the data is intact. I have tried everything that I can think of and am now at wits end! help!!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    This is a Netbook?
  3. pscott1955

    pscott1955 TS Rookie Topic Starter

    No its a small footprint desktop. it should read x1300 not x130. I am wondering if the power supply might cause this problem as swapping drives and resetting bios are having no effect
  4. pscott1955

    pscott1955 TS Rookie Topic Starter

    Have tried two different power supplies and no difference.
    a 'no signal' screen comes up and then it returns to reboot offering 'del' for set up and 'f12'. resetting these makes no difference

    I have reset the cmos settings and have pulled the battery / power out a couple of times too.

    I tested different hard drives on it in case that was the problem and managed to get as far as a windows 2000 screen on one old drive before it took me back to rebooting and the offer of Del and f12
    I have changed a couple of the cables supplying power to the drives.

    I am at a loss as to what to do next.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The motherboard is probably bad (bios corruption)

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...