Tech Stocking Stuffers: 18 awesome gifts under $50

SATA DVDRW... Not Detected.. HELP!

By ScottyF
Sep 1, 2007
  1. Hello all.

    I just purchased a few upgrades for my PC. Mainly due to my old motherboard dying (AGP). So i purchased a new mobo Gigabyte p35 ds4 and graphics, Ram etc. So i went to pick it up and they handed it over. So i brought it home..

    The dvdrw is not detected. its a Pioneer 212d DVDRW. I have a feeling that it hasn't been installed properly.. i had a look and it only has 1 wider black cable attached. there are 2 extra cable slots on the drive. one white. and one smaller black one. This is my first experience with Sata so any info is appreciated.

    The Drive does power up, but is not detected

    Do i need to change some bios settings?
    or am I missing a cable?
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    boot to bios see if listed
    if so boot to os check disk manager may need to change the drive letter
    if bios does not show check MB manual for settings on sata drives priority
    and make absolute sure cables are good
    update sata chipset controller drivers
    make sure UDMA is set
  3. robin_bga

    robin_bga TS Rookie Posts: 171

    Hi Scottyf, Like Samstoned, says,try that and also make sure u have two cables running off that Drive, the two cables r for data and power so don't miss that out, plus make sure that yo bios has the sata set to enable.

    Wish u luck
  4. ScottyF

    ScottyF TS Rookie Topic Starter

    thanks for your help.

    Yeah it seems it hasn't been installed properly. Some tech at the store obviously forgot to put in the data cable. 4 sata cables were meant to come with my mobo aswell.. and I didn't get those. So i'm gonna go down to the store tomorrow.. Thats terrible service when I paid them to install it.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...