SATA hard drive not recognized

By brisar ยท 16 replies
Jan 3, 2011
Post New Reply
  1. Hi everyone

    I am a newbie so please be gentle.

    One morning my XP machine only booted the the XP screen and the blue harizontal bar just kept going in a loop and no further. Tried booting in safe mode and received the BSOD. Tried installing a fresh copy of XP to be told no drives were detected on the system.

    Have now bought a new SATA hard drive, and disconnected the old one. On boot-up the new drive is NOT auto-detected and the BIOS states that no hard drive was found. There is no setting in the BIOS to manual force a drive recognition.

    If I disconnect the cables attached to the new disk and reconnect the old disk the original problem is shown, which I am asuming means the cables are OK.

    The motherboard is an ASUS A8V Deluxe, and the new drive is a Samsung HD 502HJ.

    This is driving me daft and fast approaching a drop test of the computer from a great height!

    Any suggestions gratefully appreciated.
  2. EDO219

    EDO219 TS Rookie Posts: 212

  3. brisar

    brisar TS Rookie Topic Starter

    Thanks Pygmus, as soon as my wife gives the necessary admin to load this I will try (it's her laptop I am using to get answers for my PC!). I understand how this is needed to load a new install of windows, but why is the disk not recognised by the BIOSm like the old one? Is it because it has not yet been formatted?

    Completed new installation disk to no avail.

    Downloaded from ASUS site latest BIOS drivers for SATA and SATA RAID. Loaded these during boot from XP installation disk, and XP still shows no disk is connected. Using same cables etc old drive is recognised but will not go past XP start-up logo.

    What a week to give up sniffing glue!
  4. EDO219

    EDO219 TS Rookie Posts: 212

    Ah, now that is odd. Have you tried using the other SATA ports?
  5. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    You may have to place a jumper over some pins on the back of the hard drive to force 'legacy' sata mode on a board that old....
  6. brisar

    brisar TS Rookie Topic Starter

    Thanks guys for all the advise to help keep my sanity!

    I have located the following drivers:

    SATA 150 TX Series driver (named in motherboard instructions)
    Promise SATA 378 driver (from ASUS web site)
    Fasttrak 376/378 driver (from ASUS web site)

    Do I have to load all 3 when I press F6 during install?

    I have disconnected old drive and connected new one with jumpers set to master.

    Pygmus when you say using the other SATA ports do you mean the SATA RAID ports (red)? Would I need to connect both drives?
  7. EDO219

    EDO219 TS Rookie Posts: 212

    Oh, I was just ruling out that one of your SATA ports didn't die. SNGX1275's suggestion will probably lead to the solution, though. ;)
  8. brisar

    brisar TS Rookie Topic Starter

    Hi guys

    It has been suggested that I need to partition/format the new drive before it can be used. Is the true? Is this why the new drive is not recognised by the BIOS?

    I have located the Samsung Drive Manager software, however it is a utility that produces the necessary diskette and when I press make disk it keeps telling me that the write protected tab needs to be closed and it is, so getting nowhere. My floppy drive is an external one connected via USB to the laptop I am using.

    I am now completly stumped and not sure what to do next. Any guidance appreciated.
  9. EDO219

    EDO219 TS Rookie Posts: 212

    Write protected tab ... isn't that the crappy little switch on the corner of floppy disks that sets it to read only? It has been a while. lol
  10. Steven Pilgrim

    Steven Pilgrim TS Member

    Sounds like there might be something wrong with the sata port on your motherboard, if worst comes to worst buy a IDE to SATA adapter if you have an IDE port that is
  11. brisar

    brisar TS Rookie Topic Starter

    Hi Steven

    If the SATA port was at fault why is the old drive recognised in the BIOS POST whilst the new one isn't? Not being a techy this is what is confusing me.
  12. Steven Pilgrim

    Steven Pilgrim TS Member

    sorry must have missed that part, but anyway that is very confusing especially if the sata cable, hard drive and port all ok, the only reason why your hard drive may not is that it may not supported by your motherboard ( ive never come accross this tupe of situation before even though it may possible) or xp, sorry thats the best i can do, good luck anyway
  13. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    You said you disconnected the old drive and connected the new drive with jumpers set to master.

    SATA drives only have jumpers to enable legacy mode (150 vs 300 vs 600, SATA I, II, III respectively). There is absolutely no Master/Slave relationship with SATA drives no matter how many you have connected.

    Since you said "SATA 150 TX Series" based on your motherboard, I think you need to look at the drive (or look it up online) and figure out what pins the jumper needs to be set to to allow it to run in at 150. Set it up that way and it should work fine.
  14. brisar

    brisar TS Rookie Topic Starter

    The jumper settings was as a result of your earlier suggestion a day ago? The installation guide with the brand new drive (Samsung HD502HJ) shows settings for Master, Slave and Select Cable(EF) (there are other settings shown if computer maximum support is under 32GB). There is no mention of any setting for 150 as you state.

    Just to clarify where I am:

    My original SATA disk boots into XP but hangs at the XP Logo screen.

    I have purchased a brand new disk and using the power and dat cables removed from the original disk, connected it.

    On start up the new disk is not recognised by the BIOS and does not appear in the POST list of drives attached. I have also borrowed a known working SATA drive and using the cables disconnected from the new drive connected it and this is laso not recognised.

    I have tried different power and data cables with the same effect.

    The SATA 150 TX series drivers came from a read me file on the motherboard disk as the one to be used during installation, but as this is loaded during the installation of XP (F6 pressed for drivers) and by then the drive has not even been recognised by the BIOS, I don't understand how this has an effect.

    Does the new drive have to be "formatted" by a DOS utility before it will be recognised by the BIOS and enable XP to be installed?
  15. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Yeh I understood your problem, but I admit I was just going off what I know about SATA drives and my experience - which is they have a jumper you can set to force them to run at 150 rather than 300 (which really makes no difference for most mechanical drives). So on your statement about the guide I looked it up. It is a confusing guide because its either a generic drive install manual or they made 2 versions of your drive. The whole part about jumpers, in your particular situation with that drive, is irrevelant. It appears those jumpers are just a holdover from the IDE/PATA version of that drive (or a similar one) and have absolutely nothing to do with forcing the legacy mode I've been talking about. You should leave them untouched. I had thought that your drive was like ones I've seen, and the jumpers could be used to force a legacy mode. Your drive does not appear to have that option.

    So this means right now, you can't use that drive on your system. If you have access to another system it looks like there is a way to force the drive to 150 with software. You need to set the UDMA mode to 150 with this tool:

    Edit: Did some more looking and came up with the idea of trying it with the jumper set on the 2nd from the right. Like this : : [:] :
  16. klepto12

    klepto12 TechSpot Paladin Posts: 1,115   +9

    you might have to look this up i seemed to remember there being a setting in the bios for this like you have to turn raid off or something like that might try that.
  17. pepsi1

    pepsi1 TS Rookie

    Most new drives need to be initialized before Windows will recognize their existence in the boot record or Disk Management. It is a simple problem for drives SATA or IDE. You will pull your hair out trying to get this thing to work over something that should have come from the factory ready for use.

    Go to your boot BIOS and enable every SATA listed. What you think is SATA 0 may be SATA 2. It should recognize the drive. Then disable each drive until you find the one that is actually being used as SATA 0 (C system). Once you have a recognized drive, you can handle the formatting and partitioning in Disk Management.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...