1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Seagate freeagent pro problem?

By ingeborgdot ยท 9 replies
Aug 19, 2007
  1. I have tried to get the computer to recognize the freeagent pro with esata port but for some reason it just doesn't. I have read others who have had the same problem on google but did not find an answer. Does anyone know what I need to do. I am using the AM2 mobod from gigabyte. gam-57sli. Advice on what I need to do will be welcome. Vista Ult. OS
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You have been posting around the Web with this... You plugged in the cable securely and it started working. Is this still the case?
  3. ingeborgdot

    ingeborgdot TechSpot Paladin Topic Starter Posts: 441

    I actually had to push rather hard, harder than I thought it should be on the freeagent pro but it does work.
    Why, do you belong to more than one forum?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I Googled using the title of you post... Glad you got it sorted
  5. ingeborgdot

    ingeborgdot TechSpot Paladin Topic Starter Posts: 441

    I don't always get responses so it is best to put it out so a lot of people see it.
  6. BobCrabtree

    BobCrabtree TS Rookie


    First thing to say is that reading here that you needed to push the eSATA lead into your Seagate FreeAgent harder than you expected proved to be the solution to my problem.

    However, though I'm delighted that your discovery solved my problem, the real thanks have to go to Tmagic650 for actually posting here the information that you didn't!

    The thing I would ask you to remember is that there is a kind of debt involved in using forums - if someone provides you with a solution (or you discover one yourself) then you are honour bound to post up that solution everywhere you posed the question.

    And, fact is, you posed the question VERY widely indeed, yet this was the first thread on which I discovered the answer - and then only thanks to Tmagic650.

    So, please, do make a point of revisiting all the many sites where you asked for help - and posting up the solution, so that others with the same problem (and I have a horrible feeling that it's all too common) can be put out of their misery.

    I kind of guess you might have felt a bit embarrassed by the fact that simply pushing the cable in hard cured the problem but you shouldn't feel that way.

    Here (and I don't know whether it's because I'm using a cheap cable or whether the Seagate's socket isn't well made), I had just the same problem and had spent MANY hours today trying to sort it out and would NEVER have thought to have pushed the cable any harder into the socket on the FreeAgent drive - and I've been messing with computers since, the days of CP/M.

    Oh and one little tip that may be helpful to others - the motherboard socket into which I have plugged the cable from the eSATA backplane adaptor clearly doesn't function in plug & play mode.

    That means that a reboot was required to allow the PC to realise that the Seagate was attached and for Windows XP to see it.

    I do have one socket on the motherboard that is supposed to be dedicated to eSATA (and, presumably, is plug and play) and so I'm off now to try using that socket to see if it works as I'd like it to - and I'll report back here shortly on whether or not it does.


    Bob Crabtree
    (Word wrangler at HEXUS.net and administrator of the DVdoctor video-editing forums)
  7. BobCrabtree

    BobCrabtree TS Rookie

    The eSATA socket is part of a RAID configuration (Marvell) and after having carried out a bios upgrade and a RAID software upgrade, I can now get the RAID controller to see the Seagate drive.

    Trouble is, Windows still doesn't see the drive.

    I've eventually located a manual for the Marvell RAID but am too tired at the moment to read it to see what I'm doing wrong - though I have a horrible feeling that I'll need to clear everything off the Seagate and use the RAID setup element that's in hardware to blat the drive.

    So, I'm off to bed and leaving the PC to copy off stuff from the Seagate to other drives.

    Ho hum.

  8. ingeborgdot

    ingeborgdot TechSpot Paladin Topic Starter Posts: 441

    I apologize but have not been home but for very short short periods and have not had any time and I mean any time to post.
  9. BobCrabtree

    BobCrabtree TS Rookie


    First thing to say - and I guess that you of all people will understand this - I was kind of tetchy yesterday on account of the grief I was suffering, so sorry for jumping down your throat.

    Next - I do appreciate your comment and understand.

    Finally, no good news to report - I totally failed to get XP to see the drive when it was attached to the motherboard's eSATA socket, even after allowing the RAID Bios to blat the disk.

    So, I've largely given up until I can lay hands on an eSATA card.

    Oh, and I've ordered up some better quality eSATA cables to see if the connectivity issue - ie having to FORCE the cable home on the drive's socket - is caused by the socket itself or my currently only having used cheap and nasty cables.


  10. BobCrabtree

    BobCrabtree TS Rookie

    Just reporting back on having, somehow, got eSATA working the way I had hoped and expected it would work.

    I suspect that this might be as a result of an update of the motherboard's Bios but, frankly, I'm not sure.

    What I discovered, though, is that the drive doesn't show in Windows' Safely Remove Hardware app - which left me kind of worried about how to disconnect the drive while the PC was turned on, but then I discovered, courtesy of Google, a free app called HotSwap! that does let me do that.

    Perhaps not surprisingly, what I've not managed yet, though, is to get any reply from Seagate to my query about the poor quality of the eSATA port on its FreeAgent drive and what it plans to do about it.

    Similarly, the reseller has not responded to my email asking if it knows about the problem and what it intends to do.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...