Severe problem in sending pockets from router to PC (Using ethernet)

By BuPher · 19 replies
Nov 23, 2016
Post New Reply
  1. Hello, I've been experiencing a problem in my DSL network the past months, and I will try my best to explain what is going on, what I noticed and what I tried (with the results). I've been using the software mumble's connection interface to indicate whether I had internet access or not, and if yes, if I could use my internet and connect to servers (Sometimes ping shows up but with a severely high packet loss and inability to connect or use internet).

    My setup:

    Router/Modem (tbh I have no idea if my device is both a router and a modem, but it's the only device plugged to the phone line): SAGEM F@ST™ 2604
    Hardware Version: 253124416
    Serial Number: LK835025071
    Software Version: 3.21a4G
    Wireless Driver Version:

    Medium between the router/pc: A cheap ethernet cable (that was replace over and over again but the issue still stands)

    PC Network Card: Intel(R) PRO/100 VE Network Connection
    PC OS: unregistered copy XP Sweet (By kal)

    Where the problem began:

    A couple of months ago, I've noticed a weird increase in packet loss (>3%) and sometimes when the router is launching, the message "limited connectivity" would appear on my pc briefly before either going away or getting fixed when I click the "Repair" button in the "Status" dialogue representing my connection to the router. Note that nothing involving wireless connection was ever affected in anyways, and this problem only appeared on any device using ethernet and the only current one is my pc (sometimes I plug in my sister's laptop when playing a video game online)

    However, we had to repaint our house at one point and so we removed the phone setup temporarily (The DSL was connected to the phone which acted as a tool to separate the phone line from the ISP (as the technicians literally said). ) When putting everything back, however, the home telephone's port got damaged and the phone cable was stuck inside it, however it was perfectly functional, internet went back to normal (after a small disconnection) UNTIL the next day...
    The next day my PC's internet was barely functional and my download speed was 4.4 kB/s at startup (my cap speed is 4Mbits), however after half an hour it went back to normal with a packet loss that hovered between 5%-0%. The next day the internet download speed was even slower and the packet loss was higher than 20%, but after an hour or so it went back to being normal. This went on for a week, on startup the internet would be so bad and then it would get fixed, with each day taking longer than the previous one.

    One day, it refused to work alltogether and my mumble's Interface said I had a "70 ping (perfectly normal) but a 40% packet loss rate". It didn't work for two days until I touched the phone cables a little and restarted the router a few times after reconfiguring the wires. So I assumed the problem was coming from the telephone and this proved to be correct as whenever anybody would touch the telephone, internet on my pc ALONE ( wifi devices were unharmed) would stop working and show a ridiculously high packet loss % and partially load a page (title only, background only etc...).

    So I replaced the telephone, the phone and internet cable in the wall (reinstalled new ones), and my ethernet cable. The internet worked for a day or two before stopping again. Which made no sense to me as the previous setup was faulty but now it's all gone and it's replaced with proper devices, so I had to test the connection between the router and my PC. I noticed that each ethernet port, although still not working, provided different results. Port 1 Had the lowest packet lost and ping (40% and 68 ping), port 2 and 3 gave atrocious results, however port 4 was really complicated; it had bad results however whenever I manage to fix the connectivity and connect to internet, it was through port 4. Then I would just plug in the ethernet to port 1 and it would go back to normal, for the time being.
    If I reboot the modem when the connection is all messed up, the pc would show the message "Limited internet connectivity: you are seeing this because your router failed to attribute an IP adress to this computer, click this message to resolve" (of course it doesn't resolve it), and when I go to the "Status" dialogue of my connection, it gives off a completely different ip than the one my router is using. So what I've done is I manually set the settings of my TCP/IP on my PC to match the ones on the router (with the only difference being the "gateway", because it was always my router's IP adress. However, on the router it shows a different adress, yet the internet works).
    Doing this made my PC detect internet again and upon launching mumble (and after waiting a little) it showed "68 ping" that kept hovering around that value, however an extremely atrocious 92% packet loss. Port 1 showed that value, port 3 and 4 showed the same value and port 2 stopped working all together.

    I launched the command prompt and trying pathpinging google using "pathping google" and it yielded these results:
    (My pc is in french and I can't copy paste from it since im not using it so I had to roughly translate:)
    Determining route to []
    With a maximum of 30 jumps:
    0 sweet-c6236374e (//<= my pc) []
    1 * * *

    Treating statistics for 25 seconds:
    Source Towards Here This node/link
    Jump Ping Lost/sent = Lost/sent = Address
    0 ---------- 100/100=100% [] sweet-c6236374e
    1 ------ 100/100=100% 0/100=0% [] sweet-c6236374e

    So I tried pathpinging my router's ip (Im not sure if that works that way, but this is what I got anyways)
    Determining route to
    With a maximum of 30 jumps:
    0 sweet-c6236374e (//<= my pc) []

    Treating statistics for 25 seconds:
    Source Towards Here This node/link
    Jump Ping Lost/sent = Lost/sent = Address
    0 ---------- 90/100=100% [] sweet-c6236374e
    1 ------ 90/100=100% 0/100=0%

    I didn't entirely understand the test results, but I noticed that each time, the jump is the one that caused trouble. So does it mean the problem is from my PC's Network Card? Or is it from my modem's ports? And if all Wifi devices function regularly, is a simple fix to purchase A wifi USB Key/Adapted and use it instead? Or should the pc be replaced? (it is an old pc, around 10 years old, however it's all I can afford for the time being).
  2. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

  3. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Don't edit the test results; try TRACERT GOOGLE.COM and post the whole thing
  4. BuPher

    BuPher Topic Starter

    I ran the test five times because it kept failing on some steps. I left it untranslated since you asked me not to edit it but it should be clear anyways.
  5. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

      1     *       <1 ms     *
      2    13 ms     *        *
      3    13 ms    14 ms     *
      4     *       13 ms    13 ms
    #1 is your router
    #2 is your ISP connection

    So when I see
    1     *        *        *     Délai d'attente de la demande dépassé.
      2     *        *       13 ms
      3     *       13 ms    13 ms
      4    12 ms    13 ms    13 ms
      5     *        *        *     Délai d'attente de la demande dépassé.
    The connection from the PC to the router is bad, likely the cable itself. Buy a quality RJ45 Ethernet cable. This connection MUST be 100% reliabile and it's on your equipment - - the cable, the NIC, or the router itself

    #5 is down stream from your ISP. ASSUMING that #1 was fixed and still #5 had this timeout, your ISP connection or routing STINKS, but there's nothing you can do about it either. :sigh:
  6. BuPher

    BuPher Topic Starter

    Thanks for confirming that either the router, NIC or the ethernet cable is faulty However I am now certain it's not the ethernet cable a I tried a (non-cheap) Cat5e ethernet cable borrowed from a friend and my internet was still dysfunctional. So how do I know if it's the router or my PC's NIC that's falling behind and not fulfilling its duty? (without introducing another device because for now it's not possible :/ )

    And, another question please; Will buying a WIFI USB adapter fix the issue? (seeing that all wifi devices function correctly)

    Ninja Edit: My ISP is horrible but I'm bearing with it for the time being, but it's not being much of a hindrance.
  7. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    To test the PC NIC, cable the pc-->directly-->to another computer-->pc
    you can set the IP settings manually in each system and you should be able to ping in both directions a->b & b->a
  8. BuPher

    BuPher Topic Starter

    I am only used to the XP interface and am not that experienced with 7's interface. How do I configure this temporary connection?
  9. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    OK, every system is the same, you need to access the DEVICE (aka the NIC) and go to the properties.

    On the NETWORK TAB, select the TCP/IPv4 and then click the properties lower right

    In the General Tab you setup the TCP. Notice that pc.A need different than pc.B
    (btw: you can connect pc<--->Mac or linux like this too, but they have different means to set the TCP config)

    Le'ts play with the subnet 192.168.1.x
    Clear ( ) Obtain IP automatically and set (*) use the following
    • ip address: on pc.A and on pc.b
    • subnet mask: on BOTH systems
    • default gateway: the same as the ip address for the other system
    CLear () obtain DNS automatically and set (*) use the following DNS
    • Preferred: set the OTHER pc ip address; if this is 1.1, then set 1.2
    • Alternate: make both systems (nothing here but who cares)
    click OK to make the settings current

    now connect A<-->B

    ping using addresses;
    • from A( ping
    • from B( ping
    You *MUST* get no timeouts.
    You can also use PATHPING in the same way and insist upon 0/100% success.
    Last edited: Nov 24, 2016
  10. BuPher

    BuPher Topic Starter

    Does the Default gateway of A = IP address of A? (And ditto for B?)

    If yes then I configured everything correctly and on both PCs it says it's sending packets but received packets are nevertheless "0", So something went wrong.
  11. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    • ipaddr gateway
    • ipaddr gateway
  12. BuPher

    BuPher Topic Starter

    Alright, worked! Pinging from the other pc to mine succeeded and yielded respectively 25% loss on 1st try; 50% loss on second, 75% on third and fourth completely failed with a 100% loss.
    However pinging from my PC to the other one completely failed on all four attempts with a 100% loss.

    So, this means my NIC is damaged and should be replaced/worked around?
  13. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    BINGO!! Bad hardware OR driver. Can you find an updated version?
  14. BuPher

    BuPher Topic Starter

    I'm positive that my driver is up to date because I've been always checking for ways to optimise my internet and maximise the bandwidth, so it must be the NIC that's dysfunctional. Cheers for the help.

    Should I resort to wifi to fix it (using a USB adapter stick)? or does that still depend on the NIC?
  15. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    NO, WiFi (via a stick) would be independent of the NIC.
    Your router needs to provide the WiFi connection SSID however - - does it?
  16. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Concerned - - over optimization by tweeking the registry can kill the connectivity - - DON'T PLAY with this stuff.
  17. BuPher

    BuPher Topic Starter

    I plugged in a WIFI stick and installed its drivers and it works perfectly! Thanks a lot for the help by the way! Truly appreciated.

    Do I have to keep looking into my NIC or is it not worth the time since I got new means to connect to the internet?
  18. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    I would yank it out of the box myself!

    Thanks for the feedback too :)
  19. jobeard

    jobeard TS Ambassador Posts: 11,158   +986

    Btw; if the nic is an onboard chip, use the device mgr to mark it DISABLED.
  20. BuPher

    BuPher Topic Starter

    Done did. Disabled it until one day I could get the central unit out of its place and disassemble it.

    Thank you for your time!

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...