Sims 2 Failed to find any DirectX 9.0c.....

By cmserene · 20 replies
Feb 3, 2007
  1. Hello. I know this topic has previously been discussed at great length in this forum, however I can't find any posts that relate to my particular situation so I am still stuck. I have The Sims 2 Nightlife and have played it for the past 2 months or so with no problems. Last time i played it was last weekend. Now all of a sudden when I start up the game I get the error "Failed to find any DirectX 9.0c compatible adapters in this system! Please make sure you have a DirectX compatible graphics adapter and have installed the latest drivers provided by the manufacturer. The application will now close."

    I am using a 6 year old Gateway computer with the following specs:

    256mb ram
    ATI Radeon 9250 graphics card (brand new and DirectX 9.0 compatible)
    newest graphic driver as of today is installed
    140gb hd
    Intel PIII 800mhz processor
    DirectX 9.0 installed
    MS .NET framework v2.0

    I can usually figure these things out on my own just by doing the research and/or trial and error, but this one has me stumped. It worked fine a week ago and now it's not working. The only thing I remember doing to my pc in the past week was resetting my system defaults which gave me a few other problems but I got those fixed. I know there is something I'm just missing here and I can't for the life of me figure it out. I guess this one is beyond my I'm starting to wonder if I might need to reinstall my xp or possibly my sims.

    Can someone please give me some ideas?
  2. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    If you used the newest graphics driver available today, you probably have the wrong one installed. The latest (7.1) as of today, doesn't support the 9200 series any longer. You should go back to 6.5.
  3. cmserene

    cmserene TS Rookie Topic Starter

    The driver version I have installed is 8.252.00.....??

    I want to also mention that under my Device Manager - Display Adapters, for some reason I can't figure out, I have 2 adapters listed.
    Radeon 9250
    Radeon 9250 - secondary

    I don't know if this is a problem or not.
  4. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    I checked and the Catalyst 6.5 driver bundle contains driver 8.252, so you appear to have the correct driver.

    The reason you have two adapters listed is because your graphics card, like many, has two output connectors for potentially two monitors.

    The only thing I can offer at the moment is perhaps the driver somehow got corrupted. Can you try uninstalling and reinstalling the graphics driver? Or perhaps reinstalling the game?
  5. N3051M

    N3051M TS Evangelist Posts: 2,115

  6. cmserene

    cmserene TS Rookie Topic Starter

    Yes I have undated DirectX to 9.0. I've also tried uninstalling and reinstalling the driver. I just tried uninstalling and reinstalling the Sims game and I'm still getting the same error. :(
  7. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    Go into Direct X settings and run the tests on the video page, it is possible that the video card has a problem.

  8. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    When you uninstalled the graphics driver, did you do so under Add/Remove Programs? I mention this just in case you tried to do it under Device Manager.
  9. cmserene

    cmserene TS Rookie Topic Starter

    I have uninstalled the driver both ways actually. The first time I did it under Add/Remove programs. The second time I did it under Device Manager. I also redownloaded the driver from the ATI website thinking somehow the first download was corrupt. I also just reinstalled my XP as an upgrade (wasn't sure which one to use). That didn't work either. As far as something being wrong with the card, how could that be? As I said before, it's a brand new card that I just installed 2 months ago. AND it was working fine up until this past week. I just have a feeling somehow a setting got changed or something and I don't know what it is. I can't help but have this nagging feeling that resetting my system defaults did something. I wasn't having any problems until after I did that.
  10. cmserene

    cmserene TS Rookie Topic Starter

    How do I go about checking my DirectX settings??
  11. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    go into c:\windows\system32 or c:\winnt\system32 and find DXDIAG.EXE and run it, you may get a box come up asking if you want to have the drivers checked, choose yes, when it has finished go into the "Display" tab and you will see some boxes marked "test direct draw" etc etc, run the tests, also see if DXDIAG shows any errors with the card or drivers.

    Pic attached for you to look at


    Attached Files:

  12. cmserene

    cmserene TS Rookie Topic Starter

    I ran DxDiag and it found no problems BUT I saw a couple things that didn't make sense. First, in the notes field of the DxDiag diagnostics tool, under the display tab, there is a message that says "Direct 3D funcionality not available. You should verify that the driver is a final version from the hardware manufacturer." I downloaded what the ATI website said was the most recent driver for my card. I ran the DirectDraw test and it said all tests were successful, but when it was running the 3rd test (the full screen test with the bouncing white box), my screen went white with colored lines before the white box appeared, and my monitor kind of reset itself. Also, under the drivers section under the display tab, it shows that my driver version is 6.14.0010.6614. When I go into my Device Manager it says my version is

    I also keep getting the following error from my ATI Control Center:

    VPU recover as reset your graphics accelerator as it was no longer responding to graphics driver commands.Then it askes me if I want to send an error report to ATI or not. I have a few times but stopped after it came up so many times.
  13. N3051M

    N3051M TS Evangelist Posts: 2,115

    have you checked your PSU has enough juice to run the card? read the guide below..
  14. cmserene

    cmserene TS Rookie Topic Starter

    I have not checked my PSU yet. That I guess is the next step. Will need to do that tonight. But, I have another question first. According to what you wrote in the other thread you linked to, you mention that the game needs the DX9's 3D component to work. Mine is grayed out and I am not able to test it but it must have worked before, because as I said further up in my thread, I have been playing the game for around 2 months on this new card. Everything was working peachy until this past week. So the card must support the 3D component or it would have never worked, right?

    Direct X can't find compatible graphics adapter
    Reason behind this, is that the games needs the DX9's 3D component to work. Some integrated graphics adapters lacks this, and thats why it won't work. In this case, if the driver fix below doesn't fix it, then you will need to get a proper graphics card or upgrade your existing one. Post a new thread if you need help choosing a new card, or want more information about this.

    Check if you have it/can enable it:
    - Go to Start >Run and type in dxdiag
    - Go to your Display Tab (or Display 1, Display 2 etc if you run multiple monitor setups) and find where it says Direct X Features
    - Click Enable for each one, if not grayed out. If gray, then your card doesn't support it, so its time for an upgrade.

    Also, I don't know if this means anything or not, but my CPU is running at 100% all the time, unless I close tcpscvs under processes. It is a system command but when I close it it makes my game run smoother and better.

    I am so confused over this whole thing. Everything was working fine! I wish I knew what I did to screw it up this bad!! About 3 months ago I installed a new video card to support the Sims2 AND upgraded my Windows from ME to XP, after which, my computer has never run so good in its life, even running TS2! I reinstalled a few programs I used on ME (XP compatible), and reinstalled my printer. Once I got things reinstalled, the PC started slowing down. It was manageable but slow nonetheless. Now all of a sudden, out of the blue, the new graphics card doesn't work anymore? or is not DX9 compatible?? How does that happen???!!!???

    (sorry for the babble there, but I want to make sure y'all have as much info as possibe...and I needed to vent a bit)
  15. N3051M

    N3051M TS Evangelist Posts: 2,115

    Can you confirm which is the correct spelling of this file?
    tcpscvs or tcpsvcs?

    The latter in green is the legit file, (see here)
    the other could be related to a trojan. Go read this, and post in the security section and see if they'll give you the green light or further instructions. If its not a trojan, then you can try disabling it from starting up if you don't use it..

    my guide was originally written for the Sims2 problem (which people think making it work with just any old PC was just by magic) but since there was a better more specific guide made for it (sims2) i just tweaked a few things to make it reflect most games..

    Right now, from what you've written so far is that you have current DX and ATI drivers. Only other driver related thing to do is to update motherboard chipset drivers..

    As it stands, i'm thinking of 3 things:
    - temperature
    - power
    - hardware problem.

    Download the Everest Home program, and in the Computer>Sensors page, post what you see on that page (minus debugging info) while your PC is doing nothing and again when you run something intensive. Post the info on your PSU sticker here.

    Hardware problem is if your card has gone dud.. which could even happen to brand new ones (thats why manufacturers have DOA policies).

    Vent as much as you want :) More info the better to find out the problem :D
  16. cmserene

    cmserene TS Rookie Topic Starter

    Ok. Here we go. I looked at my processes again to be sure the tcpsvcs was correct. It is in fact tcpsvcs. I guess I just mistyped it.

    Next, I downloaded Everest Home and these were the sensor readings:
    Sensor Type - HDD

    Temperature doing nothing:
    Seagate ST3120026A 26 °C (79 °F)

    Temperature loading TS1:
    Seagate ST3120026A 27 °C (81 °F)

    Temperature while running Simcity 3000:
    Seagate ST3120026A 28 °C (82 °F)

    The most intensive thing I know to do on my pc is TS2 which obviously I can't load, so I tried loading TS1 instead. When I tried starting up that game I got this error message: Hardware driver error: Could not initialize DirectDraw./ When I hit OK, the screen went black. I hit Ctrl and Esc together and my desktop came back with another error message: Simcity 4-Could not initialize the hardware driver. Using the software driver.When I hit ok this time, the screen went black again so I hit Ctrl-Esc again but this time only my Start Menu showed up on a black screen. Before my screen went black the 2nd time I checked my temp again and it read 86F. Also, I tried installing and running SimCity 4 Deluxe. It installed ok but when the game went to load, my screen went black. Here is the info on my PSU label:

    Input - 100-120 v 5.0A 50-60hz
    Output - +5v / 18.0.A -5v / 0.3.A
    200w max +12v / 6.0.A -12v / 0.3.A
    +5vsb / 1.7A +3.3v / 10.0A
    Newton model #NPS-200PB-96D Rev: 01
    S/N Y1026582528T
    Date code 0026
    Made in Thailand

    I didn't know exactly what you needed so I wrote everything down.

    I don't know if you noticed 2 of my posts back that I mentioned when I ran my dxdiag it told me a different driver version than the one my device manager gave. I don't understand why I'm getting conflicting versions.

    By the way thank you sooooo much for trying to help me with this. I've already learned alot and the damn thing isnt even fixed
  17. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    That's a hell of a weak PSU. 200 watts is not NEARLY enough for ANY PC these days. Try to get a new one ASAP.
  18. tweakboy

    tweakboy TS Guru Posts: 467

    Your going to need to reinstall DX9c

    Then boot into safe mode and remove ATi drivers,

    Reboot and now install latest Catalyst 7.1 drivers,, gl,
  19. N3051M

    N3051M TS Evangelist Posts: 2,115

    i would also agree there.. especially trying to run a proper graphics card. I'm guessing that the card is automatically adjusting to not enough resources available or something along those lines..

    There is a link to a PSU calculator on my faq, you should be choosing a new PSU now and see if it fixes this problem. About conflicting driver versions, i would have no clue, but the reinstall method mentioned by tweakboy would probably fix it.
  20. cmserene

    cmserene TS Rookie Topic Starter

    And the plot thickens!!

    I read all the latest posts and decided to check out the PSU calculator. I did that and found out I should have a higher wattage PSU. At least 275w. Haven't gotten one yet obviously but it's on my list of things to do.

    Next I was going to try what tweakboy said but I couldn't figure out how to uninstall dx9 so I ran my dxdiag again (thinking it was going to tell and this time my Direct3D test box was no longer grayed out and I could run the test. So I tested it and...guess problems! Please keep in mind I haven't changed anything so far. So because of this, I decided to try my TS2 and low and behold the dx9 error box didn't show up and the game started the screen is off-center. It loads fine but I can't try anything in the game because all of my control options are, of course, out of view because the picture is off-center...(ready to cry). The only thing I did tonight before trying the game, was I uninstalled a program called e-trends, which to my knowledge does not use directx at all. Hell it doesn't even need the video card to work. It runs silently in the background collecting data. But that is literally all I did besides downloading and running the PSU calculator. I did open my Catalyst Control Center hoping I could find a setting that might fix my now "off-center" problem but I found nothing.

    SO what does everyone make of this new development?? I know I am completely baffled and STILL unable to play my Sims!
  21. N3051M

    N3051M TS Evangelist Posts: 2,115

    hmm.. etrends came up on my google search as being related to adware or spyware..

    you can make a last attempt to reinstall the drivers, and using a driver cleaner in the process to make sure you really got rid of the old ones.

    Monitor adjustments, try looking for this screen here:
    You may have to enable the Advanced control options..

    i still recommend replacing that PSU asap.. you don't want to fry your PC while in the middle of renovating the house (in sims) or something... decent 300W PSU shouldn't cost that much (maybe $60 or so?)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...