Sims 2 University Crashes After Title Screen

By kkat ยท 9 replies
Nov 3, 2007
  1. Hello everyone,

    I have been searching online for two days now for some situation that is similar to mine. No such luck. I have read threads from people who have crashing problems, but none are quite the same as mine, or the solutions will not work. So here is my dilemma:

    I have Sims 2, Sims 2 Nightlife, Sims 2 Pets, and Sims 2 Glamour Stuff installed in that order. Yesterday, I tried to install Sims 2 University and it was a success! However, after the installation I clicked "launch" and it comes up with the title screen of Sims 2 University, before disappearing and nothing happens. This sort of thing is under the Sims 2 University Technical Support, but none if their solutions has worked for me. I assume this sort of problem should be titled under "Copy Protection Crash".

    I have turned off all background programs, including antivirus and spyware sweeper, etc. It still does not work. I do not have anything in my downloads folder that may be interfering with the gameplay. Also, this is NOT a copied/burned CD. It is brand new, fresh out of the box and freshly installed (I have uninstalled and reinstalled a few times, none of which were successful. My game works once I uninstall TS2U.)

    In addition, I ran disk clean up and defrag and the game STILL does not work. My CD is not scratched or anything; it is brand new. My drive letter is valid, and is currently running under E (the lowest possible). I only have one drive (I have a Sony Vaio laptop).

    Well, that's my problem. I tried deleting the Groups.cache and the Accessory.cache under my Sims 2 folder because I had read somewhere that that could be causing some sort of problem. Well, that's not it. It simply doesn't do anything after the title screen. You can hear the disk spin while pulling up the title screen, but then it disappears and the drive slows down and stops.

    URGH ASROWEWRHERUHWIURH.:( Hahaha. There is my frustration.

    I was wondering if anyone has had the same problem with TS2U crashing back to desktop after the title screen??? PLEASE HELP. (I will try uninstalling everything tomorrow and reinstalling the expansion packs in order. Maybe that has something to do with it?)

  2. kkat

    kkat TS Rookie Topic Starter

    Anything ASAP would be wonderful!!!!!!
  3. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    I'd start with each expansion's update from the Sims 2 website.

    When you installed University, you now have an out-of-date expansion as Pet's patches your existing Sims2 version up a couple of revisions.

    To be safe, get all the applicable Sims2 patches from:

    Install them in the order they show on that page and hope for the best!
  4. Vlad788

    Vlad788 TS Rookie

    Try removing your Downloads Folder. Its probably a hack or download that you have in your folder that is likely causing the problem.
  5. kkat

    kkat TS Rookie Topic Starter

    No, I deleted everything in my downloads folder into my recycle bin and then tried installing TS2U and loading it. It still didn't work, so I restored all of my items. That was not the problem.

    I had visited that site before where the patches are located, but did not think that I needed any. Perhaps I am mistaken. I will definitely check it out, but it isn't very clear on the site as to what I should do.

    Do I uninstall everything, then save the patch on a disk, put the disk in and let, then install the expansion pack that corresponds with the patch? If so, how do I save the patch to a disk?

    I will try to install everything in order. If that doesn't work, then I'll resort to getting some patches (you'll probably hear from me again!).

    I'll keep everyone updated so those with similar problems can learn, and also so I can receive some help :haha:. Thank you for all your help so far!!!:grinthumb
  6. Vlad788

    Vlad788 TS Rookie

    If you buy an older expansion pack. You will have to reinstall all of the games all over again. Lets say you have Nightlife and Pets but then you buy Open For Business, you'd have to uninstall the whole entire game and expansion packs and then reinstall everything in chronological order in which they were released, so that the game can save in the format in which your latest expansion pack has. But your problem may be the one below:

    Another reason why you are having these problems is because you are trying to run The Sims 2 University CD. You need to use the CD of your latest stuff pack which is Glamour Life Stuff and run that program as it is the "newest" and latest expansion in which you have. So even though you installed University, its still an "Old" expansion. Try running Glamour Life Stuff and see what happens.
  7. asp49330

    asp49330 TS Rookie

    Did you ever get a fix for this problem? I am having the same exact problem to a T.

    Anything you can advise will be greatly appreicated
  8. urnesha

    urnesha TS Rookie

    I am having the EXACT same problem. Did you ever get a solution? I've contacted EA Tech Support and none of their suggestions work. I even tried a new copy of the game and it's still not working.
  9. mikelowrey1

    mikelowrey1 TS Rookie

    I'm having the SAME issue
  10. simsfanatic

    simsfanatic TS Rookie


    I experienced the same problem for about a week until I started experimenting. This worked for me, but I can't guarantee perfect results.

    After installing Sims 2 University, use the same disc that you used to run the game before. For me, it was Sims 2 Pets, so try that first. GOOD LUCK.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...