1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SiS 7012 audio device "failed to install driver for Windows XP"

By jonkey86 ยท 14 replies
Apr 13, 2006
  1. I formatted my computer, installed winxp sp2 and the driver for my multimedia device was lost, i ran everest to check what it was and its SiS 7012 audio device, an odd thing was when it said my motherboard name is unknown, its a laptop.
    I downloaded different drivers but non of them were succesful, i tried installing one and a failure error pop up, "failed to install driver for windows xp" (check link or thumbnail), i tried installing winme.exe for windows ME driver but it didnt work, tried changing install directories but didnt work either. i donwloaded drivers from SIS home page but didnt work either. please help, i am most concerned about my sound device rather than the mother board, here are my specs.


    Operating System Microsoft Windows XP Professional
    OS Service Pack Service Pack 2
    DirectX (DirectX 9.0c)
    CPU Type Intel Pentium 4, 2600 MHz (13 x 200)
    Motherboard Name Unknown
    Motherboard Chipset SiS 648FX
    System Memory 512 MB (PC2700 DDR SDRAM)
    BIOS Type AMI (01/12/04)
    Communication Port ECP Printer Port (LPT1)
    Video Adapter ATI Mobility Radeon 9600/9700 (M10/M11)
    3D Accelerator ATI Mobility Radeon 9600/9700 (M10/M11)
    Audio Adapter SiS 7012 Audio Device
    IDE Controller SiS PCI IDE Controller
    Disk Drive TOSHIBA MK6022GAX (60 GB, 5400 RPM, Ultra-ATA/100)
    Optical Drive TOSHIBA DVD-ROM SD-R6112 (DVD:2x/1x/8x, CD:16x/10x/24x DVD-RW)
    SMART Hard Disks Status OK
    C: (NTFS) 27227 MB (14530 MB free)
    D: (NTFS) 29996 MB (29537 MB free)
    Total Size 55.9 GB (43.0 GB free)
    BIOS Properties:
    Vendor American Megatrends Inc.
    Version 080009
    Release Date 01/12/2004
    Size 512 KB
    Boot Devices Floppy Disk, Hard Disk, CD-ROM, ATAPI ZIP, LS-120
    Capabilities Flash BIOS, Shadow BIOS, Selectable Boot, EDD, BBS, Smart Battery
    Supported Standards DMI, APM, ACPI, ESCD, PnP
    Expansion Capabilities ISA, PCI, AGP, USB
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Go to your laptop manufacturers website. You should be able to get your drivers there.

    Regards Howard :wave: :wave:
  3. jonkey86

    jonkey86 TS Rookie Topic Starter

    its a clone laptop, a friend built it for me :S
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I don`t know why the sis7012 driver won`t work.

    Download the SIW programme from HERE. See if that can identify your mobo.

    Regards Howard :)
  5. provoke.bpk

    provoke.bpk TS Rookie Posts: 17


    Had the same problem. My friend told my how to fix it.

    1.download the drivers from this link:

    2. unzip the file

    3.right-click on the "WinXp" folder, and select send to "my documents" (or were ever you like)

    4. Right click on "my computer" and select "properties"

    5. Go to the "hardware" tab

    6. Click "device manager".

    7. Look for your sound card should be under other devices if you don't have a driver.

    8. Right-click and hit "properties"

    9. Click "reinstall driver"

    10. At the first window select "no, not this time". Select "next"

    11. select " Install from a list or specific location (advanced)". Then , select next.

    12. Make sure "search for the drivers in these locations" is bubbled in. Then make sure that "search for removable media" is NOT checked. and that "include this location in search is" is checked.

    13. Hit "browse" and go to "my documents" (or whereever you saved it) and slect "WinXp".

    14. Then slect "next"

    15. Enjoy it should find it and install it.
  6. jonkey86

    jonkey86 TS Rookie Topic Starter

    nope it didnt work, i did the unzip and sent the winxp folder to mydocuments and did the rest and the wizard said...CANNOT install hardware, any other suggestions? i also tried running the installer and it gave me an error with a number this time it was -536870397...plz help

    this is what my device manager list looks like


    i also got more info for my mobo


    im not sure what to do please help
  7. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 55

    I had that trouble once. I nearly smashed the *@#$ing thing, I tried every SiS driver I could fiind.

    I desperation I downloaded the Driver from Realtek (I can't recall if it was the AC97, or ALC650), but one of them worked.

    It really annoys when U can't get the proper drivers from the Manufacturer - try getting Display drivers that work for an early Vio Lappy :mad:
  8. jonkey86

    jonkey86 TS Rookie Topic Starter

    are there any other solutions to this problem? please help...
  9. Mr Papschmere

    Mr Papschmere TS Rookie Posts: 55

    Give my suggestions a whirl. It worked for me.

    you have nothing to lose
  10. jonkey86

    jonkey86 TS Rookie Topic Starter

    so i try these drivers for REALTEK ? the AC97, or ALC650
  11. provoke.bpk

    provoke.bpk TS Rookie Posts: 17


    yeah I can confirm that the driver is a ac97 I actually downloaded the drivers from ecsusa.com(cuz my mobo). Try that maybe...
  12. jonkey86

    jonkey86 TS Rookie Topic Starter

    Ok downloaded the realtek ac97 and i got sound, only problem is, i hear a scratchy sound on the backgroun, like static...help?
  13. jonkey86

    jonkey86 TS Rookie Topic Starter

    no suggestions??
  14. Snoozerz

    Snoozerz TS Rookie

    i know the answer

    I had the exact same problem as you.... found out that i had to do like Provoke.bpk said with some changes.

    when updating the driver choose " dont search. I will chose the driver to install"

    Then find the driver you want to install and force the install... Works perfect... let me know if u have any questions

    msn: elwood_jake(@)hotmail.com

    Im ofcourse talking about the real driver and not the realtek uve been trying
  15. lalog82

    lalog82 TS Rookie

    first at all, hi everyone, i'm new here.

    well, did the procedure you advise, but still doesnt work for me, i have the yellow icon with the !

    anyone had the same problem?

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...