slave boot problem

Not open for further replies.

I have a compaq factory built PC which is built around a micro star 6577 motherboard (with a celeron 2.8G CPU and 256MB RAM) with phoenix/award 6.00PG BIOS and I'm trying to add a second HDD on which to load linux.

My problem is that the slave disk will not boot, regardless of which drive I place in this position. Jumpers are fine and the BIOS figures out the drives correctly. A spare PC which has two HDD's in, one running solaris 10 and the other running windows 98 allows me to select which one I want from the BIOS. If I put these two disks in my compaq, again only the master is bootable. I have tried all possible combinations of these disks, so I don't think the problem is related to the disks themselves. (maxtor 80GB, WD 80GB, WD 120GB and a maxtor 40GB).

The BIOS only gives the option of ordering the drives, it does not allow individual drive exclusion or inclusion. However, I have tried making the master an inactive volume, this just makes the PC unbootable (it still won't use the slave).

Either of the two secondary IDE devices can be used to boot (DVD/CD and CDW) but moving the HDD's to the secondary IDE controller has no effect. (still only the master disk is seen).

Is there a special jumper (the "don't work as expected" jumper) that needs removing? (or smashing with a large hammer??).


Posts: 1,070   +1
I am not sure I follow your post, but you must have the jumpers on the back of the IDE designated master/slave and placed in the correct position on the IDE cable attached to the primary IDE channel on your MB. Do not make the master drive inactive?
In a Dual boot arrangement
You must load Windows first, the active drive must be the first partition of the first drive . Then load Linux to the second HDD. It will make adjustments to the boot file in order to work.
You cannot change drive positions after O/S is loaded.
problem solved

My main suspect was the BIOS since I had tried everything else, but it was taking me a while to find an upgrade. I did find one today, on compaq's website and it fixed the problem. I can now boot from the slave disk.

Just for the record, in case someone does a search for a similar problem, the PC is a compaq presario with a micro star 6577 (MS6577) motherboard and a phoenix/award BIOS (VER 3.1) and the upgrade can be found here:

It also gives me a nifty little boot menu, so I don't need to run lilo or grub.
Not open for further replies.