Slave Hard Drive Issue

By aussieguitarist · 9 replies
Jul 17, 2006
  1. Hey everyone and thanks for stopping by, Have to say I joined this forum community specifically for this issue and searched the forums for similar problems relating to mine but then again each one is unique to it's own system so I’ll stop rambling now :p

    My pc (see profile for details or feel free to ask) was running fine a few hours ago then I tried a (gigabyte) bios update, which I thought was fine but during updating it froze so I had to terminate the program then restart. Once that happened the bios didn't come up at all and needed to restart again but luckily this motherboard is equipped with backup bios I think... anyway it came up again and that leads to my problem. My slave drive can't be detected! Both drives (160g) run on sata cables. I checked the bios settings to the best of my limited knowledge and didn't get far. Cables are all fine; device manager doesn't detect my secondary hard drive even after much uninstalling.reinstalling..Updating. ect. I’d very much appreciate any feedback as all of my applications are on the "undetectable" hdd, which I need fairly urgently,
    Thanks in advance

  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Have you tried disconnecting / reconnecting the data cable & the power cable on the 2nd SATA drive ? Do you hear the drive power up when you turn the system on ?
  3. aussieguitarist

    aussieguitarist TS Rookie Topic Starter


    Thanks for the prompt reply Didou,
    Yes I have tried unplugging the sata hdd as well as tried changing the ribbon around *shrugs. On start up the 2nd hdd powers up perfectly fine as if nothing's wrong. Just to reiterate on start up the bios doesn't detect my 2nd hdd, which should be in the channel 1 of my sata connector (channel 0 is my main hd).
    Hope that helps. oh and my os is xp incase that is of some use.

  4. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    The fact that the drive isn't detected on bootup is a bit troubling. You can try to plug the drive in the channel 0 just to see if it will be picked up at the POST.
  5. aussieguitarist

    aussieguitarist TS Rookie Topic Starter

    A quick edit. The main hdd runs on ide master channel 0 which shows up and the one which is problematic should appear on ide slave channel 0 but doesn't.

    Could you explain what you mean by picked up at post?

  6. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Hmm come again ? In your first post you talked about SATA cables & now you're talking about IDE drives. Which is it ?
  7. aussieguitarist

    aussieguitarist TS Rookie Topic Starter

    Thats right, earlier I was reffering to the actual positioning of the sata cables on the motherboard and now i mean in the actual bios on startup i get somthing like this:

    IDE CHANNEL 0 MASTER - my hdd
    IDE CHANNEL 0 SLAVE - problematic hdd

    Apolagies if that was confusing earlier

  8. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Well like I said, try positionning the defective HDD on another connection on the motherboard & see if it's detected. Plug it in the primary controller where you currently have your working HDD & see what happens.
  9. aussieguitarist

    aussieguitarist TS Rookie Topic Starter

    If only computers were easy to work with as guitars! gah.
    Yeah I’ve done as you suggested then, I get a screen that tells me there’s an error and the system couldn't boot, is that what you expected? :S
    Also tried installing another hdd I had lying around and it didn't start up at all. I tried the problematic drive and that did start so im not sure what thats telling you. Could that mean that the bios is just refusing to accept any other hdd in another slot? Really trying to get this problem fixed asap.
  10. aussieguitarist

    aussieguitarist TS Rookie Topic Starter

    Hey everyone *waves
    Latest is that I’ve emailed my comp guy and he'll send the motherboard to the manufacturer so I’ll be without a comp for a while when I take it in. Thanks for all your help :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...