Sound card not working, VMM32.VXD not available?

By jack black
Aug 12, 2005
  1. This is a bit lengthy, but I wanted to include all the info I could to aid in diagnosing the problem.

    I was doing a spyware/adware/virus scan a couple of days ago on my Dell running WinME. I downloaded updates to Spybot, AdAware, and avast! antivirus. I ran Spybot and one of the results that came back mentioned Ceres. I've had run-ins with Ceres in the past and know that it can infect restore points. I turned off System Restore, rebooted to Safe Mode, ran Spybot again, and removed the bad stuff it listed. I then ran AdAware and removed the bad stuff it listed as well.

    After rebooting to a regular startup, I noticed a few changes, and they weren't good. First, no Windows startup sound. Next, the two icons in the system tray for avast! did not show up. I did a quick Ctrl-Alt-Del and the Task Manager showed the programs running. After everything finished loading at startup, I opened the Control Panel, clicked on Sounds and Multimedia, and tried to play some other sounds. No luck. I then double-clicked the avast! icon on my desktop to see if I could run a scan. It gave a message that my license key wasn't valid. Since avast! is free for home use, I went to their site and had a new one e-mailed. I cut & pasted the new key into its appropriate place, but it still gave me a message that the key was invalid.

    At this point, I assumed it was just a problem with avast! and if I reinstalled it, that would fix it. I opened the Control Panel and clicked Add/Remove Programs. To my surprise, the program list was completely blank. I had reinstalled WinME a couple of months back and I think I remember reading before that a reinstall can wipe that list out. I can't remember using Add/Remove Programs since the reinstall, so it may have been blank since then, but I don't know for sure. I downloaded a removal tool for avast! from their website, along with the newest version of avast!, removed the original, and installed the newest version. After all that, I still had the same problem with it not accepting my license key.

    I went back to the Control Panel, clicked on System, then on Device Manager. Under the heading of 'Sound, video and game controllers', one of the entries had a yellow circle with an exclamation point. The entry was one for my video card (32 MB ATI All-In_Wonder Radeon) and was titled 'ATITuneP, WDM TV Tuner'. I selected it, clicked Properties, clicked the Driver tab, and clicked Driver File Details. One of the driver file entries came back as 'Not Available'. The entry is listed as C:\WINDOWS\SYSTEM\VMM32.VXD (ntkern.vxd). This prompted me to try the TV tuner on my video card. I attempted to start it, but it gave a message saying to be sure the correct video drivers are installed.

    I went back to the Device Manager, selected my sound card (Creative SB Live! Value (WDM)), clicked Properties, clicked the Driver tab, and clicked Driver File Details. It too listed VMM32.VXD as unavailable. So, that's why my sound card isn't working.

    I did a search and found that VMM32.VXD is still listed in the C:\WINDOWS\SYSTEM directory. Can anyone offer any ideas as to what is going on? I'm thinking that it I'll have to reinstall WinME, but I'm wondering how and why this happened in the first place.
  2. jack black

    jack black TS Rookie Topic Starter

    *** UPDATE ***

    From other info I have obtained, my problem sounded like one that deals with a registry entry. I decided to try and restore the registry (Start > Run > scanreg /restore) and see what would happen. I ran it, picked the most recent date before the problems occurred, and prayed for the best. Success!!! Everything seems to be back to normal.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...