Soundmax driver - struggling to get my microphone to work

By Kua ยท 6 replies
Mar 7, 2007
  1. I have had lots of trouble getting my microphone to work. I have the same problem with different microphones.

    Basically I go to test it in windows or with the similar program that comes with soundmax and it won't work. Often I'll fiddle around with settings for a while and get it to eventually work. Now, I actually have a lot of trouble pinpointing the fix, because it seems to come with something I had already tried. Anyway I fixed it again today and the thing that made it work was ticking the box by 'front panel microphone' in the advanced options of the microphone in the record section.

    So that's fine it works. I come back a few hours later (literally) I haven't changed one thing in my sound settings anywhere and the microphone has decided not to work again. This happens every time I get the mic to work - I come back to use it again and it is broken again. So today I went to check 'front panel mic' is selected, TBH I can't remember whether it was or not. In any case that didn't fix it. So I'm back at square one. This is really very odd and in my eyes inexplicable. It's also driving me crazy. Thanks for your help.

    P.s. I've updated the driver several times to no avail. I've also updated the chipset driver (I understand that's somehow related to sound).

    EDIT: I've also had a slight problem with distortion with some music and in-game sounds.

    EDIT2: I should also state that the driver for the soundcard came with the mobo (ASUS - check my profile for exact type) and therefore I presume it's a 'built-in' soundcard. But I have no idea who made the soundcard or what type it is - I've just been installing the sound driver for my mobo on the ASUS support site.

    EDIT3: OK I just found a thread from a guy with the same make of mobo and the soundmax driver, he had a very similar problem. Somebody found the following fix:

    I FIXED IT!! The fix (if you haven't bought a new sound card) is to go to
    C:\Program Files\Analog Devices\SoundMAX\ and run ATIrem.exe. This will remove all the soundmax files. Then put in the ASUS cd and run the "Add New Hardware Wizard". It'll find the sound controller and then you just have to reinstall it. Once it's reinstalled go to ctrl panel > sound devices > voice > volume and make sure mic is checked with the volume up. Then click properties, playback, and okay. Click file then advanced properties if it isn't already checked. Then click the advanced button under microphone and make sure mic2 select isn't checked. I checked it first, then unchecked it. VOILA, the mic SHOULD work...

    The thing is I do not have ATIrem.exe. So I'm stumped. Perhaps I have it but under a different name, no idea really. The only other things it could be are: Devsetup.exe and AEEnable.exe. But so far that hasn't done the trick. In fact trying to open them does nothing, one brings up a black box for a split second but that's it. Perhaps that was the case with ATIrem.exe but running them doesn't remove the soundmax files. *SIGH*!!!
  2. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Right I've done a google for ATIrem.exe (several people have had a similar problem - and often the above fix is quoted) and read through all the results. Basically if they didn't have ATIrem.exe (presumably it was on an earlier driver) then they couldn't find a way to fix it. I'm coming to the conclusion that this ASUS built-in sound card is unable to support microphones and that I need to go and buy a 'proper' sound card. The thing that really bugs me is that I can sometimes get it to work. My problem is similar to the person (for whomthe above fix was found) or at least someone in the same thread in that I could get it to work but once the computer was turned off or went into standby it would cease working. Well I actually don't think my PC goes into standby (that's when it ceases to have a screensaver and instead is just a black screen right?).

    Anyhoo it's fairly unlikely that someone will know a fix, seen as so many have tried and failed to fix the problems of others in the same predicament. Looks like I'll have to go to the shop I bought the PC from and see if they'll get me a proper soundcard :p. TBH I doubt they'll believe the mic doesnt work tho, I'll have to take the PC in - again!

    EDIT: (Kudos to you if you got this far) I found this description of a codec on soundmax's own website. You only really need to read the bold type:

    Based on the highly praised AD1980, the AD1985 is ADI's latest and greatest 6-channel audio CODEC. Not only does it include all of the AD1980 features, but, when combined with SoundMAX4 XL, it will deliver intelligent peripheral detection and configuration features better known as AudioESP. Exclusive only with the AD1985 and SoundMAX 4 XL, AudioESP advanced jack-sensing and enumeration eliminates a common problem audio users face - the inability to get audio in or out of their PCs because of mismatched audio peripherals (speakers, headphones, mono and stereo array microphones) and I/O jacks. In addition, the SoundMAX 4 XL software suite offers users one-click control of the complete audio subsystem through a new and easy-to-use GUI. This combination greatly mitigates the risks associated with shipping 6-channel integrated audio CODECs down on motherboards and helps significantly in reducing end-user support calls, product returns, and the total cost of ownership of the audio subsystem.

    I've absolutely no idea whether this codec would fix my problem, it seems you have to pay for it in any case (or it's not available). I'm having a search around for it though. Although once again the need for a codec is not consistent with the fact that I am sometimes able to get the damn thing to work! *sob*
  3. Kua

    Kua TS Rookie Topic Starter Posts: 58

    LOL. This is becoming more of a public musing than anything. May be someone will see this and have an idea though.

    I'm absolutely desperate to fix this so have I reinstalled the driver AGAIN!!! (must be the fifth time or so). Well I went into the Soundmax control panel, clicked 'Front Panel Microphone' (does anyone know what this refers to?) and voila it worked again. Does this mean I have to reinstall the driver every time I want the mic to work :( - because I am almost certain (although I always live in hope that when I come back to my PC tomorrow it will no longer work)?

    I just rebooted and OMG it still works. It may be sorted, but I don't know how really. I'm a bit skeptical though. I'll keep you posted.
  4. _FAKE_

    _FAKE_ TS Rookie Posts: 116

    Well, i honestly don't know what to say, I also have SoundMax, and i did run into a few problems at the start, but somehow SoundMax found away to fix that. My problem was that the sound was distorted, before i updated the sound driver I found away to fix the distort, just go into SoundMax control panel, click on preferences and click the DTS Connect Tab, and than select Music and NOT cinema. But with the latest update, it doesn't matter whether or not Cinema or Music is selected, it still works.

    As for your microphone, does it simply not work at all after it dies, or is the sound really soft?, I selected 'Front panel microphone' for the microphone options and my microphone just died, so I un-ticked it and it worked. You might want to try ticking Microphone Boost, it helps boost the volume of the microphone so others can hear you better, and your voice recordings will become clearer.
  5. Kua

    Kua TS Rookie Topic Starter Posts: 58

    Predictably the mic doesnt work again today. I tried the settings I had last night but no change. This is the most unfathomable of mysteries. Every time my mic dies I try all those settings all over again in every combination. Doesnt help. i suspect reinstalling the driver would fix it again. But thats not terribly convenient to do it every time :p.

    EDIT: I apologise, I was actually using it this afternoon, so something has happened between then and now to stop it working. I ran Fraps and watched the vid of that but meh - how could that be connected? :p

    The mic does pick up something when its dead. But it's completely unusable.

    EDIT2: OK may be I've found a fix of sorts =D. I reinstalled the driver which only takes a couple of minutes, reboot voila it works. Actually I don't use the mic everyday so I can live with this. Let's hope it always does the trick :). I'm still baffled as to what's going on however :p.
  6. Notavi

    Notavi TS Rookie

    Same issue - but can confirm it's mostly driver related.

    I'm having the same issues getting my microphone to work under Windows XP. However, I also run a dual-boot setup and using Linux \ ALSA the Microphone functions fine.

    The only oddity under Linux is that sometimes it takes a few minutes once the microphone has been connected for it to start working but after that, it all works fine (I wonder if this is a clue re: the windows issue - is the driver having trouble recognising the presence of a microphone)

    I'm certainly interested to hear if you've had any progress with this.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Troubleshoot Microphone Prolems

    Notavi or others with microphone problems

    Check if applications are allowed exclusive use of the microphone
    Control Panel->Sound and look at Microphone->Advanced Properties. Are options listed for Exclusive Mode? If yes and are checked, an app that starts up with Windows can grab exclusive use of your microphone thereby not allowing other apps to use it. Note same may true for your speakers!

    Troubleshooting links
    These links are from HP and one is an older link so everything listed may not apply BUT in general they provide a good to-do checklist
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...