Static IP connection - All ports refuse connections

By sethbest ยท 5 replies
Nov 21, 2013
Post New Reply
  1. I was setting up a DVR to be accessed from outside a restaurants network. They purchased a static IP address. I've set these up a half dozen times before, usually with this was my first time that a client actually bought a static line so I thought it would be easier.

    So I setup my router, an old wrt100 Linksys, with all the correct static IP and DNS info. Setup port forwarding and tried to connect from my phone's internet connection using a laptop. No luck. So I set the laptop as the port forward address and ran a portscan from a website, and checked the port individually from Both said "Refused connection" or a derivation there-of. The scan showed this for all ports. I disabled the firewall and set the laptop as DMZ and still got this message on every port I checked.

    I then plugged the laptop directly to the modem (SURFBOARD SBG6580) and entered the static IP info into the network adapter settings. Internet connection worked fine but still kept getting "refused connection".

    I then spent an hour on the phone with Brighthouse Networks as they tested everything on their end, and inside the modem (which is actually a modem/router but they wouldn't give me the login and pass to check it myself). They said the problem must be on my end and that they do not block ports except 66 and 67 or something like that.

    Connected directly to the modem and still getting this problem, even after several reset attempts on the modem, I can't think of what to do next. I even set it to pickup the network automatically as the modem/router has a dhcp server in it. While it could still connect to the internet all ports still refused connections.

    I'm stumped. Any help would be appreciated. Thanks.
  2. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 79

    Figured it out. As always when it doesn't make sense it's because theres' more than one thing wrong. The router's port forwarding wasn't working, and I had forgotten to disable to laptops firewall and I guess windows 8 has a more sensitive firewall than 7. So plugged in the DVR directly with the static IP info typed in and worked like a charm.
    St1ckM4n likes this.
  3. jobeard

    jobeard TS Ambassador Posts: 11,124   +982

    Far more likely it was the failure to configure the firewall for the DVR port access.
  4. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 79

    I disabled the routers firewall, and used dmz, and the DVR had no built in firewall. The firewall I was talking about was the laptop I plugged in after I couldn't get the DVR to work to test with. So I couldn't figure out that it was a forwarding issue since even when I plugged the laptop directly into the modem the windows firewall was blocking the portscans.

    Cheap routers having issues with port forwarding is nothing new in my experience though not especially common, I've seen it at least twice before. I think it's one of those features that gets overlooked in early firmware tests.
  5. jobeard

    jobeard TS Ambassador Posts: 11,124   +982

    I understand that your pragmatic approach got you to a solution,
    but doing so has put your system at risk. With the PC directly connected to the modem WITHOUT a firewall, you can easily be attacked.

    As to port forwarding issues; typically it's due to misunderstanding and malconfiguration, not the router support per se.
  6. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 79

    DVR With password protection and only 2 ports open...not a pc.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...