1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Strange Kingston USB issue

By Ritwik7 ยท 86 replies
Apr 17, 2010
  1. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    AH HA!!! I got it! :approve:

    MS moved stuff around in Windows 7. AND! : i also found, by default Windows is already doing basic (vs. verbose) device logging! (at least so i found for my Windows 7 Pro install)

    So before we do anything else: Do you see a file C:\Windows\inf\setupapi.dev.log on your currently installed system?

    /* edit */
    Oh. and just saw you posted at same time... Not sure what you mean.... by "Hmm its sort of similar for me.... "
  2. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    I am at work, and on this notebook I have the file you've asked me to look for, I believe it should be case as well on my desktop (at home). And I was talking about DM traces as well.
  3. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Cool. Any remote chance you might also have backed up the installation where things didn't work? so maybe there'd be a copy of that file as well for the case in question? (a long shot but figured i'd ask)... in any event, off to bed.. check in w/you tommorrow
  4. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    No, because I reinstalled the OS with the device attached, however, last night i've created a partition for new installation again (without the device attached); so i will get back to you on this one as soon as I have some time to do this. Thanks and Regards
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Hi Archean

    Things to do (at your convenience and whenever you have the time)

    First, about DM Trace Logging
    Output file
    As you found, DM trace output log for Win7 is C:\Windows\inf\setupapi.dev.log
    ==> Ignore any other setupapi files you see

    Setting the Verbosity Level
    Trace verbosity level is controlled by HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\LogLevel
    ==> Pls tell me the LogLevel default value for both your current + your new Win7 installations (i'm guessing should be the same)

    Looks like Win7 sets a default verbosity level so DM is always writing basic trace data
    ==> When we do traces we'll increase the verbosity (I'll give you the value)
    ==> When we're all done with our project, you might want to turn it off entirely so it's not constantly writing to your disk. (And i assume MS has limited its max size - which was a problem once upon a time in XP!)

    Normally, each time we want to start collecting new trace data, pls delete the current C:\Windows\inf\setupapi.dev.log file
    ==> Windows will simply open a new one the next time it writes data
    ==> And that way we can reduce all junk we don't need in the file plus what we can find what we're looking for near the start of the file

    Also note: if you run a cleaner tool like CCleaner, depending on how its configured, it might remove all Windows log files (including the DM trace log) as junk. So fyi to either change its config or be careful when you run CCleaner vs. when you are collecting and saving data (save files with an .old extension vs. a .log extension to be safe)

    For now why don't you do this:
    1. On your current good install, save a copy of the current log file
    2. Then do the rest on new install, put the code below into .reg file and run it to set log level and reboot
      Windows Registry Editor Version 5.00
    3. Install devcon and the devcon .bat file
    4. Delete the current log file. Install the patch. Save a copy of current log file. Run devcon script and save copy of output
    5. Delete the logfile. Install your device drivers (but don't open the device yet). Save a copy of current logfile. Run devcon script and save copy of output
    6. Delete the logfile. Now open the device as before. You still have a problem? Then save a copy of logfile and run devcon script again and save output
  6. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Well, I had plans for tonight to install a new copy of win7 to try out your proposals; however; as I was preparing to do so my system crashed totally out of blue. Ironically with a BSOD + 3 beeps :( anyway, despite having it set to record minidumps, it didn't record anything; nor it was willing to send any signal to display. So I ended up disassembling the whole system; then putting it back together, long and the short of it is, after about hour or so I figured out one more of my RAM modules probably was causing this; so I took it out and the system booted normally. Now, this is really strange, this is second kingston module which has died in last 8 months; so I am left with 4GB of RAM :mad:.

    However, I do remember the error code was 0x7E with APCI.SYS as the process which caused it.

    I have DDR2-667 MHz modules, which aren't available here anymore; and I am unsure whether swapping the remaining good ones along with buying couple of more 2GB sticks of 800MHz modules is worth spending money on (i.e. ROI).

    Anyway, I guess what time I had allocated for this task is gone for now; I will do it ASAP when I get some time and I hope this thing will hold.
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    One never knows what terror lurks around the next corner within a Windows PC :p I'm in the middle of my own (small) disaster myself..

    I bought a new XFX Radeon HD 5450 graphics card. It worked (somewhat) in XP. It also worked (somewhat) in Win7 till i thought to try a fresh clean Win 7 reinstall plus a Dell BIOS update. So, now every HD 5450 driver i try (old or new) simply BSODs on install. So... i can only work in my Win 7 boot with generic video drivers at the moment (so the display is "useable" but not convenient)... So no need to hurry on my part! :haha:

    I'll probably get a different graphics card in next few days (and P.S.: stay away from that new Radeon HD 5450!)
  8. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Such is life ........... but I think probability is in your case it may be a hardware issue. Perhaps a bad graphic card?? I am using a Radeon HD 5770 (which i bought couple of months ago), and I am satisfied with its performance.

    Talking of BIOS updates, I am bit more cautious about these now, reason being last time around when i updated same type motherboard to latest bios, I ended up where I couldn't reboot my system at all it would be stuck at black screen endlessly, so every time i needed to do that, i would have to power off system and then turn it back on. Later on, on Intel forums I found out that the latest BIOS update had that bug (and I was bit lazy to downgrade to previously working BIOS), anyway I got that motherboard replaced in warranty due to other hardware issues, hence, my issue has been 'luckily' resolved ;).
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    This is actually the first time i had occasion to change an add-on graphics card. (Actually, this is my first desktop in ages! - Till now, i was always running laptops with docking stations)

    A couple basic questions

    1) The RD 5450 quick install guide (the only install guide) mentioned connecting power to its 6-pin connector. But i never saw anything that looked like a connector on the back of the card for power... Did i miss it? Hmmm.. Looking at the card, I didn't see anything that looked like it and looking at the card's pic again (below), i thought all the connectors on the bottom of the card fit into the chassis slot... or if i open my computer up will i find one of those connectors on the bottom of the card isn't in the chassis slot and is, in fact, missing a power connection??

    2) Also, i need a low profile card. The instructions didn't say but it seemed to use the low profile bracket, i simply disconnected the VGA connector to the board, switched to the low profile bracket, and inserted the card with the VGA connector open. I assume that shouldn't be an issue?

    /* edit */
    Oh. maybe i answered my own question as looking closer at the pic it looks like the first connector closest to the bracket is actually shorter then the rest!! so probably isn't sitting in the slot at all...
  10. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    It doesn't require any 'external' power source i.e. 6 pin (75W) connector usually needed for middle/higher end models. However according to AMD/ATI you need 400W PSU.

    Lastly that first connector isn't actually needed to sit in the slot, it probably is there to hold it the card in stay aligned position (if someone know better, correction will be highly appreciated).
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    First, let me thank you for letting Archean and I hijack your thread! :p

    Looking at the image again, i notice that first "connector" is actually beige not gold. So i suspect you're right as it appears after a second glance at the pic there's not any electrical contacts on it.

    But i'll double check when i get around to opening up the desktop to try a different card. And I'll also check the PSU. Thx :)
  12. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Well I've taken the 'unwanted' step of buying a 2GB DDR2 stick to replace the dead one :( and I hope this coming weekend I will find some free time to do this installation.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    An attempt to commiserate.... An update (and some questions) re: my graphics card issues.

    Last i left off, i had applied a BIOS update and could no longer install either the old or new Radeon drivers under Win 7 for the XFX Radeon 5450 i just bought (the old one on CD nor newer found on their support website)

    1. I ran DriverSweeper tool to cleanout any driver pieces and then re-seated the card. Partial success! I now came back came back to my original problem: Sound playback over HDMI is losing the 1st second of sound (so short system sounds weren't being heard but music/video/long wav files could be heard).

    2. I ran out and got an ASUS ENGT220 1GB DDR2 but discovered its low profile bracket wouldn't fit my Dell Optiplex 360 desktop. Their PCI-E card fits dell's chassis slot, but it uses a bracket needing 2 slots to expose its 3 external connections (slot 1-HDMI & DVI, slot2-VGA) but their 2-slot bracket doesn't fit the layout/cutouts in Dell's cage! Grrrr...

    3. I just put in a Zotac Geoforce 210 512MB DDR2. Booted in Win7, installed drivers and got great picture and perfect sound!!!!!! But when i boot to XP and install the drivers, the screen now looks like crap on my 1080x720p Samsung UN22C4000. (Tho screen looks great when its installed and running in my Win7 boot!! any sense?)

    So i'm thinking of maybe next using Radeon's single slot low-profile bracket with the ASUS card. The "bolts" that secure the bracket around the HDMI/DVI ports are OK but using the non-ASUS bracket will mean i can't use the extra screw that secures the bracket to the card (in addition to the "bolts"... Any thoughts if the screw is really needed? (ASUS and Radeon use the screw. I see Zotac doesn't use it when the low profile bracket is being used)

    And any idea why the Zotac looks like crap under XP???? I guess i'll double check the XP drivers tomorrow when i have the energy and will to spend more time on this pain-in-the-$$$!
  14. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Did you uninstalled 'previously installed graphic drivers' before installing the newer graphic card and its drivers in XP? Just in case some thing from that may be causing this glitch, as if the card works perfectly in one OS, it should work in another one as well.

    I think if you don't use the screws, the cards will move around a bit in the slot, and may cause you issues at some point.

    Need for 'up-gradation/customization etc.' is one reason I never bothered to have a look at 'branded' desktops let alone buying one.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    Yea, I agree and think i already knew that when i asked the question! I was just too tired and grumpy at that point and it was just wishful thinking! :rolleyes:

    Further indication of just how tired i was... Turns out the reason for the crappy screen display in XP resulted from
    1. The driver defaulted to wrong screen resolution
    2. When i manually adjusted it, i managed to pick a different and still wrong resolution! :eek:

    That'll teach me to work on things when i'm way too tired! LOL

    Something new
    Something i've observed with both graphics cards and wonder if you might have also seen in Win7 (haven't checked if same for XP).... If i let my computer go into Standby, I can wake it up with the mouse (i can see disk and other light activity) but the HDMI port (maybe the entire addon card?) seems to remain asleep. i have to reboot to get HDMI back.
  16. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    I haven't observed this issue, but then again I don't have HDMI port on this Radeon, it has two display ports and one dvi port.

    Anyway ...... good to know that it was rather 'minor' issue with regard to resolution :)
  17. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Post Withdrawn.
  18. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    The value for installed (usb working) system is: 2000ff00
    The value for newly installed (usb not working) system is: 2000ff00

    Please note that I also applied the change in value recommended by you but nothing doing.

    Then I did something which I should have been bit careful to do, i.e. apply those Huawei firmware update you suggested. The update went well but the device stopped working afterwards .... so now I have effectively bricked the USB device, unless I can find the right firmware update for my region, i.e. Pakistan. I have bought a new one, but there is incentive in fixing the old device (at least restoring its firmware to what it was) and that is my wireless broadband provider will take back the device and refund me 70% of the device cost. Any suggestions will be welcomed in this regard. Also I will try to see whether Huawei have also released firmware updates for my region/country as soon as I get some time.

    Lastly, WLL (service provider) has told me that the newer device I got have the updated firmware, therefore, it will work right out of the box with windows 7, lets see what happens though, when I plug it in some win7 machine which doesn't have had wireless connection configured beforehand. Regards
  19. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    That sounds like the Windows default value for that key
    When you apply the recommended value, i would expect to see lots of log file activity IF the device manager is involved (e.g. installing or uninstalling). If you saw no log file activity when you ran the Win7 update it must have done just the firmware. Or if it also changed any driver files (e.g. simply replacing files) it didn't invoke any device manager install or uninstall functions. (btw.. i believe the default value may also generate some, tho just a bit, of logfile activity vs. the one i recommended)

    If you set the value i recommended and then try uninstalling/reinstalling your CD/DVD drive as a test case you should see lots of log file activity.
    Ugh! Am so sorry. I certainly didn't expect it to brick your device either. As mentioned before, I couldn't recall where i first found that patch (tho i know it would have been from what i thought was a reliable site) But I searched for the patch name Windows-7-Upgrade-Patch-for-Huawei-EC168C now and I find
    • Patch file, at least based on the name, may be from Tata India? Maybe this Win7 patch is all firmware that's unique to Tata?
    • I also now find this MS Windows 7 update. (I don't recall having seen this hit the last time i went looking)
    I'll try to see if can find anything from WLL Pakistan for your Huawei
  20. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    That is alright, we were trying to learn the reasons of this issue and in the process find a way to fix the issue. Hence, absolutely no need for being sorry :)

    I have also contacted someone in WLL's IT department, which handle such issues, and the guy has promised me to send the appropriate firmware update/driver asap.

    Having said that, I have also looked around for any updates from Huawei for WLL but no luck so far. Thanks and Regards
  21. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    They want the USB device back so they can try to fix it themselves ..... but as its weekend I won't be sending it back till Monday; so if something comes up do let me know; in the meanwhile I'm also looking around to find suitable firmware/drivers etc.
  22. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    Ok Guys last update to this thread, been extremely busy at work lately (these 3 months are usually the busiest for us) ..... I simply didn't find enough time, or was too tired when I had it to try out something. Anyway, what I did was asked WLL to look into it, and recently they've posted a 'hotfix' which apparently works alright. So, the problem is solved, however, I still have that bricked device which I haven't had time to take back to WLL for fixing it, but then again ..... I bought a new on ;)

    Thankyou very much for your insights and help everyone and especially LA.

    See you around, Best Regards :)
  23. Ritwik7

    Ritwik7 TechSpot Chancellor Topic Starter Posts: 1,672   +9


    Okay guys! Hope you've all been doing great. :)

    Now for a new twist. Just yesterday I tried a USB hub on my PC. I took my friend's Kingston and tried transferring large files after plugging it into the hub. Voila! All went smooth.

    Somehow it's still not working when I plug it into the slots on my mobo or case.
  24. Archean

    Archean TechSpot Paladin Posts: 5,690   +95

    I'm doing fantastically well Thanks, I hope you are too :D

    So it works if you place the hub connector in either of the ports in question and then connect the usb to that hub?
  25. Ritwik7

    Ritwik7 TechSpot Chancellor Topic Starter Posts: 1,672   +9

    Exactly mate! Talk about SINISTER! :p
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...