Strange router-adapter connection problem

By vegar
Jan 26, 2006
  1. Hi,

    I'm trying to connect my XP SP1 computer to a gateway router (dell wireless 2350).

    I've tried both a Netgear wg311t wireless adapter and a Dell Wireless 1450 USB adapter

    Installation works fine on both, and the connection monitors claims to be connected to the network (I've tried letting both windows and the adapter software "be in charge") . But when checking the status of the connection, under "Adress type" it says "invalid IP adress", and the IP adress and subnet mask are both

    When trying to repair the connection the error reads something like "Can't renew IP-adress. Failed to empty DNS (...)" and so on (translated from norwegian).

    The (stationary) comp's fairly new, still hasn't been connected to the internet, runs no AV and is set to receive ip and dns server adress automatically.

    There are three other XP computers connecting with the same Dell Wireless 1450 USB adapters and no problems, plus a number of different laptops with different cards, also without problems.

    I'm thinking it might be some kind of compatibility issue, but I've removed Nero a TV card (Pinnacle) and all other apps that could be interfering.

    I've also cleaned the registry.

    I'm completely lost as to what to do- PLEASE HELP!!!


  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    You should compare the network configuration of your computer with the others. See if they are getting their IP and DNS addresses automatically. You may have to register the MAC address of your wireless adapter on the router too.
  3. vegar

    vegar TS Rookie Topic Starter

    Thanks Nodsu,

    But it turned out the computer had crashed a while ago, and some kind of DNS/DHCP error message had accompanied very strange sounds from the processor.

    I looked at the "services" of the "administrative tools" (from norwegian) in the control panel, and it turned out that both the DHCP and DNS clients were set to manual. I set them back to automatic and that solved it.

    The crash and the error message sounded strange to me though, so I guess I'll just reinstall windows to be sure...

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...