1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

System Event Sounds and Wav Files Won't Play

By Sandwav979 ยท 11 replies
Jan 21, 2006
  1. I installed the XVid player for Windows XP Home the other day and it hung during installation so I had to restart my computer. All of a sudden I don't have any more system sounds and I can't play .wav or .midi files. I tried doing a system restore, but of course none of my restore points allow me to roll my computer back to that date. Then I tried troubleshooting it through Windows Support...no go. I removed and reinstalled my sound card and drivers (Creative Labs Sound Blaster Live!) and installed all the codecs I could find, still no dice. Here's the kicker...I can play MP3s through WinAmp and video with sound through Windows Media Player, but I can't play .wav files or .midi files. Whenever I go into Sounds and Audio Devices and highlight an event sound, the play button remains dimmed. If anyone has any ideas on how to fix this issue short of formatting my HD and reinstalling Windows, I would be very appreciative.

    Losing patience quickly,

  2. Peddant

    Peddant TS Rookie Posts: 1,403

    In the sounds and audio control panel is your sound card registered as the preferred device for playback ? What is listed in the MIDI box ?
  3. Sandwav979

    Sandwav979 TS Rookie Topic Starter

    Issue Resolved

    In answer to your question, my sound card was listed as the preferred device for playback and there was no device listed for MIDI playback. There were about 5 to choose from (4 specific to my sound card and one generic for Microsoft), but every time I chose one and clicked "Apply", it disappeared again and wouldn't stay set.

    Regardless, I attempted a system restore AGAIN in safe mode and miraculously it worked the second time around. Maybe I did something to make it work this time around that I didn't last time. Who knows...But I got sound! HA!
  4. Peddant

    Peddant TS Rookie Posts: 1,403

    System restore worked!!!!! Congratulations.That`s a very rare event.
  5. Eggmann

    Eggmann TS Rookie

    ^im having the same problem, my problem is i cant system restore because its already too late.I choose the MIDI playback and click apply and it disappears.Anyone got any clues on how i can fix this ,like suggest any programs or w/e . thx
  6. greatman05

    greatman05 TS Maniac Posts: 423

    Try this...

    Go to Start, then click Run. In the dialog box that appears, type msconfig and press enter. The System Configuration Utility should come up. Go to the system.ini tab and verify that these three enteries are in there:



    If they aren't, add those entries and see if that helps... :grinthumb :giddy: :D :unch:
  7. Eggmann

    Eggmann TS Rookie

    thx for trying to help :grinthumb

    This is what i got [​IMG]

    i dont see the +Boot

    double clicked Driver [​IMG]
    how do i add the +Boot :confused:
  8. greatman05

    greatman05 TS Maniac Posts: 423

    I'm Sorry, thought u were using Win9x/ME...try WIndows help...sorry i couldn't be of much use...
  9. loupegarou

    loupegarou TS Rookie Posts: 39

    safe mode

    you should be able to go into safe mode and uninstall the xvid?
    Have you done that already?
    You probably need to remove the dlls associated with xvid...they are in the system32 folder.
    See if you can reinstall xvid in safe mode (may fail may not)
    If it works it may fix your issue. Sometimes a dll is locked that xvid needs to replace and that will hang or stop the installation.
  10. Sandwav979

    Sandwav979 TS Rookie Topic Starter

    Re: Sound Card Issues for Eggman


    I would suggest trying to enter Safe Mode during your computer restart in DOS. To do that, refer to your manufacturer instructions on how to enter the selective start-up screen (for most Gateways, it's holding the F8 key during booting, for some Dells it's either F1 or F12). Select 'Start Windows in Safe Mode' and let it boot as normal. When Windows opens, go to Help and Support, and System Restore. You should be able to select a restore point prior to when the issue began and it should work. Keep going back in the restore point history until you find one that works, but make sure you keep trying while in Safe Mode.

    If you're having a problem with System Restore, make sure you click on the System Restore Settings link on the bottom left of the screen and make sure the box that says "Turn off system restore on all drives" is unchecked. Although it won't help you with your current issue, it will provide system restore checkpoints from here on out during regular intervals.

    Hope the system restore works in Safe Mode. Worked for me and saved me a lot of stress and time.

    Good luck.

  11. sonicking

    sonicking TS Rookie


    I am suffering the same problem. I cannot restore the system even in Safe Mode. Is there any more idea and suggestion? Thanks!
  12. supergel

    supergel TS Rookie

    i know the last post in this thread is over a year old, but i felt like i had to post a response here. i suffered these same audio problems with my computer until just about an hour ago. techspot was one of the first sites that popped up when i searched for solutions, so i feel obliged to post here (in case anyone else with similar audio problems comes across this site).

    after days of endless searching, i found the following website:

    that website solved my problems in a second (which, unfortunately, came after several days of pulling out my hair). i had the same problem where no matter how many times i uninstalled/reinstalled my sound drivers and reset my sound settings in the control panel, no devices would be selected for my midi or voice playback. my computer would play pretty much any sound except for system sounds or flash audio (all system wav files would play perfectly thru windows media player, though). system restore was not an option for me, due to the restore files being corrupted and not letting me restore to any of the points that the computer had created.

    anyway, so after days and days and days of searching, i finally found my answer. apparently, the problem i had was a deleted k-lite codec. prior to the problem, i had been uninstalling various programs that i no longer needed, so when i cleaned my registry, i was sure that this "k-lite" business was adware or something, so i deleted it. my mistake. follow the instructions on that website, and there's an 80% chance your sound will work again.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...