System Mechanic 6 changed Network settings - can't access PC

By Doctoxic · 26 replies
Nov 18, 2005
  1. Hi all
    Situation is as follows:

    Netgear modem router (wired)
    3 PC's connected
    All 3 can connect to internet
    All can see each other but not all can connect to each other
    PC1 is the main PC that had the router software on it (not sure this matters)
    PC1 - can transfer files to and from the other 2 PC's
    PC2 and PC3 can see each other (haven't tried file transfers), BUT
    PC2 and PC3 cannot access PC1 - i get access denied contact admin

    Now, they were all working fine last week and the only thing that i can think that might have affected it is i installed System Mechanic 6 - maybe changed some settings? I ran a security wizard and my 'safety' rating is now higher so it must have changed something.

    I have looked around but can't see anything obvious.

    i am assuming it won't have changed router or firewall settings

    each PC has a different user and PC name but same workgroup name - this all worked fine before so i don't really want to change anything here

    The PC that can't be accessed is XP pro and the others XP home.

    Any suggestons as to how to fix?

    Many thanks

  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Access Denied implies you are able to connect to PC 1 in some fashion. So we can rule out connection problems and firewalls, I believe.

    Some more information may be useful, such as what operating systems are you using? Windows XP home...? Pro...? 2000...? Etc. Also, how are you connecting? Do you have user accounts and privelages set up or using simple file sharing? What is the general location of your shared files.. An entire drive, a certain folder? Where is that folder? What are the network names of your computers? When your computer says "access denied", does it display a more specific reason? The more info you can provide, the better. :)

    Assuming you're using Windows XP and simple file sharing is turned on, sharing should be pretty straight forward. It's just a matter of right clicking on the folder and choosing "sharing" and enabling shared folders.

    By default, the "everyone" account is enabled on Windows XP and offers anyone who connects to your computer on a LAN read access to whatever shared folders you may have. Well, this is how it is supposed[/b] to work at least.

    It is possible your Everyone account has been disabled. You can view your user account settings (Windows XP Pro) by typing lusrmgr.msc in Start -> Run and pressing [Enter].. But now that I think of it, i don't remember if "Everyone" shows up in the users panel and this is a company computer.

    But hey, here's all the info you need:;en-us;304040

  3. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try uninstalling the program
    I tossed out my copy of SM
    nothing seemed to work right
    had problems with defrag
    optimize internet made it go slower
    the file shredder kept files and locked up the trash
    3rd party spy removal virus separate fee's
    the only thing that seemed to work (half assed) was the move a program app.
    after uninstall just see if you can add network through wizard
    my rant is over
  4. Doctoxic

    Doctoxic TS Rookie Topic Starter

    Hi all - thanks for the comments:

    here goes with some more info - and questions :)

    * PC that can access out but others can't access it is XP Pro

    * Laptop has XP home and can ping the Pro PC and see that its there - it just gets an access dnied message

    * the silly thing is that i have networked these before and know a little bit about the basics and could set it up again from scratch - BUT i am sure some setting i don't normally use has been changed - Also - this setup was working fine for weeks before i installed this software and i know its changed settings - just don't know whic ones

    * i have tried with simple file sharing on and off - no difference - in the past when it worked all this did was restrict acces to a few of the key folders like 'program files' - not the whole thing (its turned off at the moment on the PRO pc but not on the Home one)

    * when you say 'everyone' account do you mean 'guest' account? sorry to be a pain here but can you be specific as to what i need to check - there is no everyone account. The permissions on the C drive have an Everyone account but full control is not ticked.

    * sharing and security for local accounts is 'Classic'

    * 'Let everyone permissions apply to annonymous users' is disabled

    * my 'Guest' account is a member of guest and the only things ticked on it are user cannot change PW and PW never expires

    * samstoned - what version were you using of system mechanic - cos 6 seems to work fine so far

    i am sure its one simple setting somewhere - its so annoying because so there are so many damn settings! :(

    many thanks

  5. Doctoxic

    Doctoxic TS Rookie Topic Starter

    one other thing - the share name is C but in the dro down there is also a C$ but it never stays on C$ - does this matter?

    thanks again

  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I make a new share call it something fancy IE: seagateD200gb
    delete the C$ orD$ or what ever
    delete (all users) premissions after making a admin and network
    on xp system the home has to have the same user as the xp pro
    so what ever the xp pro admin is add this to xp home admin
    password also
  7. Doctoxic

    Doctoxic TS Rookie Topic Starter

    thanks samstoned - i'll try it tomortrow and report back

  8. Doctoxic

    Doctoxic TS Rookie Topic Starter

    someone suggested this in another forum:

    Most likely incoming netbios ports were disabled (137,138 and 139) on PC1. Given the fact you are behind a router/firewall you can open those for the internal network for file sharing. I havne't got system mechainc running here right now, so I can't tell where to change it alas...

    any comments on this and if it is correct how do you open a net bios port?


  9. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    xp firewall settings or the setting that came with SM ??
    again I would uninstall SM
    check your nic see if it has been reconfiged
    I guess the software website does not help (SM)?
    you can try to add the netbios protoco/service to the nic or see if it missing
    I don't think this is a native default in XP
  10. Doctoxic

    Doctoxic TS Rookie Topic Starter

    Port scan results (PC=5, Router=1)
    Computers count=255
    Computer number: 1
    Name: no information
    IP address:
    Ports ( 67 scanned, 2 opened, 65 closed )
    Port 80 - open
    Port 5190 - open
    Computer number: 2
    Name: linux
    IP address:
    Ports ( 67 scanned, 2 opened, 65 closed )
    Port 139 - open
    Port 445 - open
  11. Doctoxic

    Doctoxic TS Rookie Topic Starter

    Thanks for all the help.

    I had to do this to fix it in the end:

    In XP, go to Administrative Tools from Control Panel. Then Local Security Policy-Security Settings-Local Policies-Security Options.

    Scroll down to the 2 similar entries, Network access: Do not allow anonymous enumeration of SAM accounts...
    Double click on each of them in turn and set to disabled.

    turns out someone else with SM6 had similar problems


  12. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    anything else that may happen with SM6 let us know
    would be appreciated,muchly.
    I think I was using version 5.5 when last I gave up
    just did not have the time to fix all the misstakes it was causing.
    it would make a nice all in one solution if it worked.
    as to me I think there is something inherently bugging about apps that do to much.
  13. Decker74

    Decker74 TS Rookie

    XP Home?

    I've been having the same problem with System Mechanic 6.

    However, I have XP home, which does not have the Security Policy option.
    Anyone know how can I reverse what System Mechanic has done so other PCs on the network can access my PC?

    Much thanks!
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    try XP's System Restore
    or network repair
  15. iss

    iss TechSpot Chancellor Posts: 1,994

    System Mechanic 6 sucks big time. I uninstalled Sm5 and tried SM6 and promptly uninstalled 6 and went back to 5.
  16. Decker74

    Decker74 TS Rookie


    Thanks for the ideas.
    For whatever reason, I cannot restore to a previous point. There are plenty there, but each one fails.
    I tried repairing the connection also, with no luck.

    Went into the registry and changed the restrictanonymous setting in Controls/LSA, but no go. I've also uninstalled and reinstalled file sharing, shut off the firewall, played round with NetBios and ran network wizard X number of times...

    I can ping the computer with no problems, I just can't see any shares or access it through the workgroup.

    I feel like I've tried just about everything, so I'm open to suggestions!
    You're right, it sucks big time.
    Thanks again.
  17. Decker74

    Decker74 TS Rookie


    I finally can access the computer 2 after creating a network setup disc on 1 and running it on 2 (2 was the one that ran System Mechanic).

    My only problem is that it is not consistent.
    1 takes forever to find two, and when it does, it first tells me I do not have permission to access it. Afterwards, I can get in, until I am dropped again.

    I have other devices that I can't run the setup on (Xbox), so I'm at a loss.
    I still haven't quite figured out what SM did to my settings.

    Thanks for any help.
  18. nickc

    nickc TechSpot Paladin Posts: 923   +11

    it might help to unshare all folders on the two computers reboot both then go back and share again.
  19. nedsram

    nedsram TS Rookie

    You and me both

    I'm afraid I don't have a solution - I also have a similar problem to you. So I am not alone. :mad:

    I bought System Mechanic 6 after it was offered at a special price by Zonealarm. I ran it on one PC (XP home) in my Intranet. Like you, it said that my PC had "critical security flaws" and I let it analyse them. I was expecting a three step process:

    1. Analyse the PC's security.
    2. Report any problems found and allow the user to select which ones to fix.
    3. FIx selected problems.

    No such luck. It just went in there and made a series of changes. No details of what it changed or a log file.

    Now this PC's network drive was "invisible" to other PCs on the Intranet, although it could still access network drives on other PCs.

    The obvious way to solve the problem was to roll back to an earlier system restart point. I did this and managed to recover partially from the problem. The network drive was now visible, but all files were "read only", even though the sharing information said that other users had full access. Unchecking and rechecking "allow network users to change my files" fixed that. OK now I thought, although I was mystified how the network drive settings had become "out of sync" like this.

    Unfortunately I had overlooked that System Mechanic had installed a "repair" service which ran overnight, so the next day it was broken again. Now I can't use system restore either, as every attempt fails for some reason. I ran the Ethereal packet sniffer on both PCs, and the PC was receiving NETBios session connect requests, but just ignoring them. I must have wasted hours trying to resolve this problem.

    I too would be most grateful for any help. In previous situations like this it has turned out that some relevant settings had been changed but others not, so the system was in an inconsistent state. However I have no real idea where to look. I'd prefer not to have to reinstall XP!
  20. nedsram

    nedsram TS Rookie

    Problem solved

    I have restored connectivity to my network drive. To do this I used two tools:

    1. Ethereal network packet analyser. This told me that the NetBIOS session requests were being received, but simply being discarded. As Windows firewall was off, ZoneAlarm wasn't blocking them, and NETBios and TCP/IP were apparently set up correctly for the LAN connection, this suggested - as I think we had all figured out - that the offender was a registry setting (or two).

    2. WinMerge is a very useful file comparison utility, although it does struggle comparing two registry files which are each 600kb long. :p I had a detailed look at all of the settings relating to networking, and where any of the values had been changed since I installed System Masochist 6, I did a Google search to see what the value was used for. This only took me two days. :evil: I found that it had changed values in two relevant keys. Usual caveats about backing up the registry first apply:


    NoNameReleaseOnDemand was set to 1. Not previously present. This tells the PC not to reveal its NETBios name over the network. Delete this value. Setting it is a protection against DOS attacks. Unfortunately it breaks the negotiation protocol between two LAN hosts, and it is not appropriate to set it in a LAN environment.


    Set restrictanonymous to 0 (don't limit access to share information), restrictanonymoussam to 1 (prevent enumeration of SAM accounts) and everyoneincludesanonymous to 0 (allow null sessions but they have no privileges).

    Restrictanonymoussam has already been discused in this thread.

    Hope this helps others. Meanwhile perhaps iolo could start thinking as users rather than geeks when designing software. Many of the "security issues" they identify are not issues in a LAN behind a router, but requirements. They need to establish how the PC is being used before blundering in there and messing things up. They also need to provide the user with details of what they propose to change, and also the option not to proceed with the changes, rather than play god. They could also learn a thing or two about user interfaces. I've never seen anything as clunky and opaque in all my life. :mad:

    Have a nice Christmas - well what's left of it. :(

  21. FireDoc

    FireDoc TS Rookie

    Yep, SysMech6, well, you know


    Your correct in saying SysMech6 is the pits. I purchased the Pro version L.

    First thing it does is change automatic updates that were off to on - When your settings are off it "warns" you that you have security flaws. Yea, right!

    The defragmenter made a mess of a 0% fragmented HardDrive. Ended with 49% fragmentation when SM6L was done with it.

    None of the computers could access the computer that had SM6 - all other computers still had SM550. The SM6 computer has a network printer attached - that did not work either. File sharing did not work.

    When scanning for registry or file cleanup and you set review to on before action is performed - it does a double scan - one to find problems and does a second to remove them. Double time.

    Soooo, on the phone to Iolo - the tech took the issues of the defrag well and he did get back to me about networking issues - don't let SM adjust anything with networking. They emailed me back with a link to version N. Well, off went a real nasty email - sending out a product that has ovious flaws - I offered to be a test rat for them - here came the arrogant customer service iolo professionals gendra - I hung up on him.

    Went back to 550. All is well after a few cleanups.

    Well, today I thought I would try the lates SM6Q. Things seem better - but they made a mess of a good thing. 550 in all aspects is better - from operational routines that actually did good to your computer and and a much nicer GUI. I'm testing out some things on 6Q, and in almost every step of looking through the programs abilities and how they perform gives me, again, more and more reason to uninstall and go back to 550.

    Honestly, if you have a beef with this or any other program - take the time to call or email them. We are not their beta testers when we purchase a product.

    When was the last time a product release came out that went from version 6, 6a, 6b,... 6l, 6m, 6n,... now 6q in just a few months.

    When I started the installation of version 6N, and before any installation occurred - the installer went to the iolo web site and got the lastest version 6Q. This version repairs the networking issues. So, if you intend to keep v6 on your computer or not - install version 6Q - it repairs the issues on installation - do NOT run any of its programs if you intend to uninstall it - go back to v550.

    Good Luck
  22. Nethog

    Nethog TS Rookie

    Well I am extremely frustrated with the result of running the System Mechanic 6 demo. At one point I was actually quite impressed and was going to purchase the software until I realized that it prevented all netbios access to the computers where I ran it (2 out of 3 on my home lan). I can still connect to the 3rd computer on which I did NOT run SM6. All computers are loaded with XP pro. By the way, all TCP/IP networking is still completely OK.

    I have tried editing the registery settings that nedsram mentioned but this did NOT work for me.

    I have tried uninstalling and reinstalling file & printer sharing. I re-ran the XP network setup wizard. I have turned off the windows XP firewall (and no other firewalls on any computer, except my router of course). I have verified that all computers are named and share the same workgroup. I have checked that folder shares have been created. I have tried connectiig using Run \\ip_address which did not work. In the WINS tab of TCP/IP I have checked that NETBIOS over TCP is on. I have tried undoing the SM6 changes. I have sent iolo a help request 2 days ago but have not heard from them. I have Googled the internet for information on this issue and did not come up with much except this thread.

    If anyone has any ideas of how I can restore my network folder access I would sure appreciate it. I would hate to be forced to reload XP due to running the SM6 demo!
  23. nedsram

    nedsram TS Rookie

    I'm sorry that my fix didn't work for you. I can't recall the details of what I did any more, but I do remember that at one point my shared drive was in an inconsistent state. Try unsharing and resharing it and see if that fixes it.

    I assume that file and printer sharing is enabled for your connection.

    Let me know if that helps.

  24. Nethog

    Nethog TS Rookie

  25. jonttt

    jonttt TS Rookie


    just undo the changes that system mechanic made in the security section of the program. Go to maintain, inspect, undo changes and undo events under security. This solved the problem for me.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...