The ever popular "PC won't boot" thread

Not open for further replies.
Sorry to do this to the regulars round here but i've spent a day and 1/2 trying to sort this problem out. I was fiddling round with my main self build pride and joy computer. I was using my wacom tablet and noticing that on each touch the computer was making a sound. Not usual. So i turned it off cuz it was being a little ***** not loading Cubase projects anyway. Turned it back on and restarted it some (as it usually sorts out the cubase error)...
I had the bright spark of, whilst it was off i'd attach my older HDs and do some data recovery. It wouldn't boot after this.
I've trawled this forum for answers but i can't get anything similar to:
I turn the power on at PSU and get the famous high pitched antec tone. Go to power button and nothing... Now there is an LED on the MOBO alight but nothing else is happening.
what i've tried.
Holding the button for longer.
power tutorial on this site
Stripping none essential parts...(CDrom etc)
I've also plugged in a lower PSU which also isn't able to fire up the machine...
I've read there are Power issues with ANtec PSUs but this has been working fine for over a year now....(or is that the answer)
Its feels like its the bloody on button. Like its decided to have a faulty connection all of a sudden....
I must sleep now as i've got a headache and this is depressing me.
yeah i've read through and tried that sir.
i'm wondering if there's anything in the fact that the light is on on the MOBO.
I'm not there is not one sign of life when I hit the On button
if that is the case then read the thread again. it will tell u more than anyone will go into as a first start.
Not open for further replies.