The Mother of all USB Port problems

By Garlock ยท 7 replies
Sep 13, 2006
  1. OK. So I've perused a bunch of the "USB Ports not working" issues here on the forums, and also on most of the internet. I believe that I have a problem that is unique, and is easily the most frustrating issue that I've ever encountered.

    Before I start, here is my system config:
    OS: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
    BIOS: BIOS Date: 03/15/04 22:33:44 Ver: 08.00.09
    Mobo: ASUS p4p800se
    Processor: Intel(R) Pentium(R) 4 CPU 2.80GHz (2 CPUs)
    Memory: 1022MB RAM
    Video Card: NVIDIA GeForce4 Ti 4600
    Sound Card: EMU - EmulatorX
    USB Devices
    + USB Root Hub
    | Vendor/Product ID: 0x8086, 0x24D4
    | Matching Device ID: usb\root_hub
    | Service: usbhub
    | Driver: usbhub.sys, 8/3/2004 23:08:44, 57600 bytes
    | Driver: usbd.sys, 8/4/2004 05:00:00, 4736 bytes

    If you need more info, please let me know.

    This computer has been solid as a rock ever since I put it together a few years back.

    - Recently I reformatted the C: Drive.
    - I have a USB mouse.
    - I then proceeded to do windows updates.
    - While windows was updating, I transferred some music to my PSP.
    - After one of the windows reboots, I noticed that my mouse had stopped working.
    - I figured that it was the mouse that had failed since it's about 5 years old at this point, and I grabbed another nearby mouse which was also USB.
    - this mouse did not work either.
    - I then tried the first mouse in another computer, and it worked fine.
    - After some initial Plug n Play testing, I found that windows no longer registered any devices that were plugged into the USB ports, yet any device that had a power light; lit up.
    - I then uninstalled the USB Hubs etc. from the device manager and restarted the computer.
    - When Windows rebooted, it reinstalled all of the USB Hubs.
    - When I attached any USB device, the power light came on, but WinXP did not "see" it.
    - I then reformatted and reinstalled windows.
    - Windows STILL did not find any USB devices that I plugged into the ports.
    - I then went into the BIOS to make sure that USB had not been turned off somehow - it had not.

    Devices that power up from USB, but are not found by windows:
    - PSP
    - various mice
    - Wacom tablet
    - External DVD Burner
    - Thrustmaster Joystick

    My MoBo has 8 USB ports, and all of them power on USB devices, but do not register them in windows. 2 of the ports are in the front, 4 are attached directly to the MoBo, and 2 are on a joystick/USB daughter card that came with the MoBo.

    Does ANYONE have any ideas? I'd like to use my accessories again :) Thanks for any help that you can give.
  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    A simple check.. Boot up some CD Linux distribution like Knoppix or INSERT. If your USB mouse works there, then your hardware is OK.

    Can you do a system restore back to before you installed those Windows updates? It wouldn't be the first time a driver update from Microsoft messes up a system.

    Did you install the latest chipset drivers for your motherboard? Check both ASUS and Intel websites.
  3. Garlock

    Garlock TS Rookie Topic Starter

    I did install all of the chipset drivers, but the MoBo cd simply says that if you have XP, the USB drivers are native - so no USB drivers.

    Also, I tried a system restore before I formatted and reinstalled a second time, and nothing happened.

    With the 8 USB ports that I have is it likely that all of them have the same problem? After all, 4 of them are soldered to the MoBo, and the other 4 are connected to it elsewhere.

    I'm also wondering why I get power out of the USB ports (ie Mice light up and power lights come on on the wacom tablet) but they don't register.

    OK as far as linux goes, it's all new territory for me. Is there a site where I can get not only the files, but a simple tutorial? Yahoo search gives me LOTS of hits on knoppix.

    Thanks for the help.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Just download and burn the Knoppix ISO image from Make sure you get the English version :)

    Boot from the CD. If you can move your mouse around on the desktop, then it obviously works.
  5. Garlock

    Garlock TS Rookie Topic Starter

    Sweet thanks. Will try when I get home.
  6. Garlock

    Garlock TS Rookie Topic Starter

    Ok, so I tried the whole Knoppix thing.

    I watched the startup sequence, it said "checking for USB... Detected" Then it detected firewire and a few other things - including a creative audigy that I don't even own, let alone have in the offending computer. It went through some other items, but apparently I don't have a supported video card and some files failed to decompress.

    There was a whole slew of errors after that.

    So, as cool as it might be to troubleshoot Knoppix for a few days, I'd rather spend that time trying to get my USBs to respond again.

    Thanks for all of you help. Do you have any other ideas?
  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Files failed to decompress? Probably a faulty burn or ISO damaged during download..

    You could always reformat again and see if the USB works in fresh Windows. Then pay attention to what updates you are applying and which one breaks the thing.
  8. Garlock

    Garlock TS Rookie Topic Starter

    I've already formatted again after the USBs broke - it didn't fix the problem.

    Thanks anyway. Told you it was the mother of all problems ;)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...