Toshiba dvd drive not working, has a yellow "!" on it

By Leo808 ยท 8 replies
Mar 6, 2008
  1. Hello, I found this forum because a person posted exactly the same problem I am having back in 12/13/2005. I tried what "iss" said to do in the response to that original email but it didn't work. Before I looked my problem up on the internet I ran the troubleshooter and it said that "Windows successfully loaded the device for this hardward but cannot find the hardware device. (code 41)" I have no clue as to what to do or where to go to find it. It would make me so happy if someone out there could help me solve this nightmare. thanks, leo
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    First, back up your registry. Go to Start>Run>regedit>Ok. Now you'll have a white window sitting in front of you. Click File>Export and then save it anywhere with whatever name you care to.

    After that, download the attachment below, unzip and execute it. Restart your PC and see if the problem is solved. Post back with your results.

    Attached Files:

  3. Leo808

    Leo808 TS Rookie Topic Starter

    It Worked

    Thank you so very much, as we say in Hawaii, u da bes (you are the best) I just wish I knew what happened but because I'm not a real techie it would just go over my head anyway. So all I can say is thanks. Aloha, Leo808
  4. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    No problem ;). As we say in Pennsylvania, you're welcome :D!
  5. Leo808

    Leo808 TS Rookie Topic Starter

    Heh Zenosincks, I hope you are still around. The same thing happened again. Let me really explain how it started. My ipod was not working right and I hit a button on the bottom right hand side of task bar (on the quick launch). From there things went down hill. The suggestion from the ipod help was to uninstall and reinstall the ipod program so I did but before I did that I tried to save my music library on cds. I thought I had everything on disk so I went ahead and deleted everything, including my library. When I tried to reinstall everything that's when I realized I must have done more damage then I started off with. It's now saying I still don't have the dvd/cd engaged, the yellow ! is back at the device manager. I get a Fatal Error message when I tried to reinstall my ipod program. And on top of all of that my music library didn't get saved on disk. I really need your help!
  6. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    :( Oh no.

    Post any and all errors that you can (the entire message with an error number if possible).

    There are thousands of people strolling through here, the majority of them probably more knowledgeable than myself, I am learning by the second and I am sure that someone else will have a great suggestion for you :).
  7. Leo808

    Leo808 TS Rookie Topic Starter

    That's okay Zenosincks, I redid what you told me to do about saving the reg. and then downloading that download again and it worked. I don't know what happened to my ipod and everything else but at least my dvd device is back on track. So thanks so much again.
  8. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Haha, well you're welcome x2 :D...
  9. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Uh.. what?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...