Toshiba Satellite can not go into BIOS

By Albert Oga
May 19, 2016
Post New Reply
  1. I have a toshiba satellite C55-B5201, windows 8.1.
    I tried to go into bios by pressing fn, f2 to f12 but still bios is not displayed. It always displays log on windows.
    I'd appreciate any help in getting into BIOS.

  2. Cycloid Torus

    Cycloid Torus Stone age computing. Posts: 3,003   +656

    Hold the F2 key down before you press the power button. It is hard to do it after the computer starts as it is busy getting started.
    Albert Oga likes this.
  3. Albert Oga

    Albert Oga TS Member Topic Starter

    I even tried that many times but still couldn't get to BIOS, so frustrating.
  4. bazz2004

    bazz2004 TS Evangelist Posts: 1,585   +250

    There's an alternative boot system called UEFI that started to appear with W8.1 that makes the start up much faster. I have no experience of this but the following link should get you going. If you have a conventional BIOS and the instructions haven't helped experiment with alternative keys.
    Cycloid Torus likes this.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...